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document was complete and accurate at the time of printing, Avaya Inc. can 
assume no liability for any errors. Changes and corrections to the information 
in this document might be incorporated in future releases.

Documentation disclaimer
Avaya Inc. is not responsible for any modifications, additions, or deletions to 
the original published version of this documentation unless such modifications, 
additions, or deletions were performed by Avaya. Customer and/or End User 
agree to indemnify and hold harmless Avaya, Avaya's agents, servants and 
employees against all claims, lawsuits, demands and judgments arising out of, 
or in connection with, subsequent modifications, additions or deletions to this 
documentation to the extent made by the Customer or End User. 

Link disclaimer
Avaya Inc. is not responsible for the contents or reliability of any linked Web 
sites referenced elsewhere within this documentation, and Avaya does not 
necessarily endorse the products, services, or information described or offered 
within them. We cannot guarantee that these links will work all the time and we 
have no control over the availability of the linked pages.

Warranty
Avaya Inc. provides a limited warranty on this product. Refer to your sales 
agreement to establish the terms of the limited warranty. In addition, Avaya’s 
standard warranty language, as well as information regarding support for this 
product, while under warranty, is available through the Avaya Support Web 
site:
http://www.avaya.com/support 

License
USE OR INSTALLATION OF THE PRODUCT INDICATES THE END USER'S 
ACCEPTANCE OF THE TERMS SET FORTH HEREIN AND THE GENERAL 
LICENSE TERMS AVAILABLE ON THE AVAYA WEB SITE 
http://support.avaya.com/LicenseInfo/ ("GENERAL LICENSE TERMS"). IF 
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Avaya grants End User a license within the scope of the license types 
described below. The applicable number of licenses and units of capacity for 
which the license is granted will be one (1), unless a different number of 
licenses or units of capacity is specified in the Documentation or other 
materials available to End User. "Designated Processor" means a single 
stand-alone computing device. "Server" means a Designated Processor that 
hosts a software application to be accessed by multiple users. "Software" 
means the computer programs in object code, originally licensed by Avaya and 
ultimately utilized by End User, whether as stand-alone Products or 
pre-installed on Hardware. "Hardware" means the standard hardware 
Products, originally sold by Avaya and ultimately utilized by End User. 

License type(s)
Concurrent User License (CU). End User may install and use the Software on 
multiple Designated Processors or one or more Servers, so long as only the 
licensed number of Units are accessing and using the Software at any given 
time. A "Unit" means the unit on which Avaya, at its sole discretion, bases the 
pricing of its licenses and can be, without limitation, an agent, port or user, an 
e-mail or voice mail account in the name of a person or corporate function 
(e.g., webmaster or helpdesk), or a directory entry in the administrative 
database utilized by the Product that permits one user to interface with the 
Software. Units may be linked to a specific, identified Server.

Copyright 
Except where expressly stated otherwise, the Product is protected by copyright 
and other laws respecting proprietary rights. Unauthorized reproduction, 
transfer, and or use can be a criminal, as well as a civil, offense under the 
applicable law.

Third-party components
Certain software programs or portions thereof included in the Product may 
contain software distributed under third party agreements ("Third Party 
Components"), which may contain terms that expand or limit rights to use 
certain portions of the Product ("Third Party Terms"). Information identifying 
Third Party Components and the Third Party Terms that apply to them is 
available on the Avaya Support Web site:
http://support.avaya.com/ThirdPartyLicense/ 

Preventing toll fraud
"Toll fraud" is the unauthorized use of your telecommunications system by an 
unauthorized party (for example, a person who is not a corporate employee, 
agent, subcontractor, or is not working on your company's behalf). Be aware 
that there can be a risk of toll fraud associated with your system and that, if toll 

fraud occurs, it can result in substantial additional charges for your 
telecommunications services.

Avaya fraud intervention
If you suspect that you are being victimized by toll fraud and you need technical 
assistance or support, call Technical Service Center Toll Fraud Intervention 
Hotline at +1-800-643-2353 for the United States and Canada. For additional 
support telephone numbers, see the Avaya Support Web site:
http://www.avaya.com/support 

Trademarks
Avaya and the Avaya logo are either registered trademarks or trademarks of 
Avaya Inc. in the United States of America and/or other jurisdictions.
All other trademarks are the property of their respective owners.

Downloading documents
For the most current versions of documentation, see the Avaya Support Web 
site:
http://www.avaya.com/support 

COMPAS
This document is also available from the COMPAS database. The COMPAS ID 
for this document is 125770.

Avaya support
Avaya provides a telephone number for you to use to report problems or to ask 
questions about your product. The support telephone number 
is 1-800-242-2121 in the United States. For additional support telephone 
numbers, see the Avaya Support Web site:
http://www.avaya.com/support 
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Preface

This section contains the following topics:

● Purpose on page 11

● Audience on page 11

● Reasons for reissue on page 11

● Related documents on page 12

Purpose
This document, Avaya IP Agent Installation and User Guide, includes information that you need 
to know in order to install and use Avaya IP Agent Release 7 (IP Agent R7). It also provides 
information on IP Agent R7 features, basic operation, and administrative tasks.

Audience
This guide is intended primarily for anyone who is installing or using IP Agent R7 and 
performing station administration on an Avaya MultiVantage system or Avaya Media Server 
using Avaya Communication Manager. It assumes that you are familiar with the following items:

● The personal computer on which Avaya IP Agent R7 will be installed and run

● Microsoft Windows XP Professional or Windows Vista Business, Enterprise, or Home 
Premium

● Standard Windows conventions and terminology

● Contact center configurations and operations

Reasons for reissue
This release of Avaya IP Agent Installation and User Guide includes the following new topics:

● Microsoft Installer (MSI) technology
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● Enhanced configuration administration

● Third party application launch from within IP Agent R7

● Wireless headset support

● Feature enhancements

● Notes and information related to IP Agent R7 operation on Windows Vista

See New features for Avaya IP Agent Release 7 on page 14 for a complete listing of the 
enhancements for IP Agent R7.

Related documents
The following documents can help you configure your Avaya communication server for use with 
Avaya IP Agent R7:

● Administrator’s Guide for Avaya MultiVantage Software

● Administrator Guide for Avaya Communication Manager
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Chapter 1: Introduction

This chapter provides introductory and basic information about Avaya IP Agent.

This chapter includes the following sections:

● What is Avaya IP Agent? on page 13

● New features for Avaya IP Agent Release 7 on page 14

● Avaya IP Agent configurations on page 19

● Compatible telephone types for Avaya IP Agent on page 24

● Network compatibility on page 28

● Voice-over-IP considerations on page 28

What is Avaya IP Agent?
Avaya IP Agent is a software application with advanced telephony features for agents in a 
contact center. Agents can use it to work in the following methods

● On-site at the contact center

● On-site or off-site using Voice over Internet Protocol (VoIP)

● Off-site using analog connections over a Public Switched Telephone Network (PSTN)

The advanced telephony features are controlled by Avaya IP Agent through its direct 
communication with an Avaya communication server.

Agents who are not located at the contact center can connect to the Avaya communication 
server in the contact center and receive calls as if they were present at their contact center 
workstation. For example, if an agent cannot travel to the contact center because of 
transportation problems or weather conditions, the agent can still take calls by using Avaya IP 
Agent to connect to the Avaya communication server.

This section contains the following topics:

● New features for Avaya IP Agent Release 7 on page 14

● Avaya IP Agent features on page 15



Chapter 1: Introduction

14 IP Agent R7 Installation and User Guide August 2007

 

New features for Avaya IP Agent Release 7
The following is a list of the new features for Avaya IP Agent Release 7 (IP Agent R7):

● Enhanced security - IP Agent enables enhanced desktop security. See Avaya IP Agent 
features on page 15

● New installation program - IP Agent R7 includes an entirely new installation program 
based on Microsoft Installer (MSI) installation technology. This program provides fully 
interactive and silent installation options. See Installing Avaya IP Agent for PC-based 
configurations on page 63.

● Launch toolbar - In IP Agent R7 the Launch toolbar provides the ability to centralize and 
organize third party application tools on the Avaya IP Agent main application window. You 
can also use the new ipaDialer program to configure speed dial buttons on the Launch 
toolbar. The Launch toolbar supports up to 23 customizable launch items. See Configuring 
the Launch toolbar on page 87.

● Web Dialer - IP Agent R7 adds new "Click-to-dial" functionality to the Web Dialer context 
menu that allows you to quickly dial highlighted telephone numbers in a Windows Explorer 
window. See Using the Web Dialer context menu item on page 169.

● Configuration Administration - In IP Agent R7 new functionality allows you to define and 
export configuration information for use on other PCs, or import previously defined 
configuration information to set local parameters. See Configuring an IP Agent *.reg file 
with Configuration Administration on page 92.

● Agent greetings - IP Agent R7 increases the default number of agent greetings to 60. 
See Agent Greetings on page 171.

● Audio feature access restrictions - In Release 7, selection access to the Audio Tuning 
Wizard, Audio Options and Audio Monitor can be restricted. These audio features are 
normally accessible from the Audio menu on the main application window. See Audio 
menu on page 213.

● Expanded dial plan - A new Program Options Feature is introduced in IP Agent R7 to 
allow multiple or combination dial plans to be defined to handle internal calls. See Internal 
Dial Plan panel on page 234.

! Important:
Important: For a phone number to be correctly reformatted and stored in the application 

database, the enabled dial plan option must be set prior to accepting or 
generating calls or creating contact phone numbers.

● Avaya Bluetooth Integrator - With IP Agent R7 (on Windows XP only) you can use 
Bluetooth-enabled headsets to answer, mute and release calls. The Bluetooth Integrator is 
available in the Road Warrior configuration only. See IP Agent Bluetooth Integrator on 
page 285. 
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● Crash analysis support - In the event an unhandled exception occurs in IP Agent, a pair 
of new files are generated in the application data \Log Files folder. See Diagnostic log 
files on page 269.

● Support of high definition audio chipsets - All IP Agent R7 features that depend on 
support of the underlying PC sound system are now compatible with the IntelR High 
Definition Audio14 chipset standard and the drivers that support it.

● Encrypted signal link - IP Agent R7 supports encryption of the signal link between IP 
Agent R7 and the serving Communication Manager (CM). This security option must be 
configured in compliance with the CM administered settings for the network region 
definition to which the extension being registered belongs. See your CM documentation for 
details.

Avaya IP Agent features 
The following lists provide the main features that are available in Avaya IP Agent:

Available configurations and supported communication servers
● Support of Avaya MultiVantage, and Communication Manager systems.

● Road Warrior configuration (Voice-over-IP) - Agents can connect to the Avaya 
communication server by using their personal computer and an IP network connection. In 
this configuration, a telephone set is not necessary because all communication is 
performed through a sound device of the personal computer.

● Telecommuter configuration - Agents using an analog or Digital Communication Protocol 
(DCP) telephone can use the advanced call features provided by the Avaya 
communication server. For example, an agent working from home can use Avaya IP Agent 
and their home telephone to transfer calls, place calls on hold, change agent work mode, 
and do other call center activities.

● Avaya Callmaster VI configuration - Avaya IP Agent running on Windows XP supports 
usage of Avaya Callmaster VI telephones. Sections of this document address 
configuration and usage of Avaya Callmaster VI telephones.

● Instant Messaging Only configuration - Avaya IP Agent does not register with an Avaya 
communication server for telephony capabilities, but does register with SIP Enablement 
Services for the purpose of instant messaging.

● IP Telephone configuration - Agents using an IP telephone can use Avaya IP Agent in the 
same manner as with the Telecommuter configuration. Features that are assigned to the 
extension can be used through the Avaya IP Agent user interface. In this configuration, 
Avaya IP Agent logs in to the telephone itself.
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● Avaya Telephone-DCP configuration - Agents using a Digital Communication Protocol 
(DCP) telephone in the contact center can use Avaya IP Agent to share control of the 
telephone and its features. While the Avaya Telephone-DCP configuration is similar to the 
Telecommuter configuration, it cannot use a telephone number that is different from the 
extension. For agents that are in the same location as the communication server, this 
configuration, unlike the Telecommuter configuration, does not require the creation of a 
second station on the Avaya communication server. This configuration is supported with 
Avaya Communication Manager 2.1 or later.

● Avaya Telephone-IP configuration - Agents using an IP telephone in the contact center can 
use Avaya IP Agent to share control of the IP telephone and its features with the Avaya 
communication server. While the Avaya Telephone-IP configuration is similar to the 
Telecommuter configuration, it cannot use a telephone number that is different from the 
extension. In this configuration, Avaya IP Agent logs in to the communication server, not 
the telephone as in the IP Telephone configuration.

● Windows Terminal Services compatibility - Those contact centers that use Windows 
Terminal Services can use a special version of Avaya IP Agent to facilitate usage of the 
Telecommuter configuration in that environment.

Call and contact center features
● VuStats support - Avaya IP Agent can display multiple lines of VuStats information in the 

VuStats Monitor dialog box. You can use VuStats information to assist in complete 
monitoring of the contact center.

● Agent greetings - Agents can record and configure multiple agent greetings based on such 
variables as login status, agent work mode, agent ID, prompted digits, Automatic Number 
Identification (ANI), or Vector Directory Number (VDN). Agent greetings are available in 
the Road Warrior and Callmaster VI configurations. Using an Avaya Switcher II headset, 
(on Windows XP only) agent greetings can also be used in the Telecommuter 
configuration. For those call centers that want to have standard greetings for all agents, 
agent greetings can also be stored on network drives.

● Support for dynamic Quality of Service (QoS) - If the QoS parameters have not been 
configured on the personal computer for an IP Endpoint configuration, Avaya IP Agent 
downloads the QoS parameters configured on the Avaya communication server and 
configures the IP Endpoint. QoS is by default automatically installed by Avaya IP Agent. 
You can choose to not install QoS by deselecting it on the Custom Setup page of the 
installation program.

● Emergency Call Handling Service (E911) - With this feature, agents using IP Endpoints 
can use numbers that connect to emergency services, such as 911 in the United States. 
Only those emergency services in the Public Safety Answering Point area where the 
Avaya communication server is located can be reached. Agents or extensions in remote 
locations should not use this feature for emergencies.

● External Number Formatting - For international users, Avaya IP Agent allows you to define 
how many digits are present in telephone numbers outside the contact center.
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● User-to-user information (UUI) screen pop enhancement - Using external applications, 
unique identifiers can be added to incoming calls. If your Avaya communication server has 
the correct features and configuration, these identifiers can be passed to Avaya IP Agent 
and used in screen pops for agents.

Contact management features
● Contact history - Avaya IP Agent records a complete contact history of incoming and 

outgoing calls, even for those calls where the caller does not leave a voice message. This 
feature also records the time and date of all instant message sessions.

● Contact Directory- Avaya IP Agent provides a customizable contact directory that lists 
telephone numbers, e-mail addresses, and instant messaging user names for each 
contact.

● Search Public Directory - With this feature, agents have the ability to search through public 
or company information using the Lightweight Directory Access Protocol (LDAP).

● Screen Pops - Screen Pops can be initiated when a call is received or placed. Avaya IP 
Agent provides agents with the ability to display Web pages, start applications, or retrieve 
and display caller information from a database. Screen pops are created using the Screen 
Pops Wizard, which guides you through their creation. A screen pop can consist of any 
process or application that can be initiated through one of the commands in the following 
list:

- Windows executable or registered file type activation
- Dynamic Data Exchange (DDE) "Execute" or "Poke" commands

Usability features
● Clipboard dialing - Avaya IP Agent can be used to dial any number copied to the clipboard 

or, in most personal computer applications, used to dial a number that an agent highlights 
by right-clicking on the Avaya IP Agent icon in the System Tray.

● Enhanced Phone features - The Phone Features window displays all of the features that 
have been assigned to the station. Through this window, users can arrange these features 
into custom folders to fit their needs and maximize usability.

● Enhanced System Tray icon - The Avaya IP Agent icon in the System Tray contains 
release, drop, hold, transfer, conference, and agent work mode functions.

● Automatic login - An agent can automatically log in to the Avaya communication server 
when Avaya IP Agent is started. Avaya IP Agent uses the login information from the 
previous login.

● Speed dialer - Agents can assign telephone numbers to function keys (F2 through F8) so 
that the agent can dial the telephone number simply by pressing the associated key.

● Voice message icon - When voice messages are present for the extension currently in 
use, an icon is displayed in the System Tray. When it has been configured, you can click 
on this icon to connect to your voice mail system.
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● Alternate user interfaces - These interfaces can be used in place of the standard interface. 
These alternate interfaces use much less space on your desktop, and then can eliminate 
the problem of the previous Avaya IP Agent interface being hidden behind other 
applications or requiring too much space on the desktop.

Security and management features
● Silent installation - In Avaya IP Agent R7, installations without user interaction are 

accomplished through the use of MSI command-line parameters.

● Media encryption - The Avaya iClarity IP Audio component of Avaya IP Agent encrypts 
communication between itself and the Avaya communication server. This provides a 
reassuring level of security in communications conducted over your contact center 
network.

● Feature deactivation - Administrators can deactivate Avaya IP Agent features that should 
not be configured or used by agents. The features that can be deactivated include Screen 
Pops, Contact Directory, Public Search Directory, Contact History, Phone Features 
configuration, Program Options, Speed Dials, VuStats, Agent Greeting selection, Launch 
toolbar, Audio Monitor, Audio Options, Audio Tuning Wizard, Configuration Admin, 
Desktop Integration, Import settings, and Export settings.

● Configurable database location - You can change the location where the Avaya IP Agent 
database is stored. This database contains the contact directory and the contact history 
information.

● Support for Virtual Private Networks (VPNs) - The Avaya iClarity IP Audio component 
supports substitution of SHIM-based IPSec client addresses for the local IP address within 
H.323 signalling messages.

● Alternate Gatekeeper - When an agent registers an IP Endpoint with an Avaya 
communication server, a C-LAN circuit pack IP address is sent by the server to the IP 
Endpoint. If registration is successful, the Avaya communication server sends back the IP 
addresses of all the C-LAN circuit packs in the network region. These addresses can be 
used if call signaling on the original C-LAN circuit pack fails.

● Support for server load balancing across gatekeepers - Registration and usage of Avaya 
communication servers can be distributed across multiple C-LAN circuit packs within a 
network region. This increases performance and reliability for all IP Endpoints.

● Application updates - This feature can be used to search for updates to Avaya IP Agent. 
During each start of Avaya IP Agent, the Uniform Resource Locator (URL) address 
specified is searched. If an update is found, it is installed. This feature saves time and 
effort for administrators because they do not need to visit each installation or create 
remote administration scripts through third-party applications.
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● Secure operation - Best practice has developed such that Microsoft Windows Desktop 
applications are designed to run with the most restrictive user privileges possible. In 
particular, they should not be required to run unrestricted with Administrator privileges. IP 
Agent R7 can write only to the current user Documents folder \Documents and Settings\
<user>\Application Data\Avaya\Avaya IP Agent\, and can only modify the Current User 
registry hive.

Avaya IP Agent configurations
Avaya IP Agent supports the following configurations:

● Road Warrior configuration (Voice-over-IP) on page 19

● Telecommuter configuration on page 20

● IP Telephone configuration on page 21

● Callmaster VI configuration (DCP connection) on page 22

● Avaya Telephone control by the server on page 22

● Instant Messaging on page 24

Road Warrior configuration (Voice-over-IP) 
Use the Road Warrior configuration in situations where an agent at a personal computer can 
make a dial-up or network connection to an Avaya communication server. This configuration 
does not use a telephone, which, obviously, is valuable when a telephone is not available. The 
single network connection between the personal computer running Avaya IP Agent and the 
Avaya communication server has two channels, one for signaling (data) and one for voice. 
Avaya IP Agent controls the data flow while the iClarity IP Audio (an H.323 V2-compliant audio 
application) handles voice communications. This type of configuration provides the best IP 
audio quality that is possible with your connection speeds, personal computer performance, and 
network setup. Agents make and receive calls through the Avaya IP Agent interface using a 
headset connected to the personal computer or optionally through a Bluetooth hardware 
configuration (on Windows XP only).

What you need to know about Road Warrior configuration

The following list provides the Road Warrior configuration requirements and capabilities:

● Connection - One dial-up or network connection from the personal computer running 
Avaya IP Agent to the Avaya communication server

● Personal computer hardware
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- Sound card (full-duplex recommended) or Universal Serial Bus (USB) headset
- Modem or network interface card for connectivity to the Avaya communication server

Note:
Note: For detailed information on supported hardware, see the listings for IP Softphone 

at http://support.avaya.com.

● Telephone - Not supported in this configuration

● Bluetooth - Optional third party hardware required (for use on Windows XP only)

● Voice quality - Dependent on the performance of the personal computer hardware, the 
amount of bandwidth available in the network connection, and network stability

● Agent greetings - Stored on the personal computer or a network drive

● Avaya communication server connections - One user connection

Note:
Note: Voice-over-IP does not necessarily provide toll-quality audio.

Telecommuter configuration 
Use the Telecommuter configuration in situations where a personal computer can make a 
dial-up or network connection to an Avaya communication server for the signaling (data) path 
and a voice path to a telephone sent through a Public Switched Telephone Network (PSTN) 
connection. The telephone can be an analog telephone, a cellular telephone, or an extension on 
a local or remote switch. This configuration provides toll-quality audio and full telephony 
functionality through Avaya IP Agent. Agents make and receive calls through the Avaya IP 
Agent interface, and the voice path is sent to the specified telephone.

What you need to know about the Telecommuter configuration

The following list provides the Telecommuter configuration requirements and capabilities:

● Connection - One dial-up or network connection from the personal computer running 
Avaya IP Agent to the Avaya communication server and a telephone capable of receiving 
calls from the Avaya communication server

● Personal computer hardware - Modem or network interface card for connectivity to the 
Avaya communication server

● Telephone set - Any telephone capable of receiving calls from the Avaya communication 
server

● Agent Greetings - Supported only through the use of the Avaya Switcher II headset (not 
available on Windows Vista)

For information about using an Avaya Switcher II, see:

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf

http://support.avaya.com
http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf
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● Avaya communication server connections - One user connection for signaling connection 
and one of the following situations:

- For off-site use, one trunk connection
- For on-site use, an additional user connection

IP Telephone configuration 
The IP Telephone configuration is similar to that of the Telecommuter configuration. Through IP 
Agent, agents can control an IP telephone, use the features of the telephone through the IP 
Agent interface, and take advantage of the regular IP Agent features. 

What you need to know about the IP Telephone configuration

The following list provides the IP Telephone configuration requirements and capabilities:

● Connection - IP network connection for the IP telephone and a TCP/IP network connection 
for the personal computer

● Personal computer hardware - Network Interface Card (NIC) for connection to the Avaya 
communication server

● Telephone set - An Avaya IP telephone that supports the Computer Telephony Integration 
(CTI) feature and is supported by your Avaya communication server. See Compatible 
telephone types for Avaya IP Agent on page 24 for more information on supported Avaya 
IP telephones.

● Voice Quality - Dependent on the IP telephone, available network bandwidth, and network 
stability

● Agent Greetings - Supported only through the use of the Avaya Switcher II headset (not 
available on Windows Vista)

For information about using an Avaya Switcher II, see:

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf

● Avaya communication server connections - One user connection

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf
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Callmaster VI configuration (DCP connection) 
The Avaya Callmaster VI is a small telephone with eight buttons, two headset jacks, and DCP 
(Digital Communications Protocol) connectivity. This telephone is connected to a personal 
computer through a serial (RS-232) connection. This configuration is for use only inside the 
contact center in conjunction with Callmaster VI telephones. Connectivity for this configuration 
is provided through a DCP connection to the Avaya communication server and does not require 
a TCP/IP network connection. Callmaster VI telephones can only be used with IP Agent R7 
running on Windows XP. 

What you need to know about the Callmaster VI configuration

The following list provides Avaya Callmaster VI configuration requirements and capabilities:

● Connection - DCP connection for the Avaya Callmaster VI telephone set and a serial 
(RS-232) connection between the Avaya Callmaster VI and the personal computer

● Personal computer hardware - Serial (RS-232) port

● Telephone - Avaya Callmaster VI

● Agent greetings - Stored on the Avaya Callmaster VI telephone set

● Avaya communication server connections - One user connection

Avaya Telephone control by the server
This section includes information about Avaya Telephone control by the Avaya Communication 
Manager server, also called shared control. 

The Avaya Telephone configuration:

● Allows a telephone and IP Agent to share control of the same administered station using 
the same button layout and features.

● Supports Avaya DCP and IP telephones, but not analog sets.

● Eliminates the need to define a second extension on Avaya Communication Manager.

● Functions normally without Avaya IP Agent if the personal computer is not operational.

● Useful because the administration is simple and because IP Agent is a powerful 
complement to a regular telephone that enables screen pops, Instant Messenger (with SIP 
Enablement Services), Agent Greetings (with an Avaya Switcher II, Windows XP only), 
VuStats monitor, and so on.
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What you need to know about the Avaya Telephone configuration

The following list provides the Avaya Telephone configuration requirements and capabilities:

Connection : For shared control, you need one network connection from the personal 
computer running Avaya IP Agent to the Avaya Communication Manager system and an IP or 
DCP telephone that is connected to the Avaya Communication Manager system. For specifics, 
see the following table.

Personal computer hardware: Use a Network Interface Card (NIC) for connection to the 
Avaya communication server.

Telephone set: Use any of the following types of telephones:

● Avaya 2400-series (DCP)

● 4600-series (IP)

● 6400-series (DCP)

● Callmaster IV (DCP)

● Callmaster V (DCP)

Agent Greetings: Agent Greetings are supported only through the use of the Avaya Switcher II 
headset. (Not available in Windows Vista.)

For information about using an Avaya Switcher II, see:

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf

Avaya communication server connections: Use one connection for the telephone and one 
for IP Agent. 

IP telephones DCP telephones

4600-series telephones 2400-series telephones and 
6400-series telephones

Callmaster IV and V 
telephones

● IP Agent Release 5 or 
later

● Communication Manager 
2.1 or later

● IP Agent Release 5 or 
later

● Communication Manager 
2.0 or later

● IP Agent Release 6 or 
later on Windows XP

● Communication Manager 
3.0 or later

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf
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Instant Messaging
The Instant Messaging feature allows you to exchange text messages with other Avaya IP 
Agent users and track their online presence.

Additionally, you can use an Instant Messaging Only configuration where Avaya IP Agent 
does not register with an Avaya communication server for telephony capabilities, but does 
register with SIP Enablement Services for the purpose of instant messaging.

What you need to know about the Instant Messaging feature

The following list provides the Instant Messaging configuration requirements and capabilities:

● Connection - One network connection from the personal computer running Avaya IP Agent 
to the SIP Enablement Services 3.1 or later

● Personal computer hardware - Network Interface Card (NIC) for connection to the SIP 
Enablement Services

● Configuration compatibility - The Instant Messaging feature is compatible with the 
following Avaya IP Agent configurations:

- Road Warrior
- Telecommuter
- Avaya Telephone (DCP and IP)
- IP Telephone

Compatible telephone types for Avaya IP Agent
This section contains the following topics:

● Supported telephone types on page 24

● Recommended telephone types on page 28

Supported telephone types 

Note:
Note: When you change telephone types for a station, you must restart Avaya IP Agent 

for the change to take effect.
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The following table provides the telephone types that are available on the Avaya communication 
server and officially supported for use with Avaya IP Agent:

Telephone model Communication 
platform

Additional features

Callmaster IV (603F1) DCP ● 80-character (2x40) display
● Compatible with Avaya 

Telephone-DCP configuration

Callmaster V (607A1) DCP ● 48-character display
● Compatible with Avaya 

Telephone-DCP configuration

Callmaster VI (606A1) DCP ● 80-character (2x40) display
● Expansion module available

2410 DCP ● Multiline display
● Compatible with the Avaya 

Telephone-DCP configuration

2420 DCP ● 203-character display
● Expansion module available
● Compatible with the Avaya 

Telephone-DCP configuration

4602 IP ● 40-character display
● This telephone cannot be used 

in the IP Telephone 
configuration.

4606 IP ● 32-character display
● Use of this telephone with the 

Avaya Telephone-IP 
configuration requires Avaya 
Communication Manager 2.1 or 
later.

4610 IP ● 168x80 pixel display
● Supported only on Avaya 

Communication Manager 2.1 or 
later

● This telephone is not supported 
for Road Warrior or 
Telecommuter configurations.
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4612 IP ● 48-character display
● Use of this telephone with the 

Avaya Telephone-IP 
configuration requires Avaya 
Communication Manager 2.1 or 
later.

4620 IP ● 168x132 pixel display
● Expansion module available
● Use of this telephone with the 

Avaya Telephone-IP 
configuration requires Avaya 
Communication Manager 2.1 or 
later.

4622 IP ● 8 line display
● Expansion module available
● Use of this telephone with the 

Avaya Telephone-IP 
configuration requires Avaya 
Communication Manager 2.1 or 
later.

4624 IP ● 48-character display
● Use of this telephone with the 

Avaya Telephone-IP 
configuration requires Avaya 
Communication Manager 2.1 or 
later.

4630 IP ● 320x240 pixel display
● Use of this telephone with the 

Avaya Telephone-IP 
configuration requires Avaya 
Communication Manager 2.1 or 
later.

6402D DCP ● 32-character (2x16) display 
● Compatible with Avaya 

Telephone-DCP configuration

6408D / 6408D+ DCP ● 48-character display
● Compatible with Avaya 

Telephone-DCP configuration

Telephone model Communication 
platform

Additional features
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6416D+ DCP ● 48-character display
● Expansion module available
● Compatible with Avaya 

Telephone-DCP configuration

6424D+ DCP ● 48-character display
● Expansion module available
● Compatible with Avaya 

Telephone-DCP configuration

8403B DCP ● 48-character display

8405D / 8405D+ DCP ● 48-character display
● This telephone cannot be used 

with the Avaya Telephone-DCP 
configuration.

8410D DCP ● 48-character display
● This telephone cannot be used 

with the Avaya Telephone-DCP 
configuration.

8411D DCP ● 48-character display
● For this telephone set, you must 

disable the data port, which is 
true for all softphones

8434D DCP ● 80-character (2x40) display
● Expansion module available

9620 IP ● Part of Avaya one-X Deskphone 
family

9630 IP ● Part of Avaya one-X Deskphone 
family

● Supports up to one expansion 
module in IP Agent R7

9650 IP ● Part of Avaya one-X Deskphone 
family

● Supports up to one expansion 
module in IP Agent R7

Telephone model Communication 
platform

Additional features
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Recommended telephone types
While Avaya IP Agent supports all of the telephone types listed in the previous table for the 
Road Warrior and Telecommuter configurations, the following types provide the most buttons 
and features, and an 80-character display:

● 606A1

● 8434D

Because of the greater number of characters used for display, these telephone types are better 
suited to handle VuStats or Prompted Digits information.

Note:
Note: For the IP Telephone and Avaya Telephone configurations, these telephone types 

are only valid for use if these exact telephones are in use at the location of the 
agent.

Network compatibility
Avaya IP Agent provides support for several H.323-compatible firewalls and Virtual Private 
Networks (VPNs). For shim-based VPNs, you must use the Advanced tab in the Avaya iClarity 
IP Audio dialog boxes used for login to set an IPSec IP address, that is assigned by the VPN 
gateway and that is visible to the application on the personal computer. If you need assistance, 
contact Avaya technical support.

Avaya iClarity IP Audio only supports VPNs using Network Address Translations (NATs) that 
provide one-to-one IP address substitution. VPNs using NATs that provide many-to-one IP 
address substitution cannot be used with Avaya IP Agent.

Voice-over-IP considerations 
Voice communication through Internet Protocol requires consistent, non-restrictive network 
bandwidth as well as the personal computer hardware sufficient to support not only the 
communications of the agent, but also other tasks being performed on the personal computer. If 
you experience problems with Avaya IP Agent Voice-over-IP telephony, you should ensure that 
network and personal computer resources are adequate for the tasks being performed. 
Consider the topics in this section when you are determining the efficiency of Voice-over-IP in 
your contact center.
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Real-time processing
Voice-over-IP uses real-time processing on your personal computer to transmit voice 
communication. Nearly all other processes on a personal computer use sequential processing 
which means that requests for system resources are processed as they become available. If 
resources are not available to process Voice-over-IP actions, the quality of the communication 
degrades.

Network bandwidth
Network bandwidth availability can also have an impact on Voice-over-IP communications. The 
codecs used for Voice-over-IP encoding can vary from using small packets for dial-up 
connections with reduced voice quality to using larger packets providing higher voice quality 
over broadband and high-speed connections.

Tip:
Tip: Avaya provides the Avaya IP Voice Quality Network Requirements as an in-depth 

and informative document that defines and describes all aspects of networking 
and how those aspects can affect Voice-over-IP communications. Contact your 
Avaya representative for more information.

Personal computer hardware and software
The personal computer software and hardware requirements in this document are the absolute 
minimum needed for operation. These minimum requirements do not take any tasks, 
applications, or other actions that may be occurring on the personal computer into account. If 
you experience problems with Voice-over-IP beyond those of configuration errors, most can be 
solved by upgrading the personal computer or using one with higher specifications.

Tip:
Tip: Voice-over-IP does not guarantee toll-quality audio. This is affected by numerous 

variables including the codec being used, network bandwidth availability, 
personal computer processing capabilities, sound device, network lag and packet 
loss, and many others.

The following information describes personal computer considerations that are related to 
Voice-over-IP communications. Avaya recommends that you validate your network 
configuration against the Avaya IP Voice Quality Network Requirements. Additionally, Avaya 
provides network assessment services to determine if your network can support Voice-over-IP 
communications.
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Voice-over-IP performance considerations
The speed and architecture of a processor are considerations in potential Voice-over-IP 
performance difficulties. However, architecture must also be considered. Both Intel® and AMD® 
have produced economical processors for small businesses and home users that, while rated at 
comparable speeds to the higher-priced models, have reduced on-chip memory (L1/L2 cache). 
This affects real-time processing which, in turn, affects Voice-over-IP communications. 
Additionally, some chip sets have been created that include specialized instruction sets that 
optimize specific types of applications and processes. These include speech processing.

To avoid experiencing problems with Voice-over-IP communications with Avaya IP Agent, 
Avaya recommends using a system with higher specifications for the following items.

● Processor speed

● On-chip memory (L1 or L2 cache)

● System Bus speed

Note:
Note: Avaya IP Agent does not officially support Cyrix™ processors.

System descriptions for Voice-over-IP
The following system descriptions provide guidelines for determining whether higher system 
requirements are necessary for Voice-over-IP communications. 

! Important:
Important: If your system more closely resembles the moderate- or high-demand systems, 

an upgrade from the minimum requirements for the Voice-over-IP configuration is 
recommended.

Specific requirements for each type of system cannot be given because RAM, processor speed, 
system bus speed, on-chip memory, sound devices, network bandwidth, and applications in 
usage are all variables that can range widely in impact.

High demand: A high-demand system is a personal computer that uses processor-intensive 
applications.

The following list presents some examples of activities and applications that are used in a 
high-demand system:

● Multiple, CPU-intensive applications running simultaneously

● Database queries or hosting

● Multimedia applications

● Computer-Assisted Drafting (CAD) applications
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● Compilers

● Streaming media

Moderate demand: A moderate-demand system is a personal computer that sometimes uses 
applications normally found in an office environment.

The following list presents some examples of activities and applications that are used in a 
moderate-demand system:

● Word processors

● Spreadsheets

● Web browsing

● Data entry

● General e-mail

Low demand: A low-demand system is a personal computer that rarely uses any applications 
apart from Avaya IP Agent.

The following list presents some examples of activities and applications that are used in a 
low-demand system:

● Text e-mail

● Simple web browsing (no streaming media)

● Minimal data entry
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Chapter 2: Configuring the Avaya 
communication server 

This section provides procedures and information on how to configure the following Avaya 
communication servers for use with Avaya IP Agent:

● Avaya communication servers with Communication Manager software

● Avaya communication servers with MultiVantage Software

Before agents can receive calls with Avaya IP Agent, the Avaya communication server must be 
configured to support extension assignments, IP connectivity, telephone types, and other 
settings.

! Important:
Important: You should be familiar with administering your Avaya communication server 

before attempting any of the procedures in this section. If you are unfamiliar with 
the fields or settings described in this section, consult your Avaya communication 
server documentation for assistance.

This section includes the following topics:

● Required Avaya communication server circuit packs on page 34

● Validating Feature Access Codes on page 35

● Road Warrior and Telecommuter configurations on page 37

● Callmaster VI configurations on page 44

● IP Telephone and Avaya Telephone-IP configurations on page 48

● Avaya Telephone-DCP configurations on page 55

Note:
Note: The screens shown in this section are from an Avaya communication server with 

the Expert Agent Selection (EAS) feature. If you do not have the EAS or some 
other features on your Avaya communication server, these interfaces may differ 
slightly from the screens shown. Because of this, each step in the procedure 
identifies when there is a distinction between an EAS and non-EAS system.
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Required Avaya communication server circuit packs 
This section provides information and documentation resources for the circuit packs required by 
your Avaya communication server to support the Telecommuter, IP Telephone, Avaya 
Telephone, and Road Warrior configurations with Avaya IP Agent.

The following two circuit packs are used for remote agent connections over TCP/IP with Avaya 
IP Agent:

● Control LAN Circuit Pack (C-LAN) (TN799B, TN799DP, or later)

● IP Media Processor (TN2302AP, TN2602AP, or later)

This section contains the following topics:

● C-LAN circuit pack on page 34

● IP Media Processor on page 35

● Documentation on page 35

C-LAN circuit pack
C-LAN is a packet port circuit pack for Avaya communication servers that provides TCP/IP 
connectivity to adjuncts for applications. It has one 10BaseT or 100BaseT Ethernet connection 
and up to 16 DS0 physical interfaces for PPP connections. Two integrated modems provide 
remote PPP connectivity over analog facilities. Multiple C-LAN circuit packs can be added to a 
system to increase TCP/IP capacity.

This circuit pack provides data signaling over TCP/IP for Avaya IP Agent. It is used for the 
Telecommuter, IP Telephone, Avaya Telephone, and Road Warrior configurations where a data 
connection is made to the Avaya communication server. The voice path does not use this circuit 
pack.

Note:
Note: Avaya recommends that the TN799C V4, TN799DP, or later C-LAN circuit pack is 

used for its increased ability to handle maximum capacities. Previous versions 
could encounter difficulties when the maximum number of active endpoints is 
reached.
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IP Media Processor
The IP Media Processor provides the transmission of voice data over an IP network. This 
enables support of applications that comply with H.323-v2 protocols. It also reduces per-port 
costs and improves quality through its dynamic jitter buffers. Additionally, it performs echo 
cancellation, silence suppression, Dual Tone Multi-Frequency (DTMF) detection, and 
conferencing. 

This circuit pack provides Voice-over-Internet Protocol (VoIP) for Avaya IP Agent. It is used for 
the Road Warrior configuration where a VoIP connection is made to the Avaya communication 
server.

Documentation
For installation procedures and configuration information for the C-LAN and IP Media Processor 
circuit packs, see Administration for Network Connectivity for your Communication Manager or 
MultiVantage.

Validating Feature Access Codes 
This section provides the procedure for administering the Feature Access Codes (FACs) on an 
Avaya communication server. Feature Access Codes are used by Avaya IP Agent to give 
agents the ability to perform the following actions: 

● Change the current work mode

● Log in

● Log out 

● Adjust the method with which an agent receives the next call (Auto-In, Manual-In)

● Request supervisor assistance

Before you begin
Feature Access Codes cannot be entered unless the fac capability is assigned in the dial plan.

To change settings on the Avaya communication server, you must have a user ID with the 
proper administrative permissions.
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! Important:
Important: Screens presented in this section might differ in appearance from those of your 

Avaya communication server. All options on the specified forms mentioned in this 
procedure are available, but might not be on the page noted.

Steps for validating Feature Access Codes
To validate Feature Access Codes:

1. Log in to the Graphically Enhanced DEFINITY Interface (GEDI) on the Avaya 
communication server.

Note:
Note: You can choose to log in to the Station Administration Terminal (SAT) on the 

Avaya communication server. The configuration steps are the same for either 
interface.

2. Enter display dialplan analysis to access the dial plan form and then ensure that 
the fac option is assigned in the dial plan.

If the fac option is not assigned in the dial plan, your dial plan does not currently support 
Feature Access Codes. For more information on configuring your dial plan for Feature 
Access Codes, see the documentation for your Avaya communication server.

3. Enter display feature-access-codes to view the feature-access-codes form.

4. Navigate to the call center portion of the feature-access-codes form.

Non-EAS Avaya communication servers will display only a subset of the access code 
fields shown in the following figure.
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Note:
Note: The Feature Access Codes shown in the graphic are only an example and do not 

need to be configured as such on your Avaya communication server. You are free 
to determine your own Feature Access Codes.

5. Administer the Feature Access Codes for Login and Logout as well as any other FACs 
that you want available for your agents.

For Avaya Callmaster VI configurations, you must also administer the PASTE Feature 
Access Code which is located on a different page of this form.

If Feature Access Codes are not assigned, see the documentation for your Avaya 
communication server to find instructions on adding Feature Access Codes.

Road Warrior and Telecommuter configurations 
If you will be using Avaya IP Agent for Voice-over-IP through the personal computer (Road 
Warrior configuration) or using any telephone as your extension (Telecommuter configuration), 
this section provides the procedures and information for proper administration of your Avaya 
communication server.

This section contains the following topics:

● Ensuring compatibility on page 37

● Configuring station settings on page 40

Ensuring compatibility
In this procedure, you set features on your Avaya communication server so that Avaya IP Agent 
can be used in your contact center.

Before you begin

The settings for IP connections can be enabled only if your Avaya communication server 
supports use of Internet Protocol (IP) for calls.

! Important:
Important: If any settings of your Avaya communication server do not conform with the steps 

in this procedure, you must contact Avaya to purchase the appropriate options or 
configuration for your Avaya communication server before you can use Avaya IP 
Agent.
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If you need to configure a specific range of ports to use with IP communications because of 
firewalls or for some other reason, you must assign the range through both the Avaya 
communication server and Avaya iClarity IP Audio. See Advanced tab on page 246 for 
information on configuring port ranges on both systems.

Steps for ensuring Road Warrior and Telecommuter station settings

To ensure that your Avaya communication server supports the Telecommuter and Road Warrior 
configurations:

1. Log in to the Graphically Enhanced DEFINITY Interface (GEDI) on the Avaya 
communication server.

Note:
Note: You can choose to log in to the Station Administration Terminal (SAT) on the 

Avaya communication server. The configuration steps are the same for either 
interface.

2. Enter display system-parameters customer-options.

The SAT displays Page 1 of the system-parameters customer-options form.
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3. Navigate to Page 2 of the customer-options form.

4. Ensure that the Maximum Concurrently Registered IP Stations field is set to a number 
greater than zero. This number represents the total number of IP stations that can be 
connected to the Avaya communication server at one time. IP stations can consist of 
Avaya IP Agent, Avaya IP Softphone, and IP telephone sets.

5. Navigate to Page 4 of the customer-options form.

6. Ensure that the IP Stations field is set to y.
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7. Navigate to Page 10 of the customer-options form.

8. Ensure that the Limit field for the IP_Agent Rel. 7 Product ID is set to the number of 
licenses you purchased for Avaya IP Agent R7.

Configuring station settings 
This section provides the procedure for configuring station settings to support the Telecommuter 
and Road Warrior configurations.

Before you begin

Before configuring station settings on the Avaya communication server, you should have 
completed the procedures in Ensuring compatibility on page 37 to verify that your Avaya 
communication server supports Avaya IP Agent and Feature Access Codes.

To change settings on the Avaya communication server, you must have a user ID with the 
proper administrative permissions.

If the station has not yet been created, you must create it using the add station command on 
the Avaya communication server.

Steps for configuring Road Warrior and Telecommuter station settings

To change station settings to support the Road Warrior and Telecommuter configurations:

1. Log in to the Graphically Enhanced DEFINITY Interface (GEDI) on the Avaya 
communication server.
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Note:
Note: You can choose to log in to the Station Administration Terminal (SAT) on the 

Avaya communication server. The configuration steps are the same for either 
interface.

2. Enter change station XXXXX where XXXXX is the number of the station to be used 
with Avaya IP Agent.

The Avaya communication server displays the change station form for the specified 
station.

3. In the Type field, enter the type of telephone that Avaya IP Agent will emulate.

Avaya recommends using one of the following telephone types because of the number of 
features available and the ability to display 80 characters for contact center or call 
information:

● 8434D

● 606A1

Note:
Note: In Telecommuter mode, Avaya IP Agent can take over the administration and 

functionality of a physical Digital Communication Protocol (DCP) telephone. The 
physical telephone must be one of those listed in Compatible telephone types for 
Avaya IP Agent on page 24. For DCP, the physical telephone is unusable while 
Avaya IP Agent is registered with its extension. The telephone will become usable 
again when the Avaya IP Agent session is disconnected from the Avaya 
communication server.

If you selected the 8434D type, and more feature buttons are needed for the station, enter 
y in the Expansion Module field.

4. Enter one of the following options in the Port field:

● IP - This option specifies that station administration is done without hardware.
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● port - This option is used when a remote agent takes direct control of a real extension 
that has a DCP connection to the Avaya communication server. Enter the port number 
of the actual telephone assigned to this extension. When a remote agent logs in to this 
extension using Avaya IP Agent, the actual telephone that is locally connected to the 
Avaya communication server port is disabled and cannot be used.

5. Enter a number in the Security Code field that will be used as a password during the 
extension login to the Avaya communication server.

If a security code is not entered, this station cannot log in to the Avaya communication 
server.

6. Set the IP Softphone field to y.

7. Navigate to Page 2 of the change station form.

8. Set the Multimedia Mode field to enhanced.

9. Set the Service Link Mode field to one of the following options:

● as-needed - Use this setting if the station has low call traffic or a toll is charged for 
calls.

● permanent - Use this setting if the station has high call traffic or if it is set as an 
auto-answer station.

10. Ensure that the Emergency Location Ext: field is set to the appropriate setting for your 
contact center.

11. If the Auto Answer field is set to All or ACD on the station or agent form, you must enable 
the Enable support for auto-answer feature in the Avaya IP Agent Program Options 
and then reboot. You can find this option under Tools > Program Options in the Avaya IP 
Agent main window.
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12. Navigate to Page 4 of the change station form.

13. On pages 3, 4, and 5 of the station administration forms, assign functions to each button 
that you want to appear in your Avaya IP Agent Phone Features window.

You must assign the necessary agent work mode buttons that are used in your contact 
center:

● auto-in - This function makes agents available for new calls immediately after they 
finish with the current call.

● manual-in - This function makes the agent available to take a call and then places the 
agent in the After Call Work (ACW) mode when the call has been completed.

● after-call - This function places agents in the After Call Work (ACW) mode.

● aux-work - This function places agents in the Auxiliary Work (AUX) mode. Multiple 
Auxiliary Work buttons with different reason codes can be assigned to this extension.

Note:
Note: You can configure your Avaya communication server to prompt for reason codes 

when an agent enters the aux-work state.

● release - Assignment of this feature is mandatory. This feature terminates the current 
call and line appearance.

● callr-info - This function is required only with the Call Prompting feature so that agents 
are allowed to display information collected from the originator of the call. The Call 
Prompting feature obtains information from a caller through a collect-digits vector 
step on the Avaya communication server.
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! Important:
Important: The 4600, 6400, and 607A1 telephone types do not have a physical Drop button; 

therefore, you must assign a drop function for each station to ensure proper 
operation of the Avaya IP Agent Drop feature.

When this station is connected to the Avaya communication server, the assigned button 
functions are displayed in the Avaya IP Agent Phone Features window.

You can find information on all available button functions in the documentation for your 
Avaya communication server.

Rebuilding Feature button and Phone feature toolbars

During station administration, if you delete a Phone Feature button from the Feature buttons 
toolbar, the entire Feature button toolbar will be deleted. Choose Tools > Phone Features and 
select File > Rebuild All to refresh phone features and rebuild the Feature button toolbar, 
Phone feature toolbar, and Personal Phone Features. 

Callmaster VI configurations 
If you use Avaya Callmaster VI telephones for your contact center agents, this section provides 
the procedures for configuring your Avaya communication server for compatibility with Avaya IP 
Agent.

Note:
Note: Callmaster VI telephones can only be used with IP Agent R7 running on Windows 

XP. 

This section contains the following topics:

● Ensuring compatibility on page 44

● Configuring station settings on page 46

Ensuring compatibility
This section provides the procedure for ensuring that your Avaya communication server is 
configured to support Avaya IP Agent in the Avaya Callmaster VI configuration.
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Before you begin

Read and understand the following items before administering your Avaya communication 
server:

● A BCS/Guestworks system does not support Avaya Callmaster VI configurations.

! Important:
Important: If any Avaya communication server settings do not conform with the steps in this 

procedure, you must contact Avaya to purchase the appropriate options or 
configuration before you can use Avaya IP Agent.

Steps for ensuring Callmaster VI compatibility

To ensure that your Avaya communication server supports Avaya IP Agent in the Callmaster VI 
configuration:

1. Log in to the Graphically Enhanced DEFINITY Interface (GEDI) on the Avaya 
communication server.

Note:
Note: You can choose to log in to the Station Administration Terminal (SAT) on the 

Avaya communication server. The configuration steps are the same for either 
interface.

2. Enter display system-parameters customer-options.

The SAT displays Page 1 of the system-parameters customer-options form.

3. Navigate to Page 6 of the customer-options form.
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4. If you are using Avaya Callmaster VI telephone sets with the 606A1 telephone type, you 
must ensure that the PC Application Software Translation Exchange (PASTE) feature is 
enabled. Locate the PASTE (Display PBX Data on Phone) field and ensure that it is set 
to y.

Configuring station settings 
This section provides the procedure for configuring station settings to support the Avaya 
Callmaster VI configurations for Avaya IP Agent.

Before you begin

Before configuring station settings on the Avaya communication server, you should have 
completed the procedure in Ensuring compatibility on page 44 to verify that your Avaya 
communication server supports Avaya IP Agent and Feature Access Codes.

To use Avaya Callmaster VI telephones, you must have the PASTE feature enabled on your 
Avaya communication server.

To change settings on the Avaya communication server, you must have a user ID with the 
proper administrative permissions.

If the station has not yet been created, you must create it using the add station command on 
the Avaya communication server.
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Steps for configuring Callmaster VI station settings

To change station settings to support Avaya Callmaster VI configurations:

1. Log in to the Graphically Enhanced DEFINITY Interface (GEDI) on the Avaya 
communication server.

Note:
Note: You can choose to log in to the Station Administration Terminal (SAT) on the 

Avaya communication server. The configuration steps are the same for either 
interface.

2. Enter change station XXXXX where XXXXX is the number of the station to be used 
with Avaya IP Agent.

The Avaya communication server displays the change station form for the specified 
extension.

3. In the Type: field, enter 606A1.

4. In the Port: field, enter the number of the port providing the connection for the Avaya 
Callmaster VI telephone.

5. Navigate to Page 3 of the change station form.

6. Ensure that the DUAL LED field is set to call-appr.
7. On pages 3, 4, 5, and 6 of the station administration forms, assign functions to each button 

that you want to appear in your Avaya IP Agent Phone Features window.

You must assign the necessary agent work mode buttons that are used in your contact 
center:

● auto-in - This function makes agents available for new calls immediately after the 
current call is finished.

● manual-in - This function makes the agent available to take a call and then places the 
agent in the After Call Work (ACW) mode when the call has been completed.

● after-call - This function places agents in the After Call Work (ACW) mode.

● aux-work - This function places agents in the Auxiliary Work (AUX) mode. Multiple 
Auxiliary Work buttons with different reason codes can be assigned to this extension.

Note:
Note: You can configure your Avaya communication server to prompt for reason codes 

when an agent enters the aux-work state.

● release - Assignment of this feature is mandatory. This feature terminates the current 
call and line appearance.
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● callr-info - This function is only required with the Call Prompting feature so that agents 
are allowed to display information collected from the originator. The Call Prompting 
feature obtains information from a caller through a collect-digits vector step.

When this station is connected to the Avaya communication server, the assigned button 
functions are displayed in the Avaya IP Agent Phone Features window.

You can find information on all available button functions in the documentation for your 
Avaya communication server.

8. After you create a station and assign or modify buttons, you must perform a download for 
the Avaya Callmaster VI. Go to the personal computer connected to the Avaya Callmaster 
VI station and select Settings > Phone Configuration from the Avaya IP Agent menu bar.

Avaya IP Agent displays a confirmation dialog box.

9. Select the OK button.

IP Telephone and Avaya Telephone-IP configurations 
This section provides the procedures for configuring your Avaya communication server to 
function properly with Avaya IP Agent if you use Avaya IP telephones in your contact center.

This section contains the following topics:

● Ensuring compatibility on page 48

● Configuring station settings on page 51

Ensuring compatibility
This section provides the procedure for ensuring that your Avaya communication server is 
configured to support the IP Telephone and Avaya Telephone-IP configurations.

Before you begin

The settings for IP connections can be enabled only if your Avaya communication server 
supports use of Internet Protocol (IP) for calls.

! Important:
Important: If any settings of your Avaya communication server do not conform with the steps 

in this procedure, you must contact Avaya to purchase the appropriate options or 
configuration for your Avaya communication server before you can use Avaya IP 
Agent.
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If you need to configure a specific range of ports to use with IP communications because of 
firewalls or for some other reason, you must assign the range through both the Avaya 
communication server and Avaya iClarity IP Audio. See Advanced tab on page 246 for 
information on configuring port ranges on both systems.

Steps for ensuring IP telephone compatibility

To ensure that your Avaya communication server supports the IP Telephone and Avaya 
Telephone-IP configurations:

1. Log in to the Graphically Enhanced DEFINITY Interface (GEDI) on the Avaya 
communication server.

Note:
Note: You can choose to log in to the Station Administration Terminal (SAT) on the 

Avaya communication server. The configuration steps are the same for either 
interface.

2. Enter display system-parameters customer-options.

The SAT displays Page 1 of the system-parameters customer-options form.
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3. Navigate to Page 2 of the customer-options form.

4. Ensure that the Maximum Concurrently Registered IP Stations field is set to a number 
greater than zero. This number represents the total number of IP stations that can be 
connected to the Avaya communication server at one time. IP stations can consist of 
Avaya IP Agent, Avaya IP Softphone, and IP telephone sets.

5. Navigate to Page 4 of the customer-options form.

6. Ensure that the IP Stations field is set to y.
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7. Navigate to Page 10 of the customer-options form.

8. For the Avaya Telephone-IP configuration, ensure that the Limit field for the 
IP_AGENTSC Rel. 7 Product ID is set to the number of licenses you purchased for Avaya 
IP Agent R7. For the IP Telephone configuration, verify the number of licenses for the 
IP_AGENT Rel. 7 Product ID.

Note:
Note: This configuration can use either the AGENTSC or IP_Agent licenses.

Configuring station settings 
This section provides the procedure for configuring station settings to support the IP Telephone 
and Avaya Telephone-IP configurations.

Before you begin

Before configuring station settings on the Avaya communication server, you should have 
completed the procedure in Ensuring compatibility on page 48 to verify that your Avaya 
communication server supports Avaya IP Agent and Feature Access Codes.

To change settings on the Avaya communication server, you must have a user ID with the 
proper administrative permissions.

If the station has not yet been created, you must create it using the add station command on 
the Avaya communication server.

! Important:
Important: To use an Avaya IP telephone with Avaya IP Agent, the firmware version of the 

telephone must be 1.7 or later.
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For the IP Telephone configuration, the Computer Telephony Integration (CTI) control feature 
must be enabled on the IP telephone before it can be used in conjunction with Avaya IP Agent. 
This feature does not need to be enabled if you are administering the Avaya Telephone-IP 
configuration. To enable the CTI control feature:

1. Press the Mute button on your IP telephone.

2. Press 2 8 4 # on the IP telephone dial pad.

The telephone display will display the state of the CTI control feature. CTI=manual 
indicates that the feature is enabled.

3. Depending on the feature state, perform the appropriate action:

- If CTI=manual is displayed, save your changes by following the prompts on the 
telephone display.

- If CTI=off is displayed, press 1 # to enable CTI control, and then save your changes 
by following the prompts on the telephone display.

Steps for configuring IP Telephone and Avaya Telephone-IP station settings

To change station settings to support the IP Telephone and Avaya Telephone-IP configurations:

1. Log in to the Graphically Enhanced DEFINITY Interface (GEDI) on the Avaya 
communication server.

Note:
Note: You can choose to log in to the Station Administration Terminal (SAT) on the 

Avaya communication server. The configuration steps are the same for either 
interface.

2. Enter change station XXXXX where XXXXX is the number of the station to be used 
with Avaya IP Agent.

The Avaya communication server displays the change station form for the specified 
station.

3. In the Type field, enter the type of telephone that Avaya IP Agent will control. The station 
type must match that of the IP telephone.

4. Ensure that the Port field is set to IP.

5. Enter a number in the Security Code field that will be used as a password during the 
extension login to the Avaya communication server.

If a security code is not entered, this station cannot log in to the Avaya communication 
server.

6. Set the IP Softphone field to y.
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7. Navigate to Page 2 of the change station form.

8. Ensure that the Multimedia Mode field has been set to enhanced.

9. Set the Service Link Mode field to one of the following options:

● as-needed - Use this setting if the station has low call traffic or a toll is charged for 
calls.

● permanent - Use this setting if the station has high call traffic or if it is set as an 
auto-answer station.

10. If the Auto Answer field is set to All or ACD on the station or agent form, you must enable 
the Enable support for auto-answer feature in the Avaya IP Agent Program Options 
and then reboot. You can find this option under Tools > Program Options in the Avaya IP 
Agent main window.
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11. Navigate to Page 4 of the change station form.

12. On pages 3, 4, and 5 of the station administration forms, assign functions to each button 
that you want to appear in your Avaya IP Agent Phone Features window.

You must assign the necessary agent work mode buttons that are used in your contact 
center:

● auto-in - This function makes agents available for new calls immediately after they 
finish with the current call.

● manual-in - This function makes the agent available to take a call and then places the 
agent in the After Call Work (ACW) mode when the call has been completed.

● after-call - This function places agents in the After Call Work (ACW) mode.

● aux-work - This function places agents in the Auxiliary Work (AUX) mode. Multiple 
Auxiliary Work buttons with different reason codes can be assigned to this extension.

Note:
Note: You can configure your Avaya communication server to prompt for reason codes 

when an agent enters the aux-work state.

● release - Assignment of this feature is mandatory. This feature terminates the current 
call and line appearance.

● callr-info - This function is required only with the Call Prompting feature so that agents 
are allowed to display information collected from the originator of the call. The Call 
Prompting feature obtains information from a caller through a collect-digits vector 
step on the Avaya communication server.

When this station is connected to the Avaya communication server, the assigned button 
functions are displayed in the Avaya IP Agent Phone Features window.

You can find information on all available button functions in the documentation for your 
Avaya communication server.
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Avaya Telephone-DCP configurations 
The Avaya Telephone-DCP configuration allows agents to use Avaya IP Agent as a direct 
interface with a Digital Communication Protocol (DCP) telephone. This configuration is used 
when there is no need for agents to use any of the following capabilities: 

● Voice-over-IP

● A telephone outside the contact center

● An extension with a different telephone type that allows more features than the DCP 
telephone.

This section contains the following topics:

● Ensuring compatibility on page 55

● Configuring station settings on page 58

Ensuring compatibility
This section describes the setting of features on your Avaya communication server so that 
Avaya IP Agent can be used in your contact center.

Before you begin

The settings for IP connections can be enabled only if your Avaya communication server 
supports use of Internet Protocol (IP) for calls.

! Important:
Important: If any settings of your Avaya communication server do not conform with the steps 

in this procedure, you must contact Avaya to purchase the appropriate options or 
configuration for your Avaya communication server before you can use Avaya IP 
Agent.

If you need to configure a specific range of ports to use with IP communications because of 
firewalls or for some other reason, you must assign the range through both the Avaya 
communication server and Avaya iClarity IP Audio. See Advanced tab on page 246 for 
information on configuring port ranges on both systems.

The DCP telephone must be connected for Avaya IP Agent to register with the Avaya 
communication server. If the telephone is disconnected, registration through Avaya IP Agent will 
be denied. Conversely, if the DCP telephone is disconnected after registration has been made, 
Avaya IP Agent will be disconnected by the Avaya communication server.



Chapter 2: Configuring the Avaya communication server

56 IP Agent R7 Installation and User Guide August 2007

 

Steps for ensuring Avaya Telephone-DCP compatibility

To ensure that your Avaya communication server supports the Avaya Telephone-DCP 
configuration:

1. Log in to the Graphically Enhanced DEFINITY Interface (GEDI) on the Avaya 
communication server.

Note:
Note: You can choose to log in to the Station Administration Terminal (SAT) on the 

Avaya communication server. The configuration steps are the same for either 
interface.

2. Enter display system-parameters customer-options.

The SAT displays Page 1 of the system-parameters customer-options form.

3. Navigate to Page 2 of the customer-options form.
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4. Ensure that the Maximum Concurrently Registered IP Stations field is set to a number 
greater than zero. This number represents the total number of IP stations that can be 
connected to the Avaya communication server at one time. IP stations can consist of 
Avaya IP Agent, Avaya IP Softphone, and IP telephone sets.

5. Navigate to Page 4 of the customer-options form.

6. Ensure that the IP Stations field is set to y.

7. Navigate to Page 10 of the customer-options form.

8. Ensure that the Limit field for the IP_AGENTSC Rel. 7 Product ID is set to the number of 
licenses you purchased for Avaya IP Agent R7.

Note:
Note: This configuration can use either the AGENTSC or IP_Agent licenses.
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Configuring station settings 

Before you begin

Before configuring station settings on the Avaya communication server, you should have 
completed the procedures in Ensuring compatibility on page 55 to verify that your Avaya 
communication server supports Avaya IP Agent and Feature Access Codes.

To change settings on the Avaya communication server, you must have a user ID with the 
proper administrative permissions.

If the station has not yet been created, you must create it using the add station command on 
the Avaya communication server.

Steps for configuring Avaya Telephone-DCP station settings

To change station settings to support the Avaya Telephone-DCP configuration:

1. Log in to the Graphically Enhanced DEFINITY Interface (GEDI) on the Avaya 
communication server.

Note:
Note: You can choose to log in to the Station Administration Terminal (SAT) on the 

Avaya communication server. The configuration steps are the same for either 
interface.

2. Enter change station XXXXX where XXXXX is the number of the station to be used 
with Avaya IP Agent.

The Avaya communication server displays the change station form for the specified 
station.
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3. In the Type field, enter the type of telephone that will be used with Avaya IP Agent. If this 
station possesses an expansion module, set the Expansion Module field to y.

! Important:
Important: This field must reflect the exact model of telephone that will be used by the agent.

4. In the Port field, specify the port that this DCP telephone will use.

This option is used when a remote agent takes direct control of a telephone that has a 
DCP connection to the Avaya communication server. Enter the port number of the actual 
telephone assigned to this extension.

5. Enter a number in the Security Code field that will be used as a password during the 
extension login to the Avaya communication server.

If a security code is not entered, this station cannot log in to the Avaya communication 
server.

6. Set the IP Softphone field to y.

7. Navigate to Page 2 of the change station form.

8. Set the Multimedia Mode field to enhanced.

9. Set the Service Link Mode field to one of the following options:

● as-needed - Use this setting if the station has low call traffic or a toll is charged for 
calls.

● permanent - Use this setting if the station has high call traffic or if it is set as an 
auto-answer station.

10. If the Auto Answer field is set to All or ACD on the station or agent form, you must enable 
the Enable support for auto-answer feature in the Avaya IP Agent Program Options 
and then reboot. You can find this option under Tools > Program Options in the Avaya IP 
Agent main window.
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11. Navigate to Page 4 of the change station form.

12. On pages 3, 4, and 5 of the station administration forms, assign functions to each button 
that you want to appear in your Avaya IP Agent Phone Features window.

You must assign the necessary agent work mode buttons that are used in your contact 
center:

● auto-in - This function makes agents available for new calls immediately after they 
finish with the current call.

● manual-in - This function makes the agent available to take a call and then places the 
agent in the After Call Work (ACW) mode when the call has been completed.

● after-call - This function places agents in the After Call Work (ACW) mode.

● aux-work - This function places agents in the Auxiliary Work (AUX) mode. Multiple 
Auxiliary Work buttons with different reason codes can be assigned to this extension.

Note:
Note: You can configure your Avaya communication server to prompt for reason codes 

when an agent enters the aux-work state.

● release - Assignment of this feature is mandatory. This feature terminates the current 
call and line appearance.

● callr-info - This function is only required with the Call Prompting feature so that agents 
are allowed to display information collected from the originator of the call. The Call 
Prompting feature obtains information from a caller through a collect-digits vector 
step on the Avaya communication server.
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! Important:
Important: The 6400-series telephones do not have a physical Drop button; therefore, you 

must assign a drop function for each station to ensure proper operation of the 
Avaya IP Agent Drop feature.

When this station is connected to the Avaya communication server, the assigned button 
functions are displayed in the Avaya IP Agent Phone Features window.

You can find information on all available button functions in the documentation for your 
Avaya communication server.
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Chapter 3: Installing Avaya IP Agent for 
PC-based configurations 

This section contains procedures and important information for installing and uninstalling Avaya 
IP Agent on a personal computer.

This section includes the following topics:

● Prerequisites on page 63

● Interactive installation on page 67

● Silent installation on page 79

● Upgrades and reinstallation on page 83

● Changing or removing Avaya IP Agent on page 84

Prerequisites 
This section provides information on the necessary hardware and software for successful 
installation and usage of Avaya IP Agent.

This section contains the minimum or recommended requirements for the following areas:

● Software download package contents on page 63

● Avaya communication server on page 64

● SIP Enablement Services on page 64

● Personal computer hardware on page 65

● Personal computer software on page 67

Software download package contents
The Avaya IP Agent software download package available from the Avaya Support Web site 
contains the following items:

● Avaya IP Agent installation program

● Avaya IP Agent program files

● A readme.txt file containing last minute information
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Note:
Note: Documentation in PDF format is available from http://www.avaya.com/support - 

Adobe Acrobat® Reader 5.0 or later is required to view PDF documents.

Avaya communication server
The following table shows the Avaya communication servers that can be used with Avaya IP 
Agent:

Note:
Note: The Avaya Telephone configuration can be used only with Avaya Communication 

Manager 2.1 or later.

Depending on the endpoint configuration being used, Avaya IP Agent requires the following 
additional components on the Avaya communication server:

● Telecommuter and Avaya Telephone-DCP - A Control LAN Circuit Pack (C-LAN) (TN799B 
or later)

● Road Warrior (VoIP), IP Telephone, and Avaya Telephone-IP - A Control LAN Circuit Pack 
(C-LAN) (TN799B or later) and an IP Media Processor (TN2302AP) circuit pack

● Avaya Callmaster VI - No extra components required

SIP Enablement Services
For the Instant Messaging feature of Avaya IP Agent, you must have Avaya SIP Enablement 
Services 3.1 or later.

Consult the documentation for your SIP Enablement Services for the proper administration 
procedures regarding the Instant Messaging feature.

IP Endpoint (Windows XP and Vista) Callmaster VI (Windows XP only)

● Avaya communication servers with 
Avaya Communication Manager 
software

● Avaya communication servers with 
Avaya MultiVantage software

● Avaya communication servers with 
Avaya Communication Manager 
software

● Avaya communication servers with 
Avaya MultiVantage software
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Personal computer hardware 
The following topics present the minimum personal computer hardware requirements for Avaya 
IP Agent:

! Important:
Important: The hardware components in your personal computer must be properly 

configured and functioning as intended. Any improperly configured devices in 
your personal computer can potentially cause problems with the normal 
functionality of Avaya IP Agent. These hardware components include such things 
as sound card, CD-ROM drive, hard disk drive, mouse and video card.

Processor 

An x86-based processor rated at 300 MHz or faster is required. For Road Warrior (VoIP) 
configurations, a minimum of a 400 MHz processor is required. See Voice-over-IP 
considerations on page 28 for more information regarding hardware resources.

Hard disk space 

Avaya IP Agent requires a minimum of 30 MB. Avaya IP Agent can require more hard disk 
space, depending on the amount of data stored for the contact directory, contact history, agent 
greetings, and screen pops.

RAM 

The following table shows the memory requirements for the Avaya IP Agent configurations and 
the supported operating systems:

Configuration Windows XP Windows Vista

Road Warrior (VoIP)
Telecommuter
IP Telephone
Avaya Telephone-IP
Avaya Telephone-DCP
Instant Messaging

256 MB 512 MB

Callmaster VI 64 MB Not applicable
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Audio 

Road Warrior (VoIP) configurations require a sound device and one of the following hardware 
configurations:

● Headset with integrated microphone

● Personal computer speakers and microphone

For maximum voice quality, Avaya recommends that you use a sound card that supports 
full-duplex operation. Use of a headset or Universal Serial Bus (USB) headset provides higher 
voice quality than that of simply using speakers and a microphone connected to your personal 
computer.

For a list of the sound cards and headsets recommended for use with Avaya IP Agent, use the 
Search feature on the Avaya support Web site at http://support.avaya.com

! Important:
Important: Only the Road Warrior (VoIP) configuration supports the use of a microphone 

through the personal computer.

Telecommuter configurations require a sound card for the proper playing of ringing sounds 
through the personal computer and usage of an Avaya Switcher II headset for agent greetings.

Networking 

The following list provides the network requirements for each configuration type:

● Road Warrior (VoIP) configurations - A single network connection between the personal 
computer and the Avaya communication server

● Telecommuter configurations - One network connection and one telephone connection 
(DCP or analog)

● IP Telephone and Avaya Telephone-IP configurations - One network connection for the 
personal computer and one network connection for the IP telephone

● Avaya Telephone-DCP configurations - One network connection and one DCP telephone 
connection

● Avaya Callmaster VI configurations - A Digital Communications Protocol (DCP) connection 
to the Avaya communication server and a serial (RS-232) connection between the 
personal computer and the Avaya Callmaster VI telephone

Tip:
Tip: Avaya provides in-depth and informative documents that define and describe all 

aspects of networking and how those aspects can affect Voice-over-IP 
communications. You can retrieve these documents from the following address:

http://www.avaya.com

http://www.avaya.com
http://support.avaya.com
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Peripherals 

The following peripheral is required for installation and use of Avaya IP Agent:

● Mouse or compatible pointing device

Personal computer software 
Avaya IP Agent requires the following software:

● Microsoft Windows XP Professional with Service Pack 2 or Windows Vista Business, 
Enterprise, or Home Premium

● Microsoft Internet Explorer 6.0 or later

● For the Quick Dial feature, one of the following versions of Microsoft Outlook:

- Microsoft Outlook 2000 SP3 or later
- Microsoft Outlook 2003 SP1 or later
- Microsoft Outlook 2007

! Important:
Important: Microsoft Windows 2000 Server, Windows 2000 Advanced Server, Windows 

2000 Datacenter Server, and Windows 2003 Server are not supported for Avaya 
IP Agent personal computer-based configurations.

! Important:
Important: IP Agent R7 will not function properly if it is installed on a system that has been 

upgraded to Windows Vista from Windows XP.

Interactive installation
This section provides the procedure for installing Avaya IP Agent on a personal computer.

This section contains the following topics:

● Distributed installation information on page 68

● Network-based installation information on page 68

● Before you begin on page 68

● Installing Avaya IP Agent on page 69

● Manually adding an Avaya Service Provider on page 79
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Distributed installation information
If you are using network management software, you can deploy Avaya IP Agent using a 
combination of the MSI installation technology and the remote execution capability of your 
management software. See Running a silent installation on page 83 for more information.

Network-based installation information
The Avaya IP Agent software download package includes a single-file executable, setup.exe, 
that installs Avaya IP Agent. If you place this file on an internal network server, desktop users 
can download the file to the local computer and then run the installation program under a user's 
profile that has administrative rights on the local PC.

! Important:
Important: The executable setup.exe must be run from a directory where you have write 

access.

Before you begin
Before you attempt to install Avaya IP Agent, ensure that you do the following tasks:

● Login to a Windows profile containing administrative privileges.

● Download the correct software from the Avaya Support site. Copy the files to a directory of 
your choosing. Choose from the following packages:

Package Contains software for

Avaya IP Agent Standard 
(Microsoft Windows XP)

Standard TAPI R7.0 installation for Windows XP

Avaya IP Agent Service Pack 
(Microsoft Windows XP)

TAPI R7.0 product updates for Windows XP

Avaya IP Agent Standard (Citrix) 
(Microsoft Windows Server 2003/
Windows Server 2000)

Standard Citrix R7.0 installation for Windows Server 
2000 and 2003

Avaya IP Agent Service Pack 
(Citrix) (Microsoft Windows 
Server 2003/Windows Server 
2000)

Citrix R7.0 product updates for Windows Server 2000 
and 2003
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● Check that you have sufficient available local diskspace before beginning installation.

● Close all Windows applications.

● If you are upgrading Avaya IP Agent, you should ensure that you have obtained new 
licenses for this version of Avaya IP Agent on your MultiVantage or Communication 
Manager system. If you have not done so or are unsure, contact your Avaya 
representative for assistance.

● Begin the installation process described in Installing Avaya IP Agent on page 69.

Installing Avaya IP Agent
To install Avaya IP Agent using the standard interactive installation process:

1. Using a Windows command window or Windows Explorer, navigate to the directory 
containing the Avaya IP Agent R7.0 software.

2. Run the Setup.exe file.

The installation program checks to verify that Internet Explorer is not running. If Internet 
Explorer is running, the installation program displays the Installer Information dialog.

Avaya IP Agent Standard 
(Microsoft Windows Vista)

Standard TAPI R7.0 installation for Windows Vista

Avaya IP Agent Service Pack 
(Microsoft Windows Vista)

TAPI R7.0 product updates for Windows Vista

Package Contains software for
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3. Shut down Internet Explorer and select the Retry button.

The installation program checks to verify that IP Agent, Avaya Bluetooth Integrator, the 
Diagnostic Support - Log File Collection utility or the iClarity Administration application are 
not running. If any of these programs is running, the installation program displays the 
Installer Information dialog.

4. Shut down the specified application and select the Retry button.

The installation program displays the window welcoming you to the installation process.
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5. Select the Next button.

The installation program displays the License Agreement window.

6. Read the entire Software License Agreement carefully and select the I accept the terms 
in the license agreement option if you understand and agree to the terms. Selecting the I 
do not accept the terms in the license agreement option causes the installation 
program to exit.

Note:
Note: The license can be retrieved after installation. It is contained in the license.rtf file 

located in the application installation folder.
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7. Select the Next button.

The installation program displays the Release Information window.

8. Carefully review the release information provided.

Note:
Note: The release information can be retrieved after installation. It is contained in the 

readme.rtf file located in the application installation folder.

9. Select the Next button.

The installation program displays the Setup Type window.
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10. Select the Complete option to install all IP Agent features and languages. Select the 
Custom option to specify which IP Agent features and languages you want to install.

11. Select the Next button.

If you selected Complete, continue at Step 10. If you selected Custom, the installation 
program displays the Custom Setup window.

From this window you can perform a variety of optional tasks. When you are done with 
these tasks, continue at Step 10.

Optional tasks:

a. To change how a feature is installed, click an icon in the Custom Setup window. To 
view the description of the icons used to indicate feature installation states, select the 
Help button. The system displays the Custom Setup Tips window. Select the OK 
button to return to the Custom Setup window.
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b. To change the Avaya IP Agent destination installation location, select the Change... 
button. The system displays the Change Current Destination Folder window.

Enter the new location in the Folder name: field and select the OK button to return to 
the Custom Setup window.
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c. To review the amount of disk space available for application installation, select the 
Space button. The system displays the Disk Space Requirements window.

Select the OK button to return to the Custom Setup window.

Note:
Note: Bluetooth items does not appear on Vista.

12. Select the Next button.

The installation program displays the Desktop Shortcuts window.
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13. Choose the desktop shortcuts you want to have the installation program create (if any) by 
moving the appropriate language or languages to the right list box. 

You can highlight multiple fields in the left list box by holding down the Ctrl key and clicking 
the cursor on each field name.

After the necessary fields have been highlighted, select the Add >> button to move the 
selected fields to the right list box

The << Remove will remove highlighted field from the right list box.

14. You can instruct the system to automatically start IP Agent with a selected language when 
Windows starts by selecting the checkbox and choosing a language from the dropdown 
list.

15. Select the Next button.

The installation program displays the Start Menu Shortcuts window.

16. Choose the startup menu shortcuts you want to have the installation program create (if 
any) by moving the appropriate language or languages to the Add box.

17. Select the Next button.

The installation program displays the Endpoint Type window. 

Note:
Note: On Windows Vista, this window does not appear. Skip to Step 18.

Select one of the following options:

● IP Endpoint - Use this option for LAN, WAN, and Internet connections. This includes 
Road Warrior, Telecommuter, and IP Telephone configurations. IP Endpoint is the only 
option available on Vista.
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● Callmaster VI Endpoint - Use this option for personal computers connected to an 
Avaya Callmaster VI terminal through a serial connection. (Not available on Vista.)

! Important:
Important: If you are reinstalling Avaya IP Agent, the Endpoint previously configured on the 

personal computer is selected by default.

Note:
Note: This Callmaster VI Endpoint option is valid only for those contact centers using 

Avaya Callmaster VI terminals with the 606A1 telephone type on the Avaya 
communication server. This also requires that the PC Application Software 
Translation Exchange (PASTE) customer option on the Avaya communication 
server is enabled.

18. Select the Next button.

The installation program displays the Ready to Install the Program window.
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19. Select the Install button.

The installation program displays the Installing Avaya IP Agent window.

The Installing Avaya IP Agent window shows the installation progress, then the 
installation program displays the Installation Completed window.

20. Select the Finish button.

The installation program closes.
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Manually adding an Avaya Service Provider
After installing IP Agent, you should reboot the PC. 

! Important:
Important: If you do not reboot after installing IP Agent, it may be necessary to add the 

appropriate Avaya Service Provider manually using the Phone and Modem 
Options from the Microsoft Windows Control Panel.

1. Reboot then log into the PC as administrator. 

2. Choose Start > Control Panel and then select Phone and Modem Options. 

3. On the Advanced tab, select Avaya IP Service Provider (if using IP Endpoint) or Avaya 
PassageWay Service Provider (for CallMaster VI on Windows XP only) should be listed. 
If one of those is not listed, select Add and follow the instructions on the screen to add the 
appropriate Avaya Service Provider. 

4. Select OK to close the dialog box. 

5. Restart Avaya IP Agent.

Silent installation 
The silent installation feature allows you to programmatically install Avaya IP Agent without 
need of user intervention.

This section contains the following topics:

● Before you begin on page 79

● Extracting the MSI installer image on page 80

● Command-line parameters on page 81

● Running a silent installation on page 83

Before you begin
Read and understand the following items before you attempt to use the silent installation 
feature:

● The Avaya IP Agent installer packages, Standard and Service-Pack, contain the MSI 
Installer.
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● To pass custom (user-defined) properties to the MSI installer you must extract the MSI 
installer image from the Avaya base package installers.

● Where applying a transform is required in order to modify the MSI image, you must extract 
the MSI installer image from the Avaya base package installers. 

● The exact same MSI installer image can be obtained from either the Standard or 
Service-Pack installer package of the same versioned build release.

● Avaya IP Agent, Avaya Bluetooth Integrator, the Diagnostic Support - Log File Collection 
utility, the iClarity Administration application and Microsoft Internet Explorer must not be 
running during a silent installation.

Extracting the MSI installer image
You can extract a compressed MSI installer image or create an uncompressed MSI installer 
image. Most application administrators prefer working with a compressed MSI image.

To extract the compressed MSI from either the standard or service-pack setup.exe, at the 
command line, execute:

"c:\install\setup.exe" /b"C:\extract"

To create an uncompressed MSI from either the standard or service-pack setup.exe:

1. Execute the command:

"c:\install\setup.exe" /a

2. Select the Next button.

3. Select the Change button. 

4. Browse to the target folder where the uncompressed MSI image will be extracted.

5. Select the Install button.

The uncompressed MSI image is extracted into the target location.
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Command-line parameters
The following table displays the parameters you can pass to the MSI installer.

Parameter Description

INSTALL_TYPE=1 Standard Install - Command-line property 
parameter used to indicate a Standard 
packaged base installer image.

INSTALL_TYPE=2 Service-Pack Install - Command-line 
property parameter used to indicate a 
Service-Pack packaged base installer 
image.

Do not use INSTALL_TYPE property to 
conditionally determine if the installation is 
a silent install.

CONNECTIONTYPE=#0 Indicates that the installation endpoint 
should be assigned to Callmaster VI 
Endpoint. (Windows XP only)

CONNECTIONTYPE=#1 Indicates that the installation endpoint 
should be assigned to IP Endpoint.

SHOW_CM_COMPORT_CONFIG=1 Shows the COM Port dialog at the 
conclusion of the Callmaster VI installation. 
[DEFAULT] (Windows XP only)

SHOW_CM_COMPORT_CONFIG=0 Suppresses the COM Port dialog at the 
conclusion of the Callmaster VI installation. 
(Windows XP only)
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ADD_PROVIDER=0 Suppress the execution of AddProv.exe 
-add at install time. The execution of 
AddProv.exe -add is deferred to application 
startup where HKEY_LOCAL_MACHINE\
Avaya\Avaya IP Agent\Config 
AddPhoneDriver is initialized to 1 
(enabled).

CALLMASTER VI Installation Only - 
Setting ADD_PROVIDER = 0 will 
supersede setting the 
SHOW_CM_COMPORT_CONFIG 
property. The COM Port dialog will not be 
shown where ADD_PROVIDER=0 
regardless of the property value assigned 
to SHOW_CM_COMPORT_CONFIG.
(Windows XP only)

ADD_PROVIDER=1 Executes AddProv.exe -add at install time. 
The execution of AddProv.exe -add is NOT 
deferred to application startup where 
HKEY_LOCAL_MACHINE\Avaya\Avaya IP 
Agent\Config AddPhoneDriver is initialized 
to 0 (disabled). [DEFAULT]
(Windows XP only)

RETAINSETTINGS=#0 Indicates that uninstall should completely 
remove the active user's application 
settings and user data. Removal of user's 
preferences and data only applies to the 
current installer's windows account under 
HKEY_CURRENT_USER which is used to 
perform uninstall.

RETAINSETTINGS=#1 Indicates that uninstall will retain the user’s 
own application settings and user data. 
[DEFAULT]

MIGRATE_SHARED_LOGIN=0 Indicates that uninstall should completely 
remove the active user's application 
settings and user data. Removal of the 
user's preferences and data only applies to 
the current installer's windows account 
under HKEY_CURRENT_USER which is 
used to perform uninstall. (Windows XP 
only)

MIGRATE_SHARED_LOGIN=1 Indicates that uninstall will retain the user’s 
own application settings and user data. 
[DEFAULT] (Windows XP only)

Parameter Description
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Running a silent installation
For instructions about passing specific MSI command line parameters to the MSI installer image 
see: http://msdn2.microsoft.com/en-us/library/aa367988.aspx.

Upgrades and reinstallation
This section provides information for installing Avaya IP Agent over a previous version of Avaya 
IP Agent, such as V1, V1.1, V2, V3, R4, R5 or R6. (This does not apply for Windows Vista 
installations.)

This section contains the following topics:

● Upgrading Avaya IP Agent V3, R4, R5 or R6 to R7 on page 83

● Reinstalling Avaya IP Agent R7 on page 84

● Applying product updates on page 84

Upgrading Avaya IP Agent V3, R4, R5 or R6 to R7
This section provides information on upgrading Avaya IP Agent V3, R4, R5 or R6 to R7.

Data migration

The installation procedure for upgrading to Avaya IP Agent is the same as listed in Interactive 
installation on page 67 except for the following:

● All shared login data used in Avaya IP Agent V3, R4, R5 or R6 are migrated to Avaya IP 
Agent R7.

● Passwords prior to R6 will not be migrated due to encryption changes implemented in R7. 
Be certain you know or have obtained your station/extension password prior to upgrading 
to R7.

● If you select to not store information for multiple users during installation and multiple 
users were used previously, Avaya IP Agent will only migrate the application data for the 
user performing the upgrade.

● If Instant Messaging was enabled in R6, you must re-enable Instant Messaging in R7.

● If you are upgrading from a previous version of Avaya IP Agent, copy the Greeting.tbl and 
Greeting*.wav files from the old location to the new location, or you will get a default 
greeting table.
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Reinstalling Avaya IP Agent R7
Reinstallation of IP Agent can only be achieved using the Repair feature of the MSI installation 
package. This is described in Changing or removing Avaya IP Agent on page 84.

Applying product updates
The Product Update feature of Avaya IP Agent is used to search a specific location for version 
updates each time Avaya IP Agent is started. See General Settings panel on page 223 for 
information on this feature and how to use it.

Changing or removing Avaya IP Agent
Upon successful installation Avaya IP Agent is listed in the Add or Remove Programs listing 
which is accessed via Start > Settings > Control Panel > Add or Remove Programs.

This section contains the following topics:

● Introduction on page 84

● Steps for interactively uninstalling Avaya IP Agent on page 85

● Silently uninstalling Avaya IP Agent on page 85

Introduction
Uninstall Avaya IP Agent using the Windows XP Add/Remove Programs feature or the 
Windows Vista Programs and Features option. Read-only folders that are shared with other 
applications are not removed. If you have added any files or directories to the Avaya IP Agent 
installation directory, those files will not be removed.

The uninstall program removes the following items:

● All installed Avaya IP Agent files, including all language versions

● Folders created by the Avaya IP Agent installation

● Log files created by Avaya IP Agent
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Steps for interactively uninstalling Avaya IP Agent
To interactively uninstall the Avaya IP Agent application, do the following tasks:

1. Close Avaya IP Agent if it is currently running.

2. In the Windows Control Panel, select Add/Remove Programs or Programs and 
Features.

3. Select Avaya IP Agent and choose Change, Remove or Uninstall (Windows Vista).

Silently uninstalling Avaya IP Agent
To silently uninstall Avaya IP Agent execute the following command:

msiexec /x {9A73CB15-2F2B-4EBC-B534-BE1A1EDB4A73} /qn 
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Chapter 4: Avaya IP Agent enhanced 
configuration options 

This section provides information and procedures for configuring advanced features in a contact 
center that uses Avaya IP Agent.

This section contains the following topics:

● Configuring the Launch toolbar on page 87

● Configuring an IP Agent *.reg file with Configuration Administration on page 92

● Configuring Instant Messaging on page 97

● Configuring and using the Click-to-Dial feature on page 98

● Configuring and using the Quick-Dial feature for Microsoft Outlook on page 100

● Configuring the Emergency Call Handling Service on page 102

● Configuring Avaya IP Agent for VPN configurations on page 104

● Installing the Quality of Service Packet Scheduler on page 105

● Configuring Alternate Gatekeeper on Avaya communication servers on page 106

● Configuring server load balancing across gatekeepers on page 107

Configuring the Launch toolbar
The Launch toolbar provides the ability to centralize and organize application tools onto the 
Avaya IP Agent main application window. The Launch toolbar supports up to 23 customizable 
launch items. Each launch item on the Launch toolbar inherits the associated icon of the launch 
application or a customized icon can be specified. This icon is presented on the launch toolbar 
on the main application window.

This section contians the following topics:

● Enabling the Launch toolbar on page 88

● Configuring the Launch toolbar dialog on page 89

● Example: Using IP Agent Dialer on page 92
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The following example illustrates the Avaya IP Agent main window with the Launch toolbar 
enabled.

Enabling the Launch toolbar
Access to the Launch toolbar and the Configure Launch Toolbar dialog is administered through 
the Launch Toolbar option on the Tools > Program Options > Feature Access panel. 

Selecting the Disable Access - Restrict the user from accessing this feature checkbox 
removes the Launch menu item from View > Toolbars on the main application and from the 
pop-up menu that appears when a user right-clicks over any main application toolbar.

Selecting Disable Modification - Restrict the user from adding, removing or modifying 
properties removes the Configure Launch Toolbar… menu item from View > Toolbars on 
the main application and from the pop-up menu that appears when a user right-clicks over any 
main application toolbar.
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Configuring the Launch toolbar dialog
The Configure Launch Toolbar dialog is where administration of launch item properties is 
assigned. This dialog is used create, modify, delete, test or change the order of appearance of 
launch items on the Launch toolbar.

The following sections describe the use of the Configure Launch Toolbar dialog.

Launch Item Names

To create a new launch item, select the New button or press the Insert key. A new default 
launch item (Launch Item n) appears in the launch item list. You can rename the launch item as 
desired. The specified launch item name appears as a tooltip, provided application tooltips are 
enabled.

To delete a launch item, select that item in the launch item list and then select the Delete button 
or press the Delete key.

To move a launch item, select that item in the launch item list then select either the Up Arrow 
button or the Down Arrow button. To cause the launch item to appear to the left of its current 
toolbar button position, select the Up Arrow button. To cause the launch item to appear to the 
right of its current toolbar button position, select the Down Arrow button.
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Filename or Folder:

Once a new launch item is created, the Filename or Folder: field is enabled. You can directly 
type in a filename or folder name or use the browse folder button to navigate to either a 
filename or folder using the Browse for Folder dialog.

If you select or enter a folder name instead of a filename, the remaining fields on the Configure 
Launch Toolbar dialog will remain disabled and empty because these properties cannot be 
applied to browse folder launch items.

If you directly type the filename or folder in the field, the entry is dynamically validated to verify 
the following executables are not included:

● ipsoftphone.exe

● ipagent.exe

● httpupdate.exe

● xmlutility.exe

● sipsoftphone.exe

● iclarity_exe.exe

● iClarityAdmin.exe

● addprov.exe

● pwreset.exe

Note:
Note: Filename or Folder:, Parameters:, Default Directory:, and Icon Filename: 

support the use of environment variables. You can use environment variables to 
reduce the amount of administration effort by setting a variable to represent some 
consistent value. For example, you can set %PROGRAMFILES% to equal the 
path to the location where IP Agent is installed.

Description:

To optionally provide a short description of the launch item, enter the description in the 
Description field. The description text provides the end-user a hint about the purpose of the 
assigned launch item button. The description text appears on the main application window 
status bar as the user pauses the mouse over the associated launch item button.

Enable Launch Item

To make the launch item button visible and enabled on the Launch toolbar, select the Enable 
Launch Item checkbox.
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Parameters:

To optionally pass additional values at the command line to a given third party application, enter 
those values in the Parameters: field.

In addition to hard parameter values for a given launch item, you can specify two special 
"runtime" determined parameter values. These values are {EXTENSION} and {AGENT_ID}. 
Both {EXTENSION} and {AGENT_ID} are runtime replacement parameter strings. These 
values are described as follows.

{EXTENSION} = Station Login Extension where the Launch Enabled checkbox is enabled and 
the agent has successfully logged into the extension. The launch item button becomes visible 
and the parameter value passed to the third party application is replaced with the end-user’s 
login extension.

{AGENT_ID} = Agent Login ID where the Launch Enabled checkbox is enabled and the agent 
has successfully logged into the ACD using IP Agent. The launch item button becomes visible 
and the parameter value passed to the third party application is replaced with the agent's ID.

Note:
Note: Usage of this field requires that the agent has at least once logged-into the ACD 

with the assigned Agent ID using the IP Agent application Agent login user 
interface.

The button appearing to the right of the Parameters: field, provides the option to insert the 
runtime parameter values {EXTENSION} or {AGENT_ID} directly into the field to avoid errors in 
the runtime parameter text.

Parameters test

When special runtime parameters are included in the Parameters: field, the Enter the 
following parameters data dialog is displayed. If only {EXTENSION} was included, a value 
must be entered into the Extension field before the test can continue. If only {AGENT_ID} was 
included, a value must be entered into the Agent ID field before the test can continue. If both 
{EXTENSION} and {AGENT_ID} were included, both values must be entered before the 
continue button is enabled and the test can be continued.

Below the Extension and Agent ID fields, a preview window appears. As you type a value into 
the field, the associated runtime parameter value is replaced dynamically in the window. 
Whatever literal value is typed in is the value that replaces the string token and is then passed 
to the third party application.

Default Directory:

To assign a default directory to use when executing a launch item, input or select the directory in 
the Default Directory field. This launch item property is important for any third party application 
that internally requires relative paths to its own execution location to reference dependent 
components.
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Icon Filename:

To substitute an icon filename and button for a launch item, specify the filename in the Icon 
Filename: field. This is useful where multiple launch items use the same launched application, 
but where the passed parameters are different. Be certain you specify an icon (*.ico) file.

Test

To verify that the launch item is properly configured, select the Test button. Selecting the Test 
button passes filename / browse folder, parameters, and default directory information to the 
ShellExecute Windows API, which allows you to determine whether the application launches as 
expected.

Example: Using IP Agent Dialer
IP Agent R7 includes a new Win32 console application program called the IP Agent Dialer. The 
executable for this program resides in Avaya\Avaya IP Agent\ipagent.exe. The functionality 
provided by IP Agent Dialer is basically the same as that provided by the Web Dialer toolbar 
except that the dial string value is passed via a command line.

IP Agent Dialer can be used with the launch toolbar to create speed dial buttons. You can set 
the buttons to dial a specific phone number or to look up a database contact string value. The 
illustration in Configuring the Launch toolbar dialog on page 89 shows such an example.

You specify the value to pass to IP Agent in the Parameters: field of the Advanced Properties 
section of the Launch Toolbar dialog. When specifying a database contact string, that value 
must be bracketed with quotes. For example, to look up John Smith in the directory, you must 
enter "John Smith" in the Parameters: field.

Configuring an IP Agent *.reg file with Configuration 
Administration

A contact center system administrator can use Configuration Administration to define a set of IP 
Agent Program Options features, save them into a *.reg registry file, and then push the settings 
to the target PCs. This allows customization of the IP Agent application on multiple PCs without 
the need to configure each PC manually.

Each administered setting represents a configuration that is a collection of registry key/value 
pairs in the HKEY_CURRENT_USER registry hive corresponding to the IP Agent features.

Users with regedit.exe execution privilege may use the generated registry file with IP Agent File 
| Import or Registry Editor directly to configure their IP Agent features.
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This section contains the following topics:

● Enabling Configuration Administration on page 93

● Before you begin on page 93

● Steps to create a *.reg file on page 94

● Steps to modify a *.reg file on page 97

Enabling Configuration Administration
Configuration Administration utilizes the familiar Program Options functionality to define the IP 
agent configurations. Configuration Administration is available to users with Feature Access 
privileges for Configuration Administration, Program Options, Import Settings, and Export 
Settings. Be certain that these privileges are correctly set in the Feature Access panel available 
from the IP Agent Tools > Program Options menu. See Feature Access panel on page 239.

Before you begin
The Configuration Administration window is very similar to the standard Program Options 
window available through the IP Agent Tools > Program Options... menu. The main difference 
is the addition of the Export button in the lower left corner of the window. This button saves your 
selected feature configurations for export to a *.reg file.

The Feature Access Set Password button provides the same functionality as the iClarity 
Administrator Set Password button. When both IP Agent Configuration Administration and 
iClarity Administrator update this password field on the same target PC, the most recent change 
takes effect.

The initial Configuration Admin dialog prompts for an import registry file. This file must be 
generated by the Configuration Administration program. If you specify an import file, the settings 
in the import file together with the default settings are used to populate each feature panel. If 
you do not specify an import file, only the default settings are used. 

Most items on the feature panels are configurable. However, you should consider the current 
settings of the target PC when exporting configurations. For example:

● If the Call Information Display dialog is exported, the Display call information using 
Japanese font setting will have impact on the target PC if that PC is running on the 
Japanese OS.

● If the General Settings panel is exported, the Enable support for auto-answer will be 
ignored by the target PC if the IP Agent is configured as Callmaster VI.

IP Agent Configuration Administration cannot configure location-related items such as database 
file location. 
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If the Program Options dialog is open when you attempt to use Configuration Administration, 
the program displays the Configuration Admin message dialog to prompt you to close 
Program Options and try again.

Steps to create a *.reg file
To use Configuration Administration to create a *.reg configuration file:

1. Select Configuration Admin... from the IP Agent File menu.

The program displays the Open window.

2. Select the Cancel button.

The program displays the Configuration Admin message dialog.
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3. Select the OK button.

The program displays the Configuration Admin window.

4. Navigate through the feature list, setting configuration options as desired.

5. When you change or review a feature configuration, select the Export button to save that 
configuration as a candidate for export to the *.reg file.

The program displays the Configuration Admin message window.

6. Select the OK button to continue.
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7. When you have completed the configuration process, select the OK button.

The program displays the Configuration Admin - Feature Selection window.

8. Verify the configurations you exported appear in the Selected Feature Areas list box. You 
can make necessary changes as follows:

You can highlight multiple fields in the Available Feature Areas and Selected Feature 
Areas list boxes by holding down the Ctrl key and clicking the cursor on each field name.

After the necessary fields have been highlighted, select the right arrow button (>) to move 
the selected fields to the Selected Feature Areas list box

The left arrow button (<) will remove the highlighted field from the Selected Feature Areas 
list box.

The double arrow buttons (<< and >>) will move all fields from one list box to the other.

9. Select the OK button.

The program displays the Save As window.

10. Supply an appropriate file name and directory location and select the Save button.
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Steps to modify a *.reg file
To use Configuration Administration to modify a *.reg file:

1. Select Configuration Admin... from the IP Agent File menu.

The program displays the Open window.

2. Select the *.reg file of interest.

3. Select the Open button.

The program displays the Configuration Admin message box.

4. Select the OK button to open the Configuration Admin window.

5. Modify and save the *.reg file as described in Steps to create a *.reg file on page 94.

Configuring Instant Messaging 
The Instant Messaging feature allows Avaya IP Agent users to send and receive text messages 
with other Avaya IP Agent users. Users can also view the presence state of other users, so that 
it is apparent if a user is online, busy, away, or offline.
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To use this feature, you must have SIP Enablement Services 3.1 or later. For more information 
about configuring your SIP Enablement Services for instant messaging, consult your SIP 
Enablement Services documentation.

This section contains the following topics:

● Enabling Instant Messaging on page 98

● Configuring messaging settings on page 98

Enabling Instant Messaging
To enable the Instant Messaging feature in Avaya IP Agent, do the following steps:

1. From the Avaya IP Agent main window, select Tools > Program Options.

Avaya IP Agent displays the Program Options window.

2. In the General Settings panel, place a check mark in the Enable Instant Messaging 
Feature check box.

3. Select the OK button.

The Instant Messaging feature is enabled.

Note:
Note: You cannot log in to the SIP Enablement Services until you first log off from the 

Avaya communication server and restart the login process. For more information 
about logging in for the Instant Messaging feature, see Registering with the 
Avaya communication server on page 120.

Configuring messaging settings
To configure the Instant Messaging feature, select Instant Messaging > IM Preferences from 
the Avaya IP Agent main window. See Instant Messaging settings on page 247 for more 
information about the options in the Instant Messaging Preferences dialog box.

Configuring and using the Click-to-Dial feature 
The Click-to-Dial feature allows you to use your mouse to automatically dial properly-formatted 
telephone numbers that appear in Web pages. This feature only functions with Web pages 
displayed in Microsoft Internet Explorer.
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This section contains the following topics:

● Enabling the Click-to-Dial feature on page 99

● Using the Click-to-Dial feature on page 99

● Disabling Click-to-Dial on page 100

Enabling the Click-to-Dial feature
The Click-to-Dial feature is automatically installed with Avaya IP Agent. By default, this feature 
is disabled. If you want to enable this feature, see Desktop Integration panel on page 230 for 
more information.

Note:
Note: If you change the setting for the Click-to-Dial feature, you must close and restart 

Internet Explorer for the change to take effect.

Using the Click-to-Dial feature

Note:
Note: To use this procedure, the Click-to-Dial feature must already be enabled.

To use the Click-to-Dial feature to automatically dial telephone numbers from Internet Explorer, 
do the following steps:

1. Use Internet Explorer to open a Web page that contains a telephone number that you want 
to call.

Internet Explorer opens the specified Web page and any properly-formatted telephone 
numbers are yellow-highlighted.

2. Move your mouse cursor over one of the highlighted telephone numbers. If the Web page 
is an unsecured site, the cursor will change to a telephone with a red A. For secured sites, 
the cursor will change to a hand with an extended index finger.

3. Left-click the highlighted telephone number.

Avaya IP Agent automatically dials the selected telephone number.
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Note:
Note: See Using the Web Dialer in Internet Explorer on page 167 for more options.

Disabling Click-to-Dial
If you have Microsoft Internet Explorer add-ins or third party thin client applications which 
conflict with the Avaya Web Dialer you can disable it by using the Change option provided 
under Avaya IP Agent in Control Panel > Add or Remove Programs. 

Note:
Note: You must have administrator privileges to perform this action.

You can also disable the Avaya Web Dialer add-in from within Internet Explorer by choosing 
Tools > Manage Add Ins and removing Avaya Web Dialer. 

Configuring and using the Quick-Dial feature for Microsoft 
Outlook 

The Quick-Dial feature allows you to call contacts in Microsoft Outlook directly through Avaya IP 
Agent.

This section contains the following topics:

● Enabling the Quick-Dial feature on page 100

● Using the Quick-Dial feature on page 101

Enabling the Quick-Dial feature
The Quick Dial feature is automatically installed with Avaya IP Agent. Before you can use Avaya 
IP Agent to call Outlook contacts, you must set the Dialing Options in Outlook to use the Avaya 
component.

To enable Avaya IP Agent to call Outlook contacts, do the following steps:

1. Open Microsoft Outlook.

2. Open the Contacts area of Microsoft Outlook.

3. On the menu bar, select Actions > Call Contact > New Call.
Microsoft Outlook displays the New Call dialog box.
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Note:
Note: If Dialing Properties (Location) has not yet been assigned, you are prompted to 

provide this information before proceeding to the next step. See Handling 
outgoing calls on page 147 for Dialing Properties information.

4. Select the Dialing Options button.

Microsoft Outlook displays the Dialing Options dialog box.

5. In the Connect using line drop-down list box, select one of the following options:

● For a Callmaster VI configuration, select DEFINITY/Line.

● For all other configurations except Instant Messaging Only, select Avaya IP/Line.

● For Instant Messaging Only, an informational dialog appears with this message: "One 
of the components of the telephone device driver is missing. Use Windows Control 
Panel to set up the device driver properly."

6. Select the OK button.

The Dialing Options dialog box is closed.

7. In the New Call dialog box, select the Close button.

Microsoft Outlook will now route all future contact calls through Avaya IP Agent.

Using the Quick-Dial feature
After you have enabled the Quick-Dial feature to use Avaya IP Agent, you can now call contacts 
directly from Microsoft Outlook.

To call a contact in Microsoft Outlook, do the following steps:

1. Open Microsoft Outlook.

2. Open the Contacts area of Microsoft Outlook.

3. Create or find a contact that you want to call.

The contact must have a defined telephone number.

4. Right-click the contact entry and select Call from the resulting popup menu.

Microsoft Outlook displays a New Call dialog box with the contact name and telephone 
number.

5. Select the Start Call button.

Avaya IP Agent begins the telephone call to the selected contact and a Call Information 
Panel is displayed in the Avaya IP Agent main window.

Note:
Note: You can select the End Call button when you are finished.
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Configuring the Emergency Call Handling Service 
The Emergency Call Handling Service (E911) allows IP Endpoints to use numbers that connect 
to emergency services, such as 911 in the United States. When used, this feature reaches only 
the emergency service in the Public Safety Answering Point area where the Avaya 
communication server is located.

! WARNING:!

WARNING: Because IP Endpoints do not dial to and connect with local emergency services 
when dialing from remote locations, agents or extensions in remote locations 
should not use this feature for emergencies.
Avaya Inc. is not responsible or liable for any damages resulting from misplaced 
emergency calls made from an Avaya endpoint. Your use of this product indicates that 
you have read this advisory and agree to use an alternative telephone to dial all 
emergency calls from remote locations.

This section contains the following topics:

● Administering the Avaya communication server for Emergency Call Handling on page 102

● Administering Avaya IP Agent for Emergency Call Handling on page 102

Note:
Note: For Avaya Telephone-DCP and Callmaster VI configurations, this feature is not 

configured through Avaya IP Agent. If an emergency call is dialed on a telephone 
while this configuration is in use, the emergency call is treated normally by the 
Avaya communication server.

Note:
Note: This feature is not available for IP Telephone configurations.

Administering the Avaya communication server for Emergency 
Call Handling

See the documentation for your Avaya communication server for information on configuring the 
Emergency Call Handling feature.

Administering Avaya IP Agent for Emergency Call Handling 
This section provides the procedure for configuring Avaya IP Agent to use the Emergency Call 
Handling Service.
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Before you begin

The Avaya communication server to which you are connecting must have each extension 
properly configured for the Emergency Call Handling Service before this feature can be used 
through Avaya IP Agent.

Steps

To configure the Emergency Call Handling Service in Avaya IP Agent:

1. Start Avaya IP Agent.

Windows displays Avaya IP Agent and the Login window.

2. In the Login window, select the Settings button.

Avaya IP Agent displays the Settings dialog box.

3. Select the Emergency tab.

4. Place a check mark in the Enable emergency call handling feature check box.

5. Select the location that will be sent through the Avaya communication server for calls 
placed to emergency services:

● Your extension number XXXXXXX - Select this option button if you want your 
extension number to be sent to emergency personnel. This selection is best used for 
those stations within the contact center.

● Telephone number - Select this option button if you want a telephone number other 
than your extension sent to emergency services. Specify the telephone number to 
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send in the provided field. For example, enter a number corresponding to a Digital 
Communications Protocol (DCP) telephone in your vicinity that has a fixed, known 
location so that emergency personnel know where to respond. If you are unsure of a 
number to enter, see your system administrator.

6. Select the OK button.

7. In the Login dialog box, select the Login button.

Any calls to emergency services will show the selected telephone number.

Configuring Avaya IP Agent for VPN configurations 
If you are using a VPN, you may need to specify a local IP address for proper network 
communication. Set this address through the Login Settings dialog box.

Steps
To set the local IP address for a VPN configuration:

1. Start Avaya IP Agent.

Windows displays Avaya IP Agent and the Login window.

2. In the Login window, select the Settings button.

Avaya IP Agent displays the Settings dialog box.
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3. Select the Advanced tab.

Avaya IP Agent displays the Advanced tab panel:

4. Place a check mark in the Use the following IP address (as displayed by the VPN 
client) check box.

Avaya IP Agent enables the associated IP address field.

5. In the IP address field, enter the local IP address to be used by the VPN client.

6. Select the OK button.

All subsequent login attempts to the Avaya communication server will cause this dialog 
box to be displayed.

Installing the Quality of Service Packet Scheduler 
Quality of Service (QoS) can help improve voice transmission on your network and personal 
computer when using Voice-over-IP. However, before you can use Quality of Service, you must 
install the QoS Packet Scheduler.

Note:
Note: The QoS Packet Scheduler for Windows is automatically installed when Avaya IP 

Agent is installed, but can be excluded from the installation via the Custom Setup 
option in the installation program.
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Before you begin
You should read and understand the following items before installing the Quality of Service 
Packet Scheduler:

● Some VPN client applications have conflicts with the Packet Scheduler. If your VPN 
exhibits problems, remove the QoS Packet Scheduler from your personal computer.

● If you are using QoS in conjunction with a firewall, the range of ports for QoS set up on the 
Avaya communication server must overlap the range of firewall ports specified in Avaya IP 
Agent by 100 ports. If these ranges do not overlap by 100 ports, QoS is not used by Avaya 
iClarity IP Audio and transmissions are done within the range of firewall ports.

● Many Avaya IP telephones are equipped with internal QoS. For information about QoS in 
IP telephones, see the documentation for your specific telephone.

Configuring Alternate Gatekeeper on Avaya 
communication servers 

Use the Alternate Gatekeeper feature when an IP Endpoint registers with an Avaya 
communication server. When Avaya IP Agent registers with an Avaya communication server, a 
C-LAN circuit pack IP address is sent to the IP Endpoint. If registration is successful, the Avaya 
communication server sends back the IP addresses of all C-LAN circuit packs defined in the 
same network region. Avaya IP Agent can use these addresses as alternatives if call signaling 
on the original C-LAN circuit pack fails.

Tip:
Tip: You can better control the usage and workload of C-LAN circuit packs by creating 

network regions.

Alternate Gatekeeper configuration
For information on defining Alternate Gatekeeper addresses, refer to your Avaya 
communication server documentation.
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Configuring server load balancing across gatekeepers 
Load balancing for an Avaya communication server refers to the ability of distributing IP 
Endpoint traffic across all C-LAN circuit packs that are defined within the same network region.

Load Balancing configuration
Load balancing is achieved by defining all of the IP addresses of the C-LAN circuit packs to be 
part of a network region on an Avaya communication server. After this has been completed, IP 
Endpoints registering with the Avaya communication server will be automatically assigned to 
the different C-LAN circuit packs in sequential order. This helps distribute IP Endpoints evenly 
amongst the C-LAN circuit packs.

! Important:
Important: It is important that you use the network region feature to control which C-LAN 

circuit packs are available when one pack loses connectivity. Without proper 
region assignments for your C-LAN circuit packs, Avaya IP Agent could attempt 
to connect to a C-LAN circuit pack that has not been properly configured or is not 
intended for use with Avaya IP Agent.

For more information on defining C-LAN circuit packs within a network region, refer to the 
documentation for your Avaya communication server.

Load Balancing documentation
For installation procedures and configuration information for the C-LAN and IP Media Processor 
circuit packs, see Administration for Network Connectivity for your Communication Manager, 
MultiVantage, or DEFINITY system.
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Chapter 5: Starting and Stopping Avaya IP 
Agent 

This chapter explains how to begin using Avaya IP Agent. It contains the following sections:

● Starting Avaya IP Agent on page 109

● Initializing IP Endpoint configurations on page 110

● Initializing Callmaster VI configurations on page 119

● Registering with the Avaya communication server on page 120

● Logging in as an agent (EAS) on page 123

● Logging in as an agent (non-EAS) on page 125

● Logging out of Avaya IP Agent on page 126

● Exiting Avaya IP Agent on page 127

● Using alternate user interfaces on page 127

Starting Avaya IP Agent 
This section provides the procedure for starting the Avaya IP Agent application.

Steps for starting Avaya IP Agent
To start Avaya IP Agent:

1. Select the Start button from the Windows task bar.

2. Do the following step that is appropriate for your situation:

● If you upgraded a previous version of Avaya IP Agent, select Programs > Avaya IP 
Agent.

● If you are using a new installation of Avaya IP Agent, select Programs > Avaya.

3. Select Avaya IP Agent - <language>.

The Avaya IP Agent window is displayed. Although Avaya IP Agent is now running, your 
extension is not yet registered with the Avaya communication server.
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4. If this is the first time that Avaya IP Agent is run, you must follow the procedure for your 
type of configuration:

- For IP Endpoint configurations, go to Initializing IP Endpoint configurations on 
page 110.

- For Callmaster VI configurations, go to Initializing Callmaster VI configurations on 
page 119.

Initializing IP Endpoint configurations 
If you have performed a new installation of Avaya IP Agent for an IP Endpoint configuration, the 
Configuration Wizard is displayed when you first start Avaya IP Agent. The Configuration 
Wizard prompts you to enter the necessary configuration information for registering with an 
Avaya communication server and for Voice-over-IP audio performance.

Steps for using the Configuration Wizard
To configure your installation of Avaya IP Agent to register with an Avaya communication 
server:

1. Start Avaya IP Agent.

Avaya IP Agent starts the Configuration Wizard automatically.

2. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

3. Select the appropriate option:

● Log into Avaya call server - Select this option for Road Warrior, Telecommuter, and 
Avaya Telephone configurations.

If you are using an Avaya Telephone configuration, place a check mark in the Control 
an Avaya telephone check box.

● Log into Avaya IP Telephone - Select this option for IP Telephone configurations. Do 
not select this option if you will be using the Avaya Telephone-IP configuration.
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4. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

5. Enter the necessary information in the following fields:

● Extension - The extension number of the station that will be used with Avaya IP 
Agent.

● Password - The numeric password associated with the specified extension.

● Remember password for next login session - Place a check mark in this check box 
if you do not want to enter your password each time you register with the Avaya 
communication server. If you are concerned with the possibility of unauthorized 
persons assuming this identity, leave this check box blank.

● IP Address - Enter the IP address of the IP telephone that will be used with Avaya IP 
Agent. If you have entered an extension number, select the Discover button to 
automatically populate the IP address of the IP telephone.

6. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

7. In the Primary Server Address field, enter the domain name or IP address of the Avaya 
communication server C-LAN circuit pack that will be used for connections.

8. In the Alternative Server Addresses field, you have the option of defining other C-LAN 
circuit pack addresses that will be used should the primary address fail. This field is 
optional. 

Tip:
Tip: The alternative server addresses should reside in the same network region as the 

primary server address. For more information on defining network regions, see 
the documentation for your Avaya communication server.

IP Telephone configurationRoad Warrior / Telecommuter /
Avaya Telephone configurations
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9. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

10. Select the pre-defined Dialing Location from the drop-down list. This selection will control 
certain telephony properties such as area code, outside line access, and so forth.

Selecting the Properties button will display the configuration for the selected dialing 
location.

11. Select the Next button.

Avaya IP Agent displays a warning message regarding the Emergency Call Handling 
feature.

Note:
Note: For the IP Telephone configuration, the Emergency Call Handling window is not 

displayed. If you are using the IP Telephone configuration, proceed to Step 17.

12. Read the text of this warning completely and select the I Agree button if you understand 
and agree to the conditions stated in this message.

If you select the I Disagree button, the Configuration Wizard will exit.

After you select I Agree, Avaya IP Agent displays the next window of the Configuration 
Wizard.
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13. If you want to enable this feature, place a check mark in the Enable Emergency Call 
Handling feature check box.

14. If you enabled the Emergency Call Handling feature, select the location that will be sent 
through the Avaya communication server for calls placed to emergency services:

! WARNING:!

WARNING: Because IP Endpoints do not dial to and connect with local emergency services 
when dialing from remote locations, agents or extensions in remote locations 
should not use this feature for emergencies.

Avaya Inc. is not responsible or liable for any damages resulting from misplaced 
emergency calls made from an Avaya endpoint. Your use of this product indicates that 
you have read this advisory and agree to use an alternative telephone to dial all 
emergency calls from remote locations.

● Your extension number XXXXXXX - Select this option button if you want your 
extension number to be sent to emergency personnel. This selection is best used for 
those stations within the contact center.

● Telephone number - Select this option button if you want a telephone number other 
than your extension sent to emergency services. Specify the telephone number to 
send in the provided field.

This selection must be compatible with the station definition on the Avaya communication 
server in the IP Emergency Calls field. Failure to use the same setting as the Avaya 
communication server will result in login failure for this extension.

15. Select the Next button.

For Road Warrior and Telecommuter configurations, Avaya IP Agent displays the next 
window of the Configuration Wizard.

This window is not displayed for Avaya Telephone-DCP configurations. If you are using the 
Avaya Telephone-DCP configuration, proceed to step 17.
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16. Select the type of IP Endpoint configuration that will be used for this installation of Avaya 
IP Agent.

If you select the Road Warrior (Voice over IP) option, you will also need to specify the 
network throughput available in the Bandwidth Setting field. Select the Help button for 
specific information about the different bandwidth settings.

! Important:
Important: The quality of the audio in a Road Warrior configuration is dependent on many 

factors. See Voice-over-IP considerations on page 28 for specific information.

If you select the Telecommuter option, you must specify the telephone or extension 
number that will be used to make and receive calls with Avaya IP Agent.

Note:
Note: For Road Warrior configurations, two lights are displayed in the status bar of the 

main window. These lights indicate the status of the network connection. If these 
lights turn red, your network is having connectivity problems or you have chosen 
a bandwidth that cannot be supported by your network connection.

17. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

You have completed the process for specifying the settings that will be used to connect 
and function with the Avaya communication server. If you selected to install the Instant 
Messaging feature of Avaya IP Agent, you will configure the settings to connect to the SIP 
Enablement Services. If you did not install the Instant Messaging feature, go to step 27.

18. To configure instant messaging settings, select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

19. Select the appropriate option for configuring the Instant Messaging feature:
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● Yes, continue with configuration - Select this option if you want to configure the 
instant messaging settings at this time.

● No, I will configure the instant messaging feature later - Select this option if you 
want to configure the instant messaging settings later through Program Options.

● I do not want to use Avaya IP Agent instant messaging feature - Select this option 
if you do not want to use instant messaging. You will be able to enable the Instant 
Messaging feature later through Program Options.

20. After you have made your selection for instant messaging configuration, select the Next 
button.

If you selected to configure the Instant Messaging feature, you are presented with a 
window allowing entry of the SIP Enablement Services user name and password.

If you selected to postpone or bypass configuration of the Instant Messaging feature, go to 
step 26.

21. In the User Name field, enter the SIP Enablement Services user ID to use for instant 
messaging.

! Important:
Important: The user name is case-sensitive. If a user has been defined as 

agent001@mycompany.com, you must enter the name in Avaya IP Agent exactly 
as it was on the SIP Enablement Services. For example, if you entered 
Agent001@mycompany.com, this would not be a match.

22. In the Password field, enter the password that corresponds to the user name that you 
entered in step 21.

23. If you want Avaya IP Agent to retain your instant messaging password each time it is 
started, place a check mark in the Remember password for next login session check 
box.

24. Select the Next button.

25. In the Server Address field, enter the IP address or domain name of the SIP Enablement 
Services.

For example, the address could be an IP address such as 123.123.123.123 or a domain 
name such as ses.mycompany.com.

26. Select the Next button.

The Configuration Wizard displays a window indicating that you will now configure the 
audio properties of Avaya IP Agent.

Note:
Note: You must complete this section before you will be allowed to register with the 

Avaya communication server.
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27. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard. This window varies 
based on the configuration type.

28. In the Select a playback device field, select the appropriate device that Avaya IP Agent 
should use for audio output.

29. If you are setting a Road Warrior configuration, select the appropriate device on your 
personal computer in the Select a recording device list. For other configurations, this 
drop-down list box is not displayed and you can continue to the next step.

30. If your personal computer contains multiple sound devices and you have specified the 
Telecommuter configuration, you can choose to have Avaya IP Agent play ringing sounds 
through another sound device. To do so, place a check mark in the Enable a secondary 
ring device check box. Then, select the appropriate sound device from the Select a 
secondary playback device drop-down list box.

31. If you want to use agent greetings in the Telecommuter or Avaya Telephone 
configurations, place a check mark in the Play greetings via Avaya Switcher II check 
box.

! Important:
Important: The Avaya Switcher II connects directly to both your telephone and personal 

computer. If you are not using an Avaya Switcher II, you will not be able to 
properly record and use agent greetings in Telecommuter and Avaya Telephone 
configurations.

For information about using an Avaya Switcher II, see:

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf

32. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard. If you are setting a 
Telecommuter or Avaya Telephone configuration, go to step 35.

33. If you are setting a Road Warrior configuration, select the device to use for transmitting 
and receiving audio:

Road Warrior (VoIP) Telecommuter Telecommuter / Road Warrior
with multiple sound devices

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf
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● Headset or Handset - Select this option if you will be using a headset (Universal 
Serial Bus or attached to the personal computer sound card) or a special handset that 
connects to your personal computer.

● PC Microphone and PC Speakers - Select this option if you will be using a 
microphone and speaker system attached to your personal computer.

● Half-Duplex Sound Device - Select this option if it is available because Avaya iClarity 
IP Audio will adjust its performance for this type of sound device. Avaya recommends 
that full-duplex sound devices be used for Voice-over-IP communications.

34. Select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

35. Follow the instructions listed in this window to set the optimal volume level for the audio 
output of your personal computer sound device.

36. After you have set the volume level, select the Next button.
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37. If you selected the Avaya Switcher II feature, Avaya IP Agent displays a window for setting 
the microphone playback volume of this unit. If you did not enable this feature, proceed to 
step 42.

38. After you have set the microphone playback volume, select the Next button.

Avaya IP Agent displays the next window of the Configuration Wizard.

39. If you are administering a Road Warrior configuration, set the microphone recording level.

If you want Avaya iClarity IP Audio to automatically adjust the recording levels, select the 
top option. 

If you want to use a steady and consistent level of volume for recording, select the bottom 
option.

You must set the initial level by moving the slider bar so that when you speak into your 
microphone, you can see green boxes in the Audio meter. These boxes should not 
exceed the boundaries marked by the caret characters.
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40. Select the Next button.

Avaya IP Agent displays a test window.

41. Select the Test button to set the level of background noise in your environment.

42. Select the Next button.

Avaya IP agent displays the last window of the Configuration Wizard.

43. If you do not need to go back and readjust your audio settings, select the Finish button to 
complete the Configuration Wizard.

Initializing Callmaster VI configurations 
If you have completed a new installation of Avaya IP Agent for a Callmaster VI configuration 
(only available on Windows XP), the Select Communication Port window is displayed when 
you first start Avaya IP Agent.

In the drop-down list box, select the communications (COM) port that is used to connect the 
personal computer to the Avaya Callmaster VI telephone. When you have specified the COM 
port, select the OK button to continue.
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Registering with the Avaya communication server 
Before you can use Avaya IP Agent, you must register Avaya IP Agent with the Avaya 
communication server and register your extension through the Login window. Once you are 
registered with the Avaya communication server, you can make yourself available for ACD calls 
by performing an agent login. 

! Important:
Important: Avaya Callmaster VI configurations do not register with the Avaya communication 

server as described in this section. Registration is automatic through the Avaya 
Callmaster VI telephone. If you are using an Avaya Callmaster VI configuration, 
proceed to Logging in as an agent (EAS) on page 123.

This section provides the procedure for registering with an Avaya communication server and 
registering with a SIP Enablement Services for the Instant Messaging feature. This must be 
done so that you can use Avaya IP Agent for placing and answering calls in an IP Endpoint 
configuration and for using the Instant Messaging feature.

Note:
Note: If you use IP Agent in the Instant Messaging Only configuration, you register with 

SIP Enablement Services only.

Before you begin
If you attempt to log in to an Avaya communication server that is not a supported DEFINITY, 
MultiVantage, or Communication Manager system, Avaya IP Agent displays an Invalid Station 
Type error message. For a list of supported systems, see Avaya communication server on 
page 64.

Setting default registration information
The Settings button on the Login window can be used to configure more advanced features 
that are used with Avaya IP Agent and the Avaya communication server. For more information 
on these settings, see Login Settings dialog box on page 240.
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Steps for registering with a server
To register with the Avaya communication server:

1. When you start Avaya IP Agent, the Login window is displayed. If this window is not 
displayed, select File > Station Login from the Avaya IP Agent main window.

Avaya IP Agent displays the Login window for your IP Endpoint configuration.

2. In the Extension field, enter your extension, which has been administered for Avaya IP 
Agent on the Avaya communication server.

3. In the Password field, enter the numeric password for the specified extension.

4. In the Configuration field, select the appropriate IP Endpoint configuration.

5. Do one of the following steps based on your IP Endpoint configuration:

6. Depending on the type of IP Endpoint configuration you are using, ensure that the correct 
information is specified in the appropriate field:

● Telephone At (Telecommuter) - This is the telephone or extension number that will 
receive incoming calls. This number cannot be the same as the number entered in the 
Extension field. The Avaya communication server administrator will have created a 
new extension to support voice communication.

● Bandwidth Setting (Road Warrior) - Select a bandwidth that is available through the 
network connection for this personal computer.

● Dialing Location - Select the entry that contains the appropriate telephony properties 
for your current location.

7. If you do not want to enter your password each time you register with the Avaya 
communication server, place a check mark in the Remember password for next login 
session check box. If you are concerned with the possibility of unauthorized persons 
registering as this extension, leave this check box blank.

Telecommuter / Road 
Warrior / Avaya Telephone

IP Telephone Instant Messaging Only

In the Call Server Address 
field, enter the IP Address or 
name of the Avaya 
communication server.

In the Telephone IP Address 
field, enter the IP address of 
your IP telephone. 
Alternatively, select the 
Discover button to query the 
Avaya communication server 
for the IP address of the 
specified extension.

In the IM Server Address 
field, ensure that the IP 
address or domain name of 
the SIP Enablement Services 
is entered correctly.
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8. If you want to automatically register with the Avaya communication server and the SIP 
Enablement Services when Avaya IP Agent is started at a later time, enable the 
Automatically log in if possible when application restarts check box. You must have 
successfully registered with the Avaya communication server at least once in the past to 
use this option.

9. To log in to the SIP Enablement Services for instant messaging, place a check mark in the 
Log into Avaya instant messaging server check box. 

Note:
Note: You cannot log in to instant messaging after registering with the Avaya 

communication server. Instant messaging login is always done at the same time 
as when you register with the Avaya communication server.

10. Select the Login button. When you successfully register with the Avaya communication 
server, the controls in the Avaya IP Agent main window are enabled.

11. If you are using the Telecommuter or IP Telephone configuration, do the appropriate action 
shown in the following table:

Telecommuter IP Telephone

Avaya IP Agent displays the Verify 
Telephone Number dialog box upon 
successful registration with the 
Avaya communication server. When 
you first start using Avaya IP Agent, it 
is important that you make some test 
calls to verify that you have set up 
your connection properly.

Press # on the IP telephone key pad 
to allow Avaya IP Agent to log in to 
the IP telephone.
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Registering while using a VPN 
If the VPN compatibility feature of Avaya IP Agent has been enabled through the Login 
Settings dialog box, the VPN Configuration In Effect dialog box is displayed during all 
subsequent login attempts to the Avaya communication server:

This dialog box contains the following options:

● Disable the user of local IP address assigned by the VPN client - Select this option to 
deactivate the VPN feature for this and all subsequent login attempts. To re-enable this 
option, you must follow the steps under Configuring Avaya IP Agent for VPN 
configurations on page 104.

● Change the local IP address used by this application - With this option, the VPN 
feature remains active. However, you can change the IP address that will be used by the 
VPN client.

● Continue with the current settings - Select this option to retain the current IP address 
settings for the VPN client and continue the login process.

When you have selected the appropriate option, press the OK button to continue the login 
process.

Logging in as an agent (EAS) 
After registering with the Avaya communication server, you can, as an extension, receive calls 
through Avaya IP Agent. However, to receive calls from a skill, you need to log in as an agent of 
that skill. This section provides the procedure for logging in to Avaya IP Agent as an agent. This 
procedure is for logging in to Avaya communication servers that use the Expert Agent Selection 
(EAS) feature.
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Steps for logging in (EAS)
To log in to Avaya IP Agent as a member of an ACD skill:

1. In the Avaya IP Agent window, select the Login button.

Avaya IP Agent displays the Agent Login dialog box.

2. In the Agent Login dialog box, enter your agent number and password in the appropriate 
fields.

3. Select the Login button.

If you are using the Telecommuter, Avaya Telephone, or IP Telephone configuration, the 
extension specified in the Login window will ring. For Road Warrior (VoIP) and Avaya 
Callmaster VI configurations, a line appearance will be created.

Note:
Note: If you do not answer your telephone immediately or if you entered the wrong 

number for the voice connection, Avaya IP Agent displays an error message. 
Acknowledge the error message by selecting the OK button and then repeat the 
login procedure.

4. Answer the telephone.

You will hear a confirmation tone, the buttons on the agent toolbar are enabled, and you 
will be automatically put in the AUX-work mode.

5. To leave the AUX-work mode, select either the Auto-In or Manual-In button.

For more information about Auto-In and Manual-In work modes, see Selecting an agent 
work mode on page 131.

You are now ready to begin receiving and making calls.
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Logging in as an agent (non-EAS) 
After registering with the Avaya communication server, you can, as an extension, receive calls 
through Avaya IP Agent. However, to receive calls from a split, you need to log in as an agent of 
that split. This section provides the procedure for logging in to splits through Avaya IP Agent. 
This procedure is for logging in to Avaya communication servers that do not have the Expert 
Agent Selection (EAS) feature.

Before you begin
In order for an agent to be able to log in to a split, Avaya IP Agent must be configured to support 
a non-EAS Avaya communication server. To change the Avaya IP Agent configuration:

1. Select Tools > Program Options.

2. From the Program Options window, select the ACD Agent item from the list box.

3. Remove the check mark from the Configure program for EAS agent support check box.

4. Ensure that a check mark is present in the Prompt for agent ID and password during 
agent login check box.

Note:
Note: If this feature is not enabled, you must enter your agent ID and password through 

the telephone key pad.

5. Select the OK button.

6. Close Avaya IP Agent by selecting File > Exit from the main window.

7. Restart Avaya IP Agent.

Steps for logging in (non-EAS)
To log in to Avaya IP Agent as a member of an ACD split:

1. In the Avaya IP Agent window, locate the Agent toolbar. This toolbar lists the splits 
assigned to this station.

If this toolbar is not visible, select View > Toolbars > Agent.
2. On the Agent toolbar, select the split you want to log into.

Avaya IP Agent displays a menu with a Login option.
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3. Select the Login option.

Avaya IP Agent displays the Agent Login dialog box.

4.  If your extension requires a password, enter the password for this split.

If you are logging in to a split that consists of only one or two digits, you may be required to 
place one or more zeros in front of the split number. This is dependent on the configuration 
of your Avaya communication server. See the documentation for your Avaya 
communication server.

5. Select the Login button.

6. Select the split from the Agent toolbar again.

7. Select the appropriate work mode from the resulting menu.

8. For each split you want to log in to, repeat this procedure.

An agent can log in to a total of four splits.

Logging out of Avaya IP Agent 
This section provides the procedure for logging out of Avaya IP Agent as an agent.

Steps
To log out of Avaya IP Agent:

1. Select the Logout button on the agent toolbar, or select Agent > Agent Logout from the 
menu bar.

If the Avaya communication server has been configured to require logout reason codes, 
Avaya IP Agent displays a prompt in the status bar for entry of the reason code.

2. Enter your logout reason code through the keyboard or the Dial Pad.
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Exiting Avaya IP Agent 
This section provides the procedure for exiting the Avaya IP Agent application.

Steps
To exit Avaya IP Agent and log out of the Avaya communication server:

1. After you have logged out as an agent, select File > Exit from the main window.

The Avaya IP Agent main window closes and your extension is logged out of the Avaya 
communication server.

Using alternate user interfaces 
This section provides information and procedures for the alternate user interfaces that are 
available in Avaya IP Agent.

In many contact center environments, agents use many different applications simultaneously. 
This can lead to overlapped application windows on the Windows desktop. This can cause 
difficulties in accessing or using the necessary application windows quickly and efficiently. To 
help overcome this problem, Avaya IP Agent provides three alternate user interfaces that use 
much less space on the Windows desktop than the default main window. The following figure 
compares interface size:

Default main window Alternate user interface example
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Note:
Note: The procedures in this document are written for the default main window. You will 

not be able to exactly follow these procedures when you are using an alternate 
user interface. However, the Program Menu button on the right side of the 
interface allows you to access the most commonly used features in Avaya IP 
Agent. Also, the shortcut key combinations for Avaya iP Agent do not function 
while you use an alternate user interface.

AutoAnswer interface

This interface uses the least amount of space, and is intended for agents using the Auto-In and 
Auto-answer features. Call-handling buttons, such as Transfer, Hold, and Release are 
present. Buttons for agent work modes and Avaya IP Agent features are not available in this 
interface.

Mini interface

This interface is slightly wider than the AutoAnswer interface and is intended for the contact 
center agent who determines the necessary work mode, such as AUX (Auxiliary Work) and 
ACW (After-Call Work). In addition to the call-handling buttons, this interface also contains 
buttons for any agent work modes assigned to this extension.

Titlebar interface

When an agent is on a call, this interface is the largest of the alternate interfaces. It includes 
call-handling buttons, agent work modes buttons, and buttons used to access other Avaya IP 
Agent features, such as the Contact Directory and Contact History window.

Selecting an alternate interface
This section provides the steps for selecting one of the three alternate user interfaces available 
with Avaya IP Agent.
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Steps

To select an alternate user interface.

1. From the Avaya IP Agent main window, select View > Alternate Interfaces.

2. From the branching menu, select the interface that you want to use:

● AutoAnswer
● Mini Interface
● Titlebar
Avaya IP Agent displays the selected interface.

Accessing features
To access Avaya IP Agent features that are not represented by a button, click the Program 
Menu button on the far right side of the interface. A menu containing login and logout options, 
work modes, online help items, and features is displayed.

Returning to the main interface
To return to the Avaya IP Agent main window from an alternate user interface, click the 
Maximize button next to Program Menu button on the right side of the interface.

Returning to a previously-used alternate user interface
If you have previously selected an alternate user interface and you have returned to the Avaya 
IP Agent main window, you can quickly change back to the previously-used alternate user 
interface by using the Ctrl+u key combination.

This key combination is helpful when you restart your personal computer and then start Avaya 
IP Agent, which always opens with the main window as the default view.
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Removing alternate user interfaces
If you do not want these interfaces available for use, remove all files located in the following 
directory:
<install-directory>\Avaya\Avaya IP Agent\Skins
If you want only one interface available to agents, leave that file in the \Skins directory and 
delete the other files.

Note:
Note: Avaya IP Agent cannot recreate these files once they have been deleted.

Renaming alternate user interfaces
If you want to change the name of an alternate user interface, rename the necessary file in the 
following directory:
<install-directory>\Avaya\Avaya IP Agent\Skins

Note:
Note: Because the names of these menu items are derived from actual filenames, 

these items will appear in English for international versions of Avaya IP Agent. To 
cause these menu items to appear in a specific language other than English, you 
must use a language-specific version of Windows and then rename the files as 
needed.
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Chapter 6: Avaya IP Agent basic 
operations

This chapter contains information on the basic operations of Avaya IP Agent.

This chapter includes the following topics:

● Selecting an agent work mode on page 131

● Handling incoming calls on page 133

● Transferring a call on page 139

● Conferencing calls on page 142

● Handling outgoing calls on page 147

● Using instant messaging on page 160

● Using the Web Dialer in Internet Explorer on page 167

Selecting an agent work mode 
During the course of placing calls, receiving calls, and performing work associated with those 
calls, work modes are used to indicate the availability of the agent or the work being performed.

Definitions of agent work modes

Auto-In and Manual-In

The Auto-In and Manual-In buttons are used to place an agent in the AVAIL (Available) work 
mode so that the agent can receive calls. 

If an agent is in Auto-In mode and completes a call, the agent is automatically available to 
receive another call, or can be placed in After-Call Work (ACW) mode for an administered 
length of time. When the timed ACW interval expires, the agent is automatically returned to 
available status. If the agent tries to change agent modes while active on a call, the change is 
not made until the agent disconnects from the call.
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If the agent is in Manual-In mode and completes a call, the agent is automatically placed in 
After-Call Work (ACW) mode. To become available to receive another ACD call, the agent must 
manually select the Auto-In or Manual-In mode. If the agent tries to change agent modes while 
not on an active call, the change takes place immediately.

ACW (After-Call Work)

Agents use this work mode to indicate that tasks related to the previous call are being 
performed. This button is not usually used in conjunction with the Auto-In feature because 
agents with the Auto-In feature are made available for a new call when the current call is 
completed.

This work mode can be selected while the agent is on an active call. The change will not occur 
until the current call is finished and released. This work mode may not function correctly if the 
agent uses it while in Auto-In mode.

AUX (Auxiliary Work)

Agents use this work mode to indicate that they cannot receive calls. Usually, this indicates that 
the agent is not in the proximity of the telephone because of meals, approved periods of 
inactivity, meetings, training, and so forth.

It is possible for multiple Auxiliary Work modes to be assigned to an extension as each can 
possess a different reason code to indicate the various situations that an agent cannot receive 
calls.

This work mode can be selected while the agent is on an active call. The change will not occur 
until the current call is finished and released.

Changing work modes
The agent work modes can be changed through the following methods:

● Using shortcut keys - See Shortcut keys on page 263.

● Selecting the associated work mode button on the agent toolbar - See Agent toolbar on 
page 217.

● Selecting the work mode from the Avaya IP Agent System Tray icon - See System Tray 
icon on page 221.

● Selecting the work mode from the Agent menu in the main window - See Agent menu on 
page 211.

Note:
Note: When a work mode is active, the timer, which is displayed in the Call Information 

Panel, displays the total time that the agent has been in the selected work mode. 
To disable this timer, see How to remove the call timer on page 283.
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Handling incoming calls
This section describes those functions that you will be using every day when you receive an 
incoming call at your station, including answering a call and holding a call.

This section includes the following topics:

● Answering a call on page 133

● Holding a call on page 136

● Releasing a call on page 137

● Dropping a call on page 138

Answering a call 
Answering a call depends on how the Avaya communication server and the network are 
administered. Each contact center environment is different, which can affect the way agents 
answer calls. Avaya suggests that each contact center evaluate its configuration and instruct 
agents on the best way to answer calls with Avaya IP Agent. There are too many possible 
Avaya IP Agent configurations to list them in this document. The following are some suggested 
procedures on answering calls for different configurations.

Telecommuter

Configuration settings for Telecommuter
The following list provides the options to set for this configuration:

● Agent Administration for auto-answer is set to station or none. 

● Station Administration for auto-answer is set to none. 

● Station Administration has service link set to as-needed. 

● Each time a call is received, the analog or DCP telephone that provides the voice path will 
ring. The personal computer will also emit a ringing sound if you have configured Avaya IP 
Agent to do so.

● Your Central Office (CO) must have the Answer Supervision feature. Contact your 
telecommunication provider for more information.

Steps for answering Telecommuter calls
To answer a call for this configuration:

1. The agent should wait for the telephone to ring and then answer it. Answering of the 
telephone will automatically be detected through Avaya IP Agent.
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2. After the call is completed and the calling party disconnects from the call, or after the agent 
selects Release for that call, the agent should hang up the telephone if no more calls are 
ringing on the Avaya IP Agent screen.

3. If there is another incoming call indicated on the screen, the agent should not hang up the 
telephone, but select the Answer button for the new call appearance on the Avaya IP 
Agent screen. The agent is then connected to the new call. The previous call is placed on 
hold.

Note:
Note: If an incoming call is displayed in the Avaya IP Agent main window before the 

telephone rings, the agent must wait for the telephone set to ring before 
answering.

Telecommuter (Auto-Answer)

Configuration settings for Telecommuter (Auto-Answer)

The following list provides the options to set for this configuration:

● Agent Administration for auto-answer is set to station, ACD, or all. 

● Station Administration for auto-answer is set to ACD or all. 

● Station Administration has the service link set to permanent. 

● During the event of agent login, the telephone will ring to deliver the login confirmation 
tone. 

Steps for answering Telecommuter (Auto-Answer) calls

To answer a call for this configuration:

1. The agent should answer the telephone and do not return it to the on-hook state for the 
remainder of the shift for that agent.

If the telephone is accidentally cut off or placed on-hook, the Avaya communication server 
rings the telephone when it has a call to deliver. The agent must answer by picking up the 
handset.

2. As with any auto-answer telephone, the Avaya communication server will provide a zip 
tone (a beep) to signal that a new call has arrived.
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Road Warrior and Callmaster VI

Configuration settings for Road Warrior and Callmaster VI

In this configuration, the Auto-Answer feature is not active. 

Steps for answering Road Warrior and Callmaster VI calls

To answer a call for this configuration:

1. A caller places a call to the contact center and is routed to a specific extension.

Avaya IP Agent displays a call appearance in a Call Information Panel (CIP) in the main 
window.

2. The agent should select the Answer button on the new CIP.

The call is connected and the agent can begin conversing with the calling party.

Road Warrior and Callmaster VI (Auto-Answer)

Configuration settings for Road Warrior and Callmaster VI (Auto-Answer)

In this configuration, the Auto-Answer feature is enabled. 

Steps for answering Road Warrior and Callmaster VI (Auto-Answer) calls

To answer a call for this configuration:

1. A caller places a call to the contact center and is routed to a specific extension.

Avaya IP Agent displays a call appearance in a Call Information Panel (CIP) in the main 
window.

2. Avaya IP Agent automatically answers the call without any action from the agent, who can 
then begin conversing with the calling party.
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IP Telephone and Avaya Telephone

Configuration settings for IP Telephone and Avaya Telephone

The following list provides the options to set for this configuration:

● Agent Administration for auto-answer is set to station or none. 

● Station Administration for auto-answer is set to none. 

● Station Administration has service link set to as-needed. 

● Each time a call is received, the telephone that provides the voice path rings. The personal 
computer also emits a ringing sound if you have configured Avaya IP Agent to do so.

● Your Central Office (CO) must have the Answer Supervision feature. Contact your 
telecommunication provider for more information.

Steps for answering IP Telephone and Avaya Telephone calls

To answer a call for this configuration:

1. The agent should wait for the telephone to ring and then answer it. Answering of the 
telephone will automatically be detected through Avaya IP Agent.

2. After the call is completed and the calling party disconnects from the call, or after the agent 
selects Release for that call, the agent should hang up the telephone if no more calls are 
ringing on the Avaya IP Agent screen.

3. If there is another incoming call indicated on the screen, the agent should not hang up the 
telephone, but select the Answer button for the new call appearance on the Avaya IP 
Agent screen. The agent is then connected to the new call. The previous call is placed on 
hold.

Holding a call
You can put a call on hold by using either the Auto Hold or Manual Hold feature.
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When a call is on hold, the text on the button for the associated Call Information Panel (CIP) 
changes to Reconnect.

Using Manual Hold
To perform a Manual Hold, select the Hold button on the Phone Button toolbar. For those using 
the Telecommuter configuration or the IP Telephone configuration, you may also place a call on 
hold by pressing the Hold button on the telephone, if it is so equipped.

Using Auto Hold
The Auto Hold feature does not require pressing a Hold button. If you change to a second call 
appearance, the first call is automatically placed on hold.

Reconnecting to a call on hold
To reconnect to a call that is currently on hold, select the Reconnect button on the appropriate 
CIP. Alternatively, you may re-select the Hold button in the main window.

Releasing a call
There are different methods for releasing a call. These methods will work only if the Release 
feature has been administered for your station.

Hold button

Reconnect 
button
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Steps for releasing a call
To release a call:

1. Do one of the following actions:

● While on an active call, select the Release button that is located on the Call 
Information Panel (CIP). You will not hear a dial tone after you select the Release 
button.

● Select the Release button that is located on the Phone Button toolbar.

● If you are using an Avaya Callmaster VI, press the Release button on the telephone.

● If you are using Telecommuter or IP Telephone configuration, you may hang up the 
handset.

● Select the Release item in the Phone Features window.

2. If you have a call on hold, you must first reconnect to it before you can release the call.

In the example below, you would have to reconnect to extension 1048 before you could 
release it.

Dropping a call 
Use the Drop feature when you want to disconnect from a normal call or drop the last party 
added to a conference call.

To drop a call, select the Drop button located on the Phone Button toolbar. You are then 
disconnected from the call and hear a dial tone.
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Transferring a call 
This section describes the following methods of transferring calls:

● Basic call transfer on page 139

● Unsupervised call transfer on page 140

● Enhanced call transfer on page 141

Before you begin
Read and understood the following items before using the procedures described in this topic:

● The Transfer button on the Phone Buttons toolbar can be configured for Basic, 
Unsupervised, or Enhanced transfer. Use the Call Handling screen in the Program 
Options dialog box to set this option. You can also choose a type of transfer that is 
different from the default, by selecting Call > Transfer from the menu bar.

● If all of your call appearances are currently in use, you can transfer a call only to an 
existing call appearance, not to a new telephone number.

● If you enable the Abort Transfer or Abort Conference feature on your Avaya 
communication server, Avaya IP Agent cannot transfer or conference between active call 
appearances.

Basic call transfer 
Use the Basic Transfer feature to send an active call to another extension or telephone number. 
With this type of transfer, you enter the number to receive the transfer through the keyboard and 
then announce the call to the receiving party.
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Steps for a Basic Transfer

To transfer a call using Basic Transfer:

1. While you are on an active call, select Call > Transfer > Basic Transfer from the menu 
bar.

The current call is automatically put on hold, a new Call Information Panel (CIP) is 
displayed, and a dial tone is heard.

2. Using the keyboard or Dial Pad, enter the number of the party to receive the transferred 
call.

3. When the receiving party answers, you can privately talk to the party and then select 
Basic Transfer again to complete the transfer.

Both CIPs are no longer displayed in the main window, indicating that the transfer was 
successful.

You can complete the transfer at any time after the number is entered, either during the 
ringing state or after the second party answers.

You can change this call transfer into a conference by selecting Basic Conference 
instead of Basic Transfer.

4. If there is no answer, the line is busy, or you decide the transfer is not needed, do the 
following steps to cancel the transfer:

● Select the Release button associated with the receiving party. This action terminates 
the call to the receiving party.

● Return to the call on hold by selecting the Reconnect button on the associated CIP.

Unsupervised call transfer 
Use the Unsupervised Transfer feature to transfer an active call to another extension or 
telephone number by entering the number of the receiving party into a dialog box. 
Announcement of the call to the receiving party is not available in this mode.
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Steps for an Unsupervised Transfer

To transfer a call using Unsupervised Transfer:

1. While you are on an active call, select Call > Transfer > Unsupervised Transfer.
Avaya IP Agent displays the Unsupervised Transfer dialog box.

2. In the available field, enter the number to receive the current call.

3. Select OK to transfer the call. 

Unlike the basic transfer, you do not have to select Transfer a second time to complete the 
transfer.

The Call Information Panel (CIP) will disappear from the main window which indicates that 
the transfer was successful.

Enhanced call transfer 
Use the Enhanced Transfer feature to transfer the active call to another extension or telephone 
number by entering the number of receiving party into a dialog box. With this mode, you have 
the ability to transfer the call directly without announcing it to the receiving party or you can wait 
to announce the call and then decide whether to transfer the call.

Steps for an Enhanced Transfer

To transfer a call using enhanced transfer:

1. While you are active on a call, select Call > Transfer > Enhanced Transfer.
Avaya IP Agent displays the Enhanced Transfer dialog box.

2. In the available field, enter the number of the receiving party.



Chapter 6: Avaya IP Agent basic operations

142 IP Agent R7 Installation and User Guide August 2007

 

3. Select the OK button.

The caller is automatically put on hold, a new Call Information Panel (CIP) is displayed, a 
dial tone is heard, and Avaya IP Agent displays a confirmation dialog box.

If you need to enter digits, such as answering prompts, use the number pad on the right 
side of this dialog box. If you are on hold or are delayed for some reason, you can return to 
the original call without losing this call by selecting the Switch to call on hold button and 
select this button again to return to the transfer.

4. Remain on the line and wait for an answer.

5. Perform one of the following actions:

Conferencing calls
This section provides information and procedures for conferencing multiple calls together so 
that all parties can communicate simultaneously.

This section contains the following topics:

● Basic Conference on page 143

● Enhanced Conference on page 145

Note:
Note: If all of your call appearances are currently in use, you can conference only with 

existing call appearances, not new telephone numbers.

If... Then...

The number dialed is answered Announce the call and select the OK button in the 
confirmation dialog.
Both CIPs are no longer displayed in the main 
window, indicating that the transfer was 
successful.

The number dialed is not answered 
or is busy

Select the Cancel button in the confirmation dialog 
and select the Reconnect button on the 
appropriate CIP to return to the held call.
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Basic Conference 
Use the Basic Conference feature to connect multiple calls together so that all parties can 
communicate simultaneously. With this method, you use the numbers on the keyboard or the 
Dial Pad to enter the telephone numbers to conference together.

Steps for using Basic Conference

To conference a call using Basic Conference:

1. While you are active on a call, select Call > Conference > Basic Conference.

The current call is automatically placed on hold, a new Call Information Panel (CIP) is 
displayed, and a dial tone is heard.

2. Use the keyboard or Dial Pad to enter the number of the party you want to add to the 
conference call.
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3. When the second party answers, you can privately talk to the second party and then select 
Basic Conference again to initiate the conference call. 

You may initiate the conference when the number is entered, during the ringing state, or 
after the second party answers.

One CIP is displayed in the main window, which displays CONFERENCE 2. indicating that 
a conference is active.

You may change the conference call into a transfer by selecting Basic Transfer instead of 
Basic Conference in Step 3.

4. Repeat the previous steps until you have conferenced all parties.

The single CIP displays CONFERENCE X, where X equals the number of parties 
participating in the call.

Example:
If you added three parties to the call, the CIP displays CONFERENCE 3.

5. If there is no answer, the line is busy, or you decide the conference is not needed: 

● Select the Release button associated with the party that was going to be added to the 
conference.

● Return to the held call by selecting the Reconnect button on the associated CIP.
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Enhanced Conference 
Use the Enhanced Conference feature to connect multiple calls together by entering the 
extensions or telephone numbers through a dialog box and then adding them to an active call.

Steps for using Enhanced Conference

To add a party to a current call, perform the following steps:

1. While you are on an active call, select Call > Conference > Enhanced Conference.

Avaya IP Agent displays the Enhanced Conference dialog box.

Note:
Note: The dialog box you see may be different because it depends on the number of 

call appearances that are present. If all available call appearances are active, the 
dialog box does not have a New Number field. If only one call appearance is 
active, the dialog box does not display the Existing Call field.

2. In the New Number field, enter the extension or telephone number of the party you want 
to add to the active call.

Note:
Note: If you have only one call appearance, the field in which you provide a telephone 

number is not labeled.

One call appearance More than one call appearance
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3. Select the OK button.

The current call is automatically placed on hold, a new CIP is displayed, a dial tone is 
heard, and Avaya IP Agent displays a confirmation dialog box.

If you need to enter digits, such as answering prompts, use the number pad on the right 
side of this dialog box. If you are on hold or are delayed for some reason, you can return to 
the original call without losing this call by selecting the Switch to call on hold button and 
select this button again to return to the conference.

4. When you decide to add the call to the conference, select the OK button. If there is no 
answer, the line is busy, or you decide to cancel the conference, select the Cancel button.

If you selected the Cancel button, select the Reconnect button on the CIP associated with 
the original call.

5. If you selected the OK button, wait for an answer.

If... Then...

The number dialed is 
answered

You can privately talk to the new party and then 
select the OK button in the confirmation dialog to 
add the party to the call.
One CIP is displayed in your main window, which 
displays CONFERENCE 2, indicating that a 
conference is active.

The number dialed is not 
answered or is busy

Select the Cancel button in the confirmation dialog 
and then select the Reconnect button to return to 
the original call.
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6. Repeat the previous steps until you have conferenced all parties.

The single CIP displays CONFERENCE X, where X equals the number of parties 
participating in the call.

Example:
If you added three parties to the call, the CIP displays CONFERENCE 3.

Any person on the conference call can hang up at any time.

7. To disconnect the last person added to the conference call, select the Drop button.

8. When the conference call is over, select the Release button.

 The CIP is removed from the main window.

Handling outgoing calls
There are several ways you can make the handling of outgoing calls more efficient. You can use 
a Recent Calls list, a Speed Dial number, or an Abbreviated Dial button.
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Note:
Note: In the Contact Directory, you may notice that all telephone numbers are prefixed 

with a "+1" (in the United States). All external telephone numbers are displayed in 
the Contact Directory in canonical format, as seen in the following example:

+1 (800) 555-1234

This format is universally constant and allows this number to be dialed from 
anywhere in the world. This number is dialed only if deemed necessary through 
the Dialing Properties of your personal computer.

For example, a user with a laptop may have two or more sets of Dialing 
Properties configured. In the office, one set of Dialing Properties cause a 
number, sometimes a "9", to be dialed to access an external line. Alternatively, the 
same laptop could have a Dialing Properties set that does not use an external 
line number for when the user is at home or traveling. The format of telephone 
numbers in the Contact Directory ensures that all of these configurations will 
work without having to change the format.

This section includes the following topics:

● Recent Calls list on page 148

● Using the Contact Directory on page 149

● Using the Contacts window on page 153

● Speed Dial on page 157

● Abbreviated Dial button on page 160

Recent Calls list 
You can quickly dial or re-dial recent incoming or outgoing calls by using the Recent Calls list. 
Telephone numbers are not duplicated in the list, so if the last ten calls are to the same number, 
the number is displayed only once in the list. Only those calls with valid telephone numbers are 
added to the list.

Before you begin

Before using the Recent Calls list, read and understand the following items:

● You or your system administrator can control the number of recent call numbers displayed 
by setting that number in the Program Options dialog box. 

● The list can show a maximum of the last 25 unique numbers recorded in the Contact 
History log. Abbreviated Dial buttons or numbers dialed on active calls (pin numbers) are 
not included in the list.

● Letters that are dialed, for example, 1866GOAVAYA, are displayed in the recent calls list 
as letters, not as the associated numbers.
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Steps for using the Recent Calls list

To make a call using the Recent Calls list:

1. Select the down arrow next to the Contact History button. 

Avaya IP Agent displays a list of previously dialed and received numbers.

2. Select the number you want Avaya IP Agent to dial.

A call appearance is created and the selected telephone number is dialed.

Using the Contact Directory
The Contact Directory feature stores contact information that you provide. Through this 
interface, you can dial telephone numbers, send e-mail messages, or send instant messages to 
those contacts that you have defined.

The Contact Directory, by default, stores the types of information shown in the following list:

● Name

● Telephone numbers

● Instant messaging user name

● Instant messaging presence state

● Email

● Category

● Pronunciation (Japanese version only)
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Note:
Note: You can also select which fields are displayed in the Contact Directory window. 

Select Edit > Field Organizer to display the Field Organizer window.

Menu bar

The following list provides the menus and menu items available for the Contact Directory 
window:

File
● New - This item displays the Properties dialog and allows entry of a new contact.

● Import
- Text File (Comma Separated Values) - This item allows you to import a .CSV file 

containing contacts and their associated information.

Note:
Note: The Import feature will not update information for existing contacts.

● Export - This item exports the Contact Directory to a comma-separated value file (.CSV)

Note:
Note: The entries for the comma-separated values are listed below in the order that 

they are displayed:

- Name

- Address

- Email

- Business

- Business Fax

- Home

- Home Fax
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- Mobile

- Assistant

- Car

- Company

- Pager

- Instant Message

- Track availability

- Category

- Pronunciation (Japanese version only)

Each item must be enclosed within quotation marks.

● Search Public Directory - This item opens the Search Public Directory window, which 
can be used to search for contact information through an Lightweight Directory Access 
Protocol (LDAP) service. Entries can be added to the Contact Directory from the Search 
Contact Directory window. For more information on this feature, see Using a Public 
Directory with Avaya IP Agent on page 181.

● Close - Selecting this item closes the Contact Directory window.

Edit
● Delete - Delete the selected contact.

● Properties - View all information for the selected contact.

● Field Organizer - Organize the fields displayed in the Contact Directory.

● Categories - Add, delete, or modify the categories defined in the Contact Directory.

View
Use this menu to determine how the entries appear in the Contact Directory window. These 
items are similar to those used in Windows Explorer: Large Icons, Small Icons, List, and 
Details (default). 

Selecting the Contacts item closes this window and displays the Contacts window. See Using 
the Contacts window on page 153 for more information.

Action
● Call: (name) - Select this menu item to initiate a telephone call to the highlighted contact.

● Send Email - Select this menu item to initiate an e-mail message to the highlighted 
contact.
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Toolbar

The toolbar of the Contact Directory window contains the following controls:

● Name - This field allows the dynamic filtering of the entries in the Contact Directory on 
any field. Select the name button to display the list of fields available for the Contact 
Directory. After you select the field on which to filter, enter letters or digits in the 
corresponding field. Each character entered in this field causes only those entries 
matching the filter to remain visible. For example, entering the letter S causes all entries 
that do not begin with that letter to be hidden. For numeric fields, any numbers entered in 
this field are used to filter the entries. The filtering for numeric fields is not sequential. Any 
entries that contain the string of numbers entered will remain visible. Additionally, any 
punctuation existing in the entry is ignored. For example, entering the numbers 123 would 
match against the following entries:

- (555) 555-1234
- (800) 123-5555
- 1 (230) 555-5555
- 512-3555

● Dial Number - Select this button to dial the number entered in Number field.

● Send Touch Tones - Select this button send DTMF tones after you are connected, as with 
the DialPad.

● Send Email - Select this button to open an e-mail message to the highlighted entry.

● Properties - Select this button to display a dialog box containing the details of the 
highlighted entry. This dialog box also allows modification of this information.

● Delete - Select this button to delete the highlighted entry.

● New entry - Select this button to display the Properties dialog and enter the information 
for a new contact.

● Categories - Select this button to display a list of all categories defined in the Contact 
Directory and to filter the existing contacts. Selecting one of the categories in this list 
results in only those contacts assigned to that category remaining visible.

Contact Directory window usage 

Within the Contact Directory window, you can perform the following actions on a selected 
contact:

● With the mouse, right-click on an entry to display a pop-up menu containing the following 
items:

- Call (contact) - Initiates a call to the selected contact.
- Send Email - Initiates an e-mail to the selected contact.
- Delete - Removes the selected contact from the Contact Directory.
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- Properties - Displays a dialog box listing all information for the selected contact. This 
dialog box also allows editing of that information.

● Press the Enter key or double-click the mouse to initiate a call to a contact.

● Press Alt + Enter to display all information for the selected contact.

● Press the Delete key to remove the selected contact from the Contact Directory.

You can also sort the entries in the Contact Directory by clicking the title of any column. The 
sorting is done based on the column selected and alternates between ascending to descending 
order with subsequent clicks.

More information

The following topics provide additional information on the use of the Contact Directory window:

● Administering Speed Dial from the Contact Directory on page 157

● Searching a Public Directory on page 183

Using the Contacts window
The Contacts window displays your contacts in a vertical format, separated into groups that you 
define. These contacts can be associated with e-mail, telephone numbers, instant messaging, 
or a combination of these types.

To open this window, select Tools > Contacts from the Avaya IP Agent main window.
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Menu bar

The following list provides the menus and menu items available for the Contacts window:

File
● Close - Select this item to close the Contacts window.

Edit
● Delete - Select this item to remove the highlighted contact from the Contacts window and 

the Avaya IP Agent database. 

● Properties - Select this item to display a dialog box containing the details of the 
highlighted entry. This dialog box also allows modification of this information.

● Rename - Select this item to rename the highlighted contact. This action only changes the 
name of the contact. All other information is retained.

● Add Contact - Select this item to add a new contact. A blank properties page is displayed 
so that you can enter the necessary information. After you have entered the necessary 
information, you must close the properties page to have this contact appear in the 
Contacts window.

● Add Group - Select this item to add a new group to this window. This new group will 
appear as a Category in the Contact Directory window.

View
● IM Preferences - Select this item to open the Instant Messaging Preferences window, 

which allows you to change your instant messaging configuration, such as alerts, logging, 
and automated responses.

● IM Wizard - Select this item to open the Instant Messaging Wizard, which allows you to set 
your instant messaging configuration. You can only select this item if you are not logged in 
to a SIP Enablement Services for instant messaging.

● Contact Directory - Select this item to close the Contacts window and display the 
Contact Directory window.

● Search Public Directory - Select this item to display the Search Public Directory 
window, which allows you to search an LDAP public directory service.

● Always on Top - Select this item to set the Contacts window to always be displayed in 
front of other windows. This feature is enabled if a check mark appears next to this item in 
the menu.
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Actions
● Send Instant Message - Select this item to display a dialog box that allows you to enter 

an instant messaging user name of an Avaya IP Agent user so that you can send an 
instant message. After you have entered a valid user name, and Instant Message 
Session window is displayed.

● My Presence Status - Select this item to display a list of available presence states. Select 
one of these presence states to notify other instant messaging users of your availability.

● Track - Select this item to track the presence status of the highlighted instant messaging 
user. This feature is enabled for the highlighted contact if a check mark appears next to 
this item in the menu.

● Block - Select this item to block instant messages from the highlighted instant messaging 
user. This feature is enabled for the highlighted contact if a check mark appears next to 
this item in the menu.

● Dial Number - Select this item to have Avaya IP Agent dial the telephone number of the 
highlighted contact. If no telephone number has been defined for the highlighted contact, 
this item is disabled.

● Send Touch Tones - Select this item to send DTMF tones after you are connected, as 
with the DialPad.

● Send Email - Select this item to open a blank e-mail that is addressed to the highlighted 
contact. If no e-mail address has been defined for the highlighted contact, this item is 
disabled.

● Sort - Select this item to display a list of sort options for your contacts. These sort options 
are variations on ascending and descending alphabetical order and can include a 
secondary sort on the presence state of other instant messaging users. If you select an 
online only sort option, only those contacts with an instant messaging address are 
displayed; all other contacts are hidden.

Toolbar

The toolbar of the Contacts window contains the following controls:

● Start IM Session - Select this button to display a dialog box that allows you to enter an 
instant messaging user name of an Avaya IP Agent user so that you can send an instant 
message. After you have entered a valid user name, and Instant Message Session 
window is displayed.

● Presence state- Select this button to display a list of presence states. Select the presence 
state that you want to other instant messaging users to see for your user name.

● Dial Number - Select this button to have Avaya IP Agent dial the telephone number of the 
highlighted contact. If no telephone number has been defined for the highlighted contact, 
this button is disabled.
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● Send Touch Tones - send DTMF tones after you are connected, as with the DialPad.

● Properties - Select this button to display a dialog box containing the details of the 
highlighted entry. This dialog box also allows modification of this information.

● Sort - Select this button to display a list of sort options for your contacts. These sort 
options are variations on ascending and descending alphabetical order and can include a 
secondary sort on the presence state of other instant messaging users. If you select an 
online only sort option, only those contacts with an instant messaging address are 
displays; all other contacts are hidden.

● Send Email - Select this button to open a blank e-mail that is addressed to the highlighted 
contact. If no e-mail address has been defined for the highlighted contact, this button is 
disabled.

● Delete - Select this button to remove the highlighted contact or group from the Contacts 
window and the Avaya IP Agent database. 

CAUTION:!

CAUTION: If you select a group with contacts, those contacts are also deleted.

● Add Contact - Select this button to add a new contact. A blank properties page is 
displayed so that you can enter the necessary information. After you have entered the 
necessary information, you must close the properties page to have this contact appear in 
the Contacts window.

Contacts window usage

Within the Contacts window, you can perform the following actions on a selected contact:

● With the mouse, right-click on an entry to display a pop-up menu containing the following 
items:

- Send Instant Message - Initiates an instant messaging session to the selected 
contact.

- Dial Number - Initiates a telephone call to the selected contact.
- Track - Updates the presence status of the selected contact when it changes.
- Block - Prohibits the selected contact from sending an instant message to you.
- Send Email - Initiates an e-mail to the selected contact.
- Rename - Changes the name of the selected contact. This change only appears on 

the local personal computer.
- Delete - Removes the selected contact from the Contacts window.
- Properties - Displays a dialog box listing information for the selected contact. This 

dialog box also allows editing of that information.

● Press the Enter key or double-click the mouse to initiate an instant message session to 
the selected contact.
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● Press the Delete key to remove the selected contact from the Contacts window.

Speed Dial 
Use the Speed Dial feature to dial frequently-used telephone numbers by selecting entries from 
the Speed Dial list or by pressing function keys (F2-F8) on the keyboard. A maximum of 25 
telephone numbers can be assigned to the Speed Dial list. Speed Dial telephone numbers can 
be administered through two methods.

This section contains the following topics:

● Administering Speed Dial from the Contact Directory on page 157

● Administering Speed Dial from the Speed Dial Numbers window on page 158

● Using a Speed Dial telephone number on page 159

Administering Speed Dial from the Contact Directory 

This section provides the procedure for assigning an entry in the Contact Directory as a Speed 
Dial telephone number.

To assign a telephone number in the Contact Directory to the Speed Dial list:

1. In the Avaya IP Agent main window, select Tools > Contacts.

Avaya IP Agent displays the Contacts window.

2. In the Contacts window, select View > Contact Directory.

Avaya IP Agent displays the Contact Directory window.

3. Do the appropriate step in the following table:

4. Enter or edit the appropriate information in the Properties dialog box.

If... Then...

You are creating a new entry Select File > New... from the menu bar.

You are editing an entry Highlight the entry and select Edit > 
Properties from the menu bar.
Avaya IP Agent displays the Properties 
dialog box.
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5. Place a check mark in the Speed Dial check box next to the telephone number that you 
want to use as a Speed Dial number.

Avaya IP Agent displays the Speed Dial Function Keys dialog box.

6. If you want to have the telephone number for this Contact Directory entry available when 
a function key, such as F2, F3, ..., F8, is pressed, select the Assign this number to a 
function key option.

The Contact Directory entry appears in the F2 row.

Note:
Note: If you want to assign this new entry to another function key, highlight it and use 

the up and down arrow icons in the dialog box to move the entry to a new location 
in the list.

7. When you are satisfied with the function key that this number has been assigned to, press 
the OK button.

8. In the Properties window, select the OK button to close it.

Administering Speed Dial from the Speed Dial Numbers window 

This section provides the procedure for creating a Speed Dial telephone number that does not 
exist in the Contact Directory. Once you create a Speed Dial telephone number with this 
method, this new entry is added to the Contact Directory and can be edited the same as other 
entries.

To create a new Speed Dial telephone number:

1. From the Avaya IP Agent main window, select Tools > Speed Dial Numbers.

Avaya IP Agent displays the Speed Dial Numbers window.

2. In the Speed Dial Numbers windows, select File > New.

Avaya IP Agent displays the New Speed Dial window.
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3. In the Name field, enter a unique name for this Speed Dial entry.

4. If necessary, select the button to the right of the Business field to change the category of 
the telephone number that will be entered.

5. Once you have set the category, enter the telephone number into the labeled field.

6. If you want to assign this Speed Dial telephone number to a function key (F2, F3...), place 
a check mark in the Assign this number to a function key check box.

7. If you assigned this Speed Dial telephone number to a function key, you can change the 
key to which it is assigned by highlighting the entry in the Function Keys list and using the 
up and down buttons at the top of this list.

Note:
Note: You cannot edit an existing entry from the Speed Dial Numbers window. To edit 

an existing entry, you must use the Contact Directory.

Using a Speed Dial telephone number 

To select a Speed Dial number:

1. Select the down arrow next to the Contact Directory button in the Avaya IP Agent main 
window.

Avaya IP Agent displays the Speed Dial Numbers list.

2. Select the party that you want to call.

A call appearance is created and the telephone number is dialed.

Note:
Note: If you have assigned a Speed Dial telephone number to a function key, you can 

simply press that function key to dial the associated telephone number.

You can also display the Speed Dial Numbers window by selecting the Speed Dials button on 
the same toolbar.
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Abbreviated Dial button
If the Abbreviated Dial feature has been administered on the Avaya communication server for 
your extension, you can store telephone numbers in the Phone Features window for quick and 
easy dialing. Each number can be a complete or partial telephone number, an extension 
number, a trunk, or feature code.

Steps for using Abbreviated Dial

To make a call using an Abbreviated Dial button:

1. Select Tools > Phone Features.

Avaya IP Agent displays the Phone Features window.

2. In the Phone Features dialog box, select the Abbreviated Dial button associated with the 
number you want to dial.

A call appearance is created and the selected telephone number is dialed.

The button label for an Abbreviated Dial is a number, whereas the button label for an 
autodial button is the word autodial plus the number. This difference is shown in the 
following table:

Using instant messaging 
The instant messaging feature allows you to send and receive text messages with other Avaya 
IP Agent users. This feature also allows you to track the presence state of other instant 
messaging users so that you can tell if the agent is available, away, or busy with some other 
task.

This feature behaves similarly to other instant messaging products. When an instant message 
session is initiated, both users will see an Instant Message Session window. Through this 
window, the users will enter text messages and see the messages of the other user.

This section contains the following topics:

● Starting an instant message session on page 161

● Sending and receiving instant messages on page 162

● Changing your presence state on page 162

Abbreviated Dial Autodial

51008 autodial 51008
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● Blocking users on page 163

● Tracking user presence states on page 164

● Viewing message history on page 164

● Other instant messaging features on page 165

Starting an instant message session 
You can send an instant message through one of the following methods:

● Starting an instant message session without a contact list on page 161

● Starting an instant message session through the Contacts window on page 161

● Starting an instant message session through the Contact Directory window on page 162

● Starting an instant message session from a Call Information Panel on page 162

Starting an instant message session without a contact list
To send an instant message to another Avaya IP Agent without the use of a contact list, do the 
following steps:

1. From the Avaya IP Agent main window, select Instant Messaging > Send a message or 
select the Start Instant Messaging Session button on the Instant Messaging toolbar.

Avaya IP Agent displays the Contact address dialog box.

2. In the Contact address dialog box, enter the instant messaging address of the user to 
whom you want to send an instant message.

3. Select the OK button.

Avaya IP Agent displays an Instant Message Session window for the user you specified.

4. Go to Sending and receiving instant messages on page 162 to learn more about sending 
and receiving instant messages.

Starting an instant message session through the Contacts window
To send an instant message to another Avaya IP Agent user from the Contacts window, do one 
of the following actions:

● Double-click the online contact to whom you want to send an instant message.

● Highlight the instant messaging contact to whom you want to send an instant message 
and select Actions > Send Instant Message from the menu bar.

● Right-click the instant messaging contact to whom you want to send an instant 
message and select Send Instant Message from the resulting popup menu.

Once the Instant Message Session window is displayed, go to Sending and receiving instant 
messages on page 162 to learn more about sending and receiving instant messages.
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Starting an instant message session through the Contact Directory window
To send an instant message to another Avaya IP Agent use from the Contact Directory window, 
do one of the following actions:

● Highlight the instant messaging contact to whom you want to send an instant message 
and select Actions > Send Instant Message from the menu bar.

● Right-click the instant messaging contact to whom you want to send an instant 
message and select Send Instant Message from the resulting popup menu.

Once the Instant Message Session window is displayed, go to Sending and receiving instant 
messages on page 162 to learn more about sending and receiving instant messages.

Starting an instant message session from a Call Information Panel
If Avaya IP Agent displays a Call Information Panel (CIP) from an instant messaging user in 
your Contacts window, that CIP displays an instant message button. You have the option of 
selecting this button to start an instant message session with that contact.

Sending and receiving instant messages 
Once an Instant Message Session window is displayed, you can have a text-based 
conversation with the selected instant messaging user.

To send text to another user, do the following steps:

1. In the text field at the lower section of the Instant Message Session window, enter a text 
message.

2. Select the Send button to the right of the field.

The text message is sent to the other user and is displayed in the larger text field in the 
upper section of this window.

3. When the other user responds, that text message is displayed below your previous 
message.

Changing your presence state 
Your instant messaging presence state is a way of broadcasting your current availability to other 
instant messaging users. The following list provides the presence states that are available in 
Avaya IP Agent:

● Online - This state indicates that you are available for instant messaging.

● Busy - This state indicates that you are busy with some task and cannot participate in an 
instant messaging session.
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● Away - This state indicates that you are not at your personal computer and cannot 
participate in an instant messaging session.

● On the Phone - This state indicates that you are currently participating in a telephone 
conversation and may not be readily available to reply to an instant message.

● Appear Offline - This state provides the appearance that you are not logged in to the SIP 
Enablement Services. This state does not prevent you from receiving instant messages 
when an address is manually entered in the Contact address dialog box.

You can change your presence state in several areas:

● From the Avaya IP Agent main window, select Instant Messaging > My Presence Status 
and select the appropriate state.

● From the Instant Messaging toolbar on the Avaya IP Agent main window, select the 
Change instant messaging status button and then select the appropriate state from the 
resulting popup menu.

● In the Contacts window, select Actions > My Presence Status and select the appropriate 
state.

Blocking users 
In some situations, you may want to block other users from sending you an instant message. 
Any attempts by that user to send you an instant message will fail. You will not be notified when 
a block has intercepted an instant message.

To block an Avaya IP Agent user from sending you an instant message, do the following steps:

1. In the Contacts or Contact Directory window, highlight the instant messaging user that 
you want to block.

2. Do one of the following actions:

● From the menu bar, select Actions > Block.

● Right-click the contact entry and select Block from the resulting popup menu.

Note:
Note: If a check mark is displayed next to the Block item, the selected instant 

messaging user is already blocked. Selecting this option again will unblock the 
selected instant messaging user.

When you block another user, the Contact Directory window will reflect that condition in the IM 
Status field.
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Tracking user presence states 
Presence states allow you to view the availability of other instant messaging users. Using this 
capability, you can determine the possibility of receiving a response from an instant messaging 
user. By default, all instant messaging contacts have the Track feature enabled. 

Tip:
Tip: For performance reasons, Avaya recommends that you track only 50 or fewer 

instant messaging contacts. Exceeding this limit could result in delays of 
presence state changes.

To change the tracking of the presence state for a contact, do the following steps:

1. In the Contacts or Contact Directory window, highlight the instant messaging user for 
whom you want to change presence state tracking.

2. Do one of the following actions:

● From the menu bar, select Actions > Track.

● Right-click the contact entry and select Track from the resulting popup menu.

Note:
Note: If a check mark is displayed next to the Track item, the selected instant 

messaging user is already being tracked. Selecting this option again will stop the 
automatic updating of the presence state for that user.

When you stop tracking the presence state of an instant messaging user, the Contact Directory 
window displays Unknown in the IM Status field.

Viewing message history
If you enabled the storing of all instant message sessions, all of your conversations are saved 
locally on your personal computer. See History tab on page 251 for more information about 
saving your instant message sessions.

To view an instant message session that occurred in the past, do the following steps:

1. From the Avaya IP Agent main window, select Tools > Contact History.

Avaya IP Agent displays the Contact History window.

2. Locate the instant messaging session that you want to review and highlight it.

In the Contact History window, instant messaging sessions have an icon with a chat 
bubble and an arrow that indicates the initiator of that session.

3. Do one of the following actions:
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● Right-click the instant messaging session entry and select the View IM Session item 
from the resulting popup menu.

● Select Instant Messaging > View IM Session from the menu bar of the Contact 
History window.

The instant messaging session is displayed in a Web browser window.

Other instant messaging features 
This section contains information for other instant messaging features that you can use to 
customize and simplify your instant messaging sessions:

● Font on page 165

● Emoticons on page 165

● Responses on page 166

● Timestamps on page 167

Font

The Font feature allows you to change the font, size, color, and font style of your message text.

During an instant message session, you can access the Font dialog box by selecting the Font 
button in the Instant Message Session window or by selecting Edit > Change Font from the 
menu bar.

Emoticons

Emoticons are graphical icons that reflect your mood to the other person in your instant 
messaging session. These icons can be inserted anywhere in your text messages.

These icons can be inserted into your text message by selecting the Emoticons button in the 
Instant Message Session window.
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Emoticons can also be created manually by combining specific characters. These combinations 
are interpreted and replaced with the corresponding emoticon when the instant message is 
sent. The following table provides the character combinations for each emoticon:

Responses

When you receive an instant message from other Avaya IP Agent user, you can use the 
Responses feature to select a pre-defined message to send. These responses are used when 
you are busy and do not want to take the time to manually enter a reply.

To send a pre-defined reply to an instant message, select the Responses button in the Instant 
Message Session window and select a response from the resulting popup menu.

You can customize your responses through the Responses tab of the Instant Messaging 
Preferences dialog box. See Responses tab on page 252 for more information.

Emoticon Character 
combination

:)

:D

:P

;)

:S

:@

:|

:s

:(
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Timestamps

The Timestamps feature displays the time when an instant message is sent or received. The 
timestamp is displayed next to the user name for each message. To change the visibility of 
timestamps, select View > Show Timestamps in the menu bar of the Instant Message 
Session window.

A check mark is displayed next to this menu item when the feature is enabled. Selecting this 
option again will remove the check mark and hide all timestamps in the Instant Message 
Session window.

Using the Web Dialer in Internet Explorer 
The Web Dialer is associated with the Click-to-Dial feature of Avaya IP Agent. This feature has 
a toolbar that you can display in Internet Explorer. 

The Web Dialer allows you to do the following tasks:

● Enter a telephone number and call that number through Avaya IP Agent.

● Select a previously-entered telephone number and call that number through Avaya IP 
Agent.

● Click a button to start Avaya IP Agent or make the Avaya IP Agent main window display 
itself in front of other open windows.

● Select text (for example, Smith) and then drag and drop the selected text to the Web Dialer 
for an Avaya IP Agent contact directory lookup.

● Use the Avaya Web Dialer entry in the context menu to dial a number, clear the dialing 
history, open the Avaya technical support Web page, or display information about the Web 
Dialer component.

This section contains the following topics:

● Displaying the Web Dialer toolbar on page 168

● Calling a telephone number through the Web Dialer toolbar on page 168

● Calling a previously-dialed telephone number on page 168

● Using the Avaya IP Agent button on page 168

● Using the Web Dialer context menu item on page 169
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Displaying the Web Dialer toolbar
You can display and move the Web Dialer toolbar in the same manner as other Internet 
Explorer toolbars.

To display the Web Dialer toolbar, do the following steps:

1. Open Internet Explorer.

2. From the menu bar, select View > Toolbars > Avaya Web Dialer.
Internet Explorer displays the Avaya Web Dialer toolbar.

Calling a telephone number through the Web Dialer toolbar
You can make a telephone call from your Web browser through Avaya IP Agent by entering a 
telephone number in the combination text box on the Avaya Web Dialer toolbar and pressing 
the Enter key or selecting the telephone button to the right of the field.

Alternatively, you can highlight a telephone number in the Web page and then drag-and-drop it 
into the Web Dialer toolbar text box.

Calling a previously-dialed telephone number
You can call a telephone number that was previously entered in the Web Dialer toolbar by 
selecting it from the drop-down list on the Toolbar.

Using the Avaya IP Agent button
The Avaya IP Agent button on the Web Dialer toolbar can be used to do the following things:

● Start Avaya IP Agent

● Display the Avaya IP Agent main window in front of any other open windows on the 
desktop
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Using the Web Dialer context menu item
The Avaya Web Dialer component also includes a menu item that appears on the context menu 
that is displayed when you right-click within the Internet Explorer window.

On this menu, you can select the following items:

● Dial - Selecting this item when a phone number has been selected on a web page, as 
would be required to copy the selected number to the Windows clipboard, will dial the 
selected phone number in Avaya IP Agent.

● Clear Dialing History - Selecting this item causes the list of previously-dialed telephone 
numbers in the list box on the Web Dialer toolbar to be deleted. This action does not 
remove these telephone numbers from the Contact History window.

● Avaya Technical Support - Selecting this item opens the Avaya technical support Web 
site in a new Internet Explorer window.

● About - Selecting this item displays a message box that provides the version of Avaya 
Web Dialer.
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Chapter 7: Agent Greetings 

This section provides information and procedures for the creation and use of agent greetings 
through Avaya IP Agent.

The Agent Greetings feature frees you from having to repeatedly say the same greeting at the 
beginning of each call. When a call is answered, your microphone is muted and the selected 
greeting is played. After the greeting is played, your microphone is un-muted and you are able 
to talk to the calling party. 

Additionally, it is possible to configure agent greetings to play only for specific telephone 
numbers or VDNs from which calls originate.

This chapter includes the following topics:

● Creating agent greetings on page 172

● Setting the active agent greeting on page 173

● Setting activation criteria for agent greetings on page 173

● Deleting agent greetings on page 174

● Copying agent greeting files on page 175

Before you begin
Read and understand the following items before you work with the Agent Greetings feature:

● Avaya IP Agent supports agent greetings for Avaya Callmaster VI endpoints and IP 
endpoints using the Road Warrior configuration. The Telecommuter and Avaya Telephone 
configurations can support agent greetings if you use an Avaya Switcher II headset.

For information about using an Avaya Switcher II, see:

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf

● Agent greetings are stored in different locations, depending on your current Avaya IP 
Agent configuration.

- Road Warrior / Telecommuter / Avaya Telephone - You can store the agent greetings 
on your personal computer or in a network location. These configurations will support 
up to 60 greetings of 30 seconds each.

- Callmaster VI - Agent greetings are stored on the Callmaster VI unit and not on the 
personal computer.

● To view or configure the optional settings for agent greetings, such as configuring the 
agent greeting to play for a specific VDN or ANI, see Agent Greetings settings on 
page 252.

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf
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● If you are using the Avaya Switcher II headset, you must run the Audio Tuning Wizard and 
enable the Play greetings via Avaya Switcher II check box. You must then close and 
restart Avaya IP Agent for Agent Greetings to appear in the Tools menu.

Creating agent greetings 
This section provides the procedure for recording an agent greeting.

Note:
Note: Before users of the Callmaster VI configuration can record agent greetings, the 

user must first deactivate the headset by clicking the headset button in the 
headset toolbar.

Steps for creating an agent greeting
To record an agent greeting:

1. Change to an inactive agent mode, such as Auxiliary Work or After Call Work, to prevent 
interruptions from incoming calls when you are recording your greeting.

2. From the Avaya IP Agent main window menu bar, select Tools > Agent Greetings.

Avaya IP Agent displays the Agent Greetings window.

3. Highlight an agent greeting in the list by clicking on the name.

4. Select the Record button.

5. By using the microphone that is either on your headset or attached to the personal 
computer, speak your greeting.

6. When you have finished recording your greeting, select the Stop button.

Avaya IP Agent enables and updates the selected greeting.
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Setting the active agent greeting 
This section provides the procedure for setting an agent greeting as the one to play for incoming 
calls.

Steps for setting an active agent greeting
To set an agent greeting to activate:

1. From the Avaya IP Agent main window menu bar, select Tools > Agent Greetings.

Avaya IP Agent displays the Agent Greetings window.

2. Place a check mark next to the agent greeting that will be used for all incoming calls.

Note:
Note: There are some circumstances when it is possible to have more than one agent 

greeting active at the same time. For example, you can set multiple agent 
greetings to be active if each greeting has a unique VDN as the activation criteria. 
This is also true for agent greetings that play for specific Automatic Number 
Identification (ANI) telephone numbers or Prompted Digits.If two agent greetings 
meet the same criteria so that both would play for a single call, Avaya IP Agent 
restricts the activation of both agent greetings.

3. Close the Agent Greetings window.

Avaya IP Agent updates the agent greeting toolbar to display the currently active greeting 
and uses this greeting for all incoming calls.

Alternate method

If you have the Agent Greetings toolbar displayed in the Avaya IP Agent main window, you can 
use the mouse to click the agent greetings button and, from the resulting menu, select a 
different agent greeting. This action sets the selected agent greeting as active.

Setting activation criteria for agent greetings 
This section provides the procedure for configuring the properties of an agent greeting. These 
settings include the name, description, and auto-play criteria for the ANI, VDN, or Prompted 
Digits that will activate the agent greeting.
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Steps for setting agent greeting activation criteria
To set the activation criteria for an Agent Greeting:

1. From the Avaya IP Agent main window menu bar, select Tools > Agent Greetings.

Avaya IP Agent displays the Agent Greetings window.

2. Highlight the agent greeting to modify by clicking on the name.

3. Select the Properties button in the button bar.

Avaya IP Agent displays the Agent Greetings dialog box for the selected greeting.

4. Use this dialog box to change the settings for this agent greeting. See Agent Greetings 
settings on page 252 for complete information on the different panels for this dialog box 
and the associated controls.

Deleting agent greetings 
This section provides the procedure for deleting an existing agent greeting.
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Steps for deleting an agent greeting
To delete an existing agent greeting:

1. From the Avaya IP Agent main window menu bar, select Tools > Agent Greetings.

Avaya IP Agent displays the Agent Greetings window.

2. Highlight an agent greeting in the list by clicking on the name.

3. Select the Delete button which is displayed as an X on the toolbar.

Avaya IP Agent deletes the selected agent greeting.

Copying agent greeting files
Use Tools > Program Options > Greetings Options to enter the location of the directory to 
store audio files containing recorded agent greetings and audio information. 

Note:
Note: If you are upgrading from a previous version of Avaya IP Agent, copy the 

Greeting.tbl and Greeting*.wav files from the old location to the new location, or 
you will get a default greeting table.
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Chapter 8: Using VuStats 

The VuStats feature is used to pass contact center information from the Avaya communication 
server to a display on a station or extension. Supervisors and agents use this feature to monitor 
contact center activity and statistics.

The VuStats window of Avaya IP Agent displays any VuStats buttons that have been assigned 
to the extension by the communication server administrator. 

Using Avaya IP Agent, you will be able to specify how long the program monitors each 
transmission of VuStats information before it moves to the next one.

This section includes the following topics:

● Configuring an extension for VuStats through the Avaya communication server on 
page 177

● Viewing a single set of VuStats information in Avaya IP Agent on page 178

● Adjusting intervals for monitoring VuStats on page 179

Configuring an extension for VuStats through the Avaya 
communication server 

For an Avaya IP Agent extension to display VuStats information, the following configurations on 
the Avaya communication server must be done:

● The extension must be assigned as a telephone type that has a display. Avaya 
recommends the 8434D or 606A1 telephone types for Road Warrior and Telecommuter 
configurations.

● The extension must have one or more buttons assigned with the vu-display feature. 
Different streams of VuStats information are available by specifying the format and ID 
parameters of the vu-display feature.

● For different views and formats, multiple VuStats configurations can be assigned to the 
buttons for this extension.

Configuration
For information on configuring extensions for the VuStats feature through your Avaya 
communication server, see the "VuStats" section of Guide to ACD Call Centers.
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Definitions and reference material for the VuStats fields on the forms of the Avaya 
communication server can be found in the Administrator Guide for your Avaya communication 
server.

Viewing a single set of VuStats information in Avaya IP 
Agent 

This section provides the procedure for displaying a single set of VuStats information in the 
Phone Display panel of the Avaya IP Agent main window.

Before you begin
To view VuStats information in the main window of Avaya IP Agent, you must ensure that the 
Phone Display panel is visible. Select the View menu from the main menu and verify that a 
check mark next to the Phone Display menu item is present. If a check mark is not present, 
select the item to enable it.

Before performing this procedure, the VuStats feature must have been assigned to one or more 
buttons for this extension. See Configuring an extension for VuStats through the Avaya 
communication server on page 177 for more information.

Steps
To display VuStats in the Avaya IP Agent main window:

1. From the Avaya IP Agent main window menu bar, select Tools > Phone Features.

Avaya IP Agent displays the Phone Features window.
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2. Select the VuStats information to view by double-clicking the associated entry in the Phone 
Features window.

Avaya IP Agent displays the selected VuStats information in the Phone Display toolbar of 
the main window.

Adjusting intervals for monitoring VuStats 
When VuStats are being displayed through the VuStats Monitor, you can configure the 
following time-related items:

● Refresh Rate - The period of time that passes before focus is changed from the last line of 
display in the list to the first line.

● Display Interval - The period of time that passes before the VuStats Monitor changes 
focus from one VuStats line of display to the next one in the list.

Before you begin
You should ensure that you set the VuStats Monitor time intervals so that each line of display 
can be updated before the Refresh Rate changes focus to the top of the list. For example, if 
you have six VuStats lines of display in the VuStats Monitor and the Display Interval is set for 
10 seconds, your Refresh Rate should be 60 seconds or greater.

Tip:
Tip: If a VuStats line of display has not been updated before the next VuStats item 

begins to update, increase the Display Interval delay.
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Steps
To change the periods of time used in the VuStats Monitor window:

1. Start the VuStats Monitor.

2. Click the Refresh Rate button on the toolbar of the VuStats Monitor window.

Avaya IP Agent displays a menu with the following time intervals:

● 10 seconds

● 20 seconds

● 30 seconds

● 60 seconds

● 120 seconds

3. Select the interval that should pass before focus is changed from the last line of display to 
the first line.

4. Click the Display Interval button on the toolbar of the VuStats Monitor window.

Avaya IP Agent displays a menu with the following time intervals:

● 5 seconds

● 10 seconds

5. Select the interval that should pass before focus is changed from one line of display to the 
next line.

When focus moves to a line of display in the VuStats Monitor, the VuStats data for that 
line is updated.

6. After setting one or both time intervals, click the Start button on the toolbar.

The VuStats Monitor window begins displaying VuStats information according to the time 
intervals specified.
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Chapter 9: Using a Public Directory with 
Avaya IP Agent 

The Search Public Directory feature of Avaya IP Agent provides access to corporate or public 
directory services which enable you to query those services by any defined field. This feature 
can function as an LDAPv2 or LDAPv3 client. Another name for this feature is Search LDAP 
(Lightweight Directory Access Protocol).

This section includes the following topics:

● Defining a Public Directory service on page 181

● Searching a Public Directory on page 183

● Selecting the fields to display and the order on page 186

● Identifying multiple telephone number fields on page 188

● Deleting a Public Directory service on page 189

Defining a Public Directory service 
So that you can search for information on a Public Directory (LDAP) server by using Avaya IP 
Agent, a definition of the service must first be created and configured.

Steps for defining a Public Directory service
To define and configure a Public Directory service for Avaya IP Agent:

1. From the Avaya IP Agent menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory window.
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2. From the menu bar of the Search Public Directory window, select File > Add Public 
Directory.

Avaya IP Agent displays the Directory Properties window.

3. In the following fields, enter the necessary information:

● Description - Enter a name by which you will identify this Public Directory server. This 
field is required.

● Server Address - Enter the network domain or IP address of the Public Directory 
server. This field is required.

● Login - If authorization is required by the Public Directory server, enter a valid user 
name in this field.

● Password - Enter the password for the user name specified in the previous field.

● Search Root - Enter an LDAP format string representing the type of information being 
sought. For example, ou=people, o=mycompany.com specifies that information 
under the organization unit of “people” within the organization of “mycompany.com” is 
used for the search. Refer to the documentation for your LDAP system and company 
database configuration for more information on Base DN or Search Root strings.

If you are unsure of the settings for your Public Directory server, contact the administrator 
of that system.

4. Select the Advanced tab if changes to the following defaults are required:

● Port: 389
● Search Timeout: 200 (secs)
● Max Entries Returned: 200

● Bind Option:

- Simple Bind - Select this option if this service is to interface with an LDAPv2 server.
- Active Directory GSS Bind - Select this option if this service is to interface with an 

LDAPv3 server.
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5. After entering all necessary information, select the OK button.

Avaya IP Agent adds this Public Directory to the list of available services and closes the 
Directory Properties dialog box.

Searching a Public Directory 
After a Public Directory service has been defined, a search against that database can now be 
performed. If a Public Directory service has not been defined, see Defining a Public Directory 
service on page 181.

Before you begin
You can optionally use the asterisk as a wildcard in a name search as described in Step 6 in 
Steps for searching a Public Directory on page 183. However, to search on other fields, a 
wildcard is requried.  For example, to search a directory field called job function for the string 
"service," you must enter "service*" in the search field.

Steps for searching a Public Directory
To search a Public Directory service:

1. In the Avaya IP Agent menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory dialog box.
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2. To select the Public Directory service to use, start by clicking the Directory Menu button.

Avaya IP Agent displays a menu listing all defined Public Directory services.

3. From the resulting list, select the Public Directory service that you will use.

The selected item from the menu is set as the active Public Directory service and the 
Directory Menu button displays its name.

4. Click the Name field to view a list of available fields defined in this Public Directory service.

Note:
Note: If you have not connected previously to the Public Directory service, you must 

first run a query with the default settings. After this first query, all defined fields of 
the service will be available.

5. Select the field through which you want to conduct your search. The data field that you 
select appears as the label.

Directory Menu button
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6. In the field to the right of the label, enter a string to search for within the selected data field 
and press the Enter key.

Avaya IP Agent sends the query to the Public Directory service, receives the data, and 
displays it in the Search Public Directory window.

For example, after setting the data type to Name, enter Smith in the field and press the 
Enter key.

Tip:
Tip: You can use an asterisk as a wildcard for a string. For example, entering the 

string, j*n, returns all names beginning with a J and ending with an N with one 
or more characters in between. This could include entries such as John, but also 
entries such as Joseph Brown.

7. Right-click on an entry in the set of resulting data.

Avaya IP Agent displays a pop-up menu for the entry.
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8. Select an action from the following table: 

Selecting the fields to display and the order 
Avaya IP Agent allows you to select which fields from the Public Directory service will be 
displayed in the Search Public Directory window.

If... Then...

You want Avaya IP Agent to dial the 
number listed for the selected entry

Select Call: Name.
If you have configured Avaya IP Agent to 
have multiple telephone numbers for each 
entry, another pop-up menu is displayed 
with this list of numbers. From this second 
list, select the number you want to call.

You want to compose an e-mail to the 
address associated with the selected entry

Select Send Email.

You want to view all available data for the 
selected entry

Select Properties.
Avaya IP Agent displays the Properties 
dialog box.

You want to add this entry to your Avaya IP 
Agent Contact Directory

Select Add to Directory.
Avaya IP Agent adds the name, telephone 
number, and e-mail address for this 
selection in the Contact Directory.
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Steps for displaying Public Directory fields
To configure which Public Directory fields will be displayed in the Search Public Directory 
window after a query and in which order they will be displayed:

1. From the main window menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory window.

2. From the menu bar of the Search Public Directory window, select Edit > Field 
Organizer....
Avaya IP Agent displays the Field Organizer window.

Note:
Note: If the Field Organizer window does not contain any fields, you might need to first 

run a query of the Public Directory service with the default settings so that the list 
of available fields can be retrieved.

3. In the Available Fields list box, highlight the field you want to add to the Search Public 
Directory window.

You can highlight multiple fields in this list box by holding down the Ctrl key and clicking 
the cursor on each field name.

4. After the necessary fields have been highlighted, select the right arrow button (>) to move 
the selected fields to the Show fields in this order list box.

The left arrow button (<) will remove the highlighted field from the Show fields in this 
order list box.

The double arrow buttons (<< and >>) will move all fields from one list box to the other.

5. To change the order of the fields in the Show fields in this order list box, highlight the 
field to move by clicking on it.

6. Use the up and down buttons at the bottom of the list box to move the position of the 
highlighted field.
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7. Repeat Steps 5 and 6 for the pertinent fields to set the desired order.

8. Select the OK button.

Note:
Note: The selected fields and the associated order will not be displayed until you run a 

new query.

Identifying multiple telephone number fields 
Avaya IP Agent allows you to select multiple fields to be considered as telephone numbers. For 
example, the Public Directory service could have several numbers assigned to an individual, 
such as pager, fax, voice mail, mobile telephone, home telephone, and so forth.

When multiple telephone numbers are identified in Avaya IP Agent, the Call feature of the 
Search Public Directory window will ask you to select which of these numbers you want to 
call.

Steps for identifying telephone number fields
To select multiple telephone numbers to be available for the Call feature, perform the following 
steps:

1. From the main window menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory window.

2. From the Search Public Directory window menu bar, select Edit > Select Phone 
Numbers....
Avaya IP Agent displays the Select Phone Numbers window.
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3. In the Available Fields list box, highlight the field you want to add as another telephone 
number for the contact.

You can highlight multiple fields in this list box by holding down the Ctrl key and clicking 
the cursor on each field name.

4. After the necessary fields have been highlighted, select the right arrow button (>) to move 
the selected fields to the Phone Number Fields list box.

5. Select the OK button.

Deleting a Public Directory service 
This section provides the procedure for deleting a Public Directory service from Avaya IP Agent.

Steps for deleting a Public Directory service
To delete a Public Directory service, perform the following steps:

1. From the main window menu bar, select Tools > Search Public Directory.

Avaya IP Agent displays the Search Public Directory window.

2. To select the Public Directory service to delete, click the Directory Menu button.

Avaya IP Agent displays a menu listing all defined Public Directory services.

3. Select the Public Directory service from the Directory Menu.

The selected item from the menu is set as the active Public Directory service and the 
Directory Menu button displays its name.

4. Once again, click the Directory Menu button.

Avaya IP Agent displays Directory Menu.

5. From the Directory Menu, select Remove.

Avaya IP Agent deletes the active Public Directory service from Avaya IP Agent and sets 
the first remaining service as active.
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Chapter 10: Screen pops 

Screen pops are used to start an application or interface when an incoming call is received by 
Avaya IP Agent or when an outgoing call is placed.

Screen pops are most useful for the following actions:

● Starting an application so that the agent can enter customer or critical information 
regarding the call.

● Viewing data based on information transmitted with the call, such as customer information, 
the area from which they are calling, or the selections a customer made while being 
processed through a vector.

There are two types of screen pops:

● Windows application - This type of screen pop starts a Windows application, such as an 
HTML browser, a database interface, a trouble ticket program, or a custom application. 
This type of screen pop is also capable of passing parameters as part of an HTML string 
when it is initialized.

● Dynamic Data Exchange (DDE) - This type of screen pop retrieves information you specify 
from a call and passes it to a DDE server or application. The DDE server or application can 
then send information from its database or a file to an interface displayed on the personal 
computer.

This section includes the following topics:

● Creating a Windows application screen pop on page 192

● Creating a DDE screen pop on page 197

● Setting the active screen pop on page 201

● Modifying a screen pop on page 202

● Deleting a screen pop on page 203

Before you begin
Read and understand the following items before administering screen pops through Avaya IP 
Agent:

● Many DDE services have distinct features. For this reason, the complete syntax for a DDE 
query cannot be specified in this document. For information regarding your DDE service 
and how to query information from it, refer to the documentation supplied with that product.
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● User-to-User Information (UUI) is a unique identifier that is added to an incoming call 
through an external application, such as Avaya ASAI. To pass UUI, the Avaya 
communication server must have the Display UUI Information feature enabled. 
Additionally, the UUI feature does not support user-defined languages. This feature is only 
available for incoming calls, and it requires that a uui-info button is administered for the 
extension receiving the call.

Creating a Windows application screen pop 
This section provides the procedure for starting a Windows application when Avaya IP Agent 
receives an incoming call or an outgoing call is made.

Steps for creating an application screen pop
To create a Windows screen pop:

1. From the menu bar of the Avaya IP Agent window, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.

2. Select File > New.

Avaya IP Agent displays the Screen Pops wizard.

3. Enter a name for this screen pop in the text box.

4. Ensure that the Window Explorer option button is selected.
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5. Select the Next button.

Avaya IP Agent displays the Screen Pops - Trigger window.
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6. Select the appropriate call condition from the following table:

7. If you want the screen pop to start when an incoming call appears on a specific VDN:

a. Place a check mark in the Pop the screen only when the VDN is check box.

b. In the associated field, enter the VDN name (up to 15 characters) that will cause this 
screen pop to run.

If... Then...

This screen pop should be run for 
incoming calls

Select one of the following options to 
indicate when it should start:
● Ringing - The screen pop starts 

when Avaya IP Agent receives an 
incoming call.

● Answered - The screen pop starts 
when an incoming call has been 
answered through the Avaya IP 
Agent interface or by picking up the 
handset in the Telecommuter or IP 
Telephone configuration.

● Missed - The screen pop starts 
when the call appearance from an 
incoming call disappears after not 
being answered. This can be 
caused by the caller hanging up or if 
the call was routed to a voice mail 
system after a specific number of 
rings.

● Released - The screen pop starts 
when the Release button is pressed 
on a Call Information Panel (CIP) or 
when the agent hangs up the 
telephone in the Telecommuter or IP 
Telephone configuration.

This screen pop should be run for 
outgoing calls

Select one of the following options to 
indicate when it should start:
● Connected - The screen pop starts 

when the party being called answers 
the telephone.

● Released - The Screen Pop starts 
when the Release button is pressed 
on a CIP or when the agents hangs 
up the telephone in the 
Telecommuter or IP Telephone 
configuration.
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! Important:
Important: If, through Communication Manager, you assign VDN names with more than 15 

characters, you may encounter a situation where your screen pop may match 
multiple VDN names. To avoid this situation, you should not create VDN names 
longer than 15 characters.

8. Select the Next button.

Avaya IP Agent displays the Screen Pop - Action window.

9. In the field provided, enter one of the following items:

● A Uniform Resource Locator (URL) address - This refers to a Web page. This could 
also include CGI scripts, java scripts, or many other Web-enabled tools.

● A filename - This can be any filename with an extension specified in the Windows 
Registry as having an associated application that is used to open it, for example,.HTM, 
.DOC, and .TXT. If a filename is specified that does not have a valid application 
association in the Registry, Windows will display an error message.

Note:
Note: If you enter a program name in the action field, be certain to enclose the program 

name in quotation marks. Failure to include the quotes may cause the screen pop 
to fail. For example:

"C:\Program Files\Avaya\Avaya IP Agent\Notepad.exe"

10. Calls contain information that can also be included in this field as parameters of a URL 
address string. To include call information parameters with a URL string, select the arrow 
to the right of the field to display the Insert Call Data menu.

The information that may be available for retrieval from a call are:

● Called/Caller Name (%n) - Passes the name of the other party on the call, if available

● Called/Caller Number (%m) - Passes the telephone number of the other party on the 
call, if available
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● Prompted Digits (%p) - Passes the digits the caller selected while being processed 
through a vector, if available

● VDN (%v) - Passes the VDN name through which the call was connected

● UUI (%u) - Passes User-to-User-Information that was collected by the Avaya 
communication server from a centralized application

● Start Time (%s) - Passes the time when the telephone call was received by Avaya IP 
Agent

● End Time (%e) - Passes the time when the telephone call was terminated.

● Date (%d) - Passes the current date when the telephone call is received by Avaya IP 
Agent

You may also specify these parameters manually within the URL address string.

11. After entering the URL address or filename, select the Next button.

12. If you specified any parameters to be used in the Action window, you are presented with 
the Format Call Information window for each parameter. In this window, you can specify 
the number of characters or digits used for that parameter in the screen pop.

If you want to limit the number of characters presented for each parameter, do the 
following steps:

a. Enable the check box on the specific parameter screen.

b. Use the Number of characters to include and Location fields to adjust the 
boundaries of the string. 

c. After you have specified the boundaries of the parameter string, select the Next 
button.

If more than one parameter was specified in the Action dialog box earlier, the Format Call 
Information for the next parameter is presented. Select the Next button when you have 
finished configuring each parameter.

If there are no more parameters to configure, Avaya IP Agent displays the Testing dialog 
box.

13. Select the Test button to verify that the configuration of this screen pop works as intended.

If you are using parameters in your screen pop, you will be presented with another dialog 
box that allows you to enter Caller Name, Caller Number, Prompted Digits, VDN, and 
UUI as test information. Select the Continue button when all necessary test information 
has been entered in these fields.

Avaya IP Agent starts the screen pop.

14. After you have confirmed that the test of the screen pop was successful, close the screen 
pop and select the Next button on the Testing window.

Avaya IP Agent displays the Setup Completed window.
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15. Select the Finish button.

Avaya IP Agent saves this screen pop and displays it in the Screen Pops window.

Creating a DDE screen pop 
This section provides the procedure for starting a DDE screen pop when Avaya IP Agent 
receives an incoming call or when an outgoing call is made.

Steps for creating a DDE screen pop
To create a DDE screen pop:

1. From the menu bar of the Avaya IP Agent window, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.

2. Select File > New.

Avaya IP Agent displays the Screen Pops wizard.

3. Select the Dynamic Data Exchange (DDE) option button.

4. Select the Next button.

Avaya IP Agent displays the Screen Pops - Trigger window.
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5. Select the appropriate call condition from the following table: 

6. If you want the screen pop to start when an incoming calls appears on a specific VDN:

a. Place a check mark in the Pop the screen only when the VDN is check box.

b. In the associated field, enter the VDN name (up to 15 characters) that will cause this 
screen pop to run.

If... Then...

This screen pop should be run for 
incoming calls

Select one of the following options to 
indicate when it should start:
● Ringing - The screen pop starts 

when Avaya IP Agent receives an 
incoming call.

● Answered - The screen pop starts 
when an incoming call has been 
answered through the Avaya IP 
Agent interface or by picking up the 
handset in the Telecommuter or IP 
Telephone configuration.

● Missed - The screen pop starts 
when the call appearance from an 
incoming call disappears after not 
being answered. This can be 
caused by the caller hanging up or if 
the call was routed to a voice mail 
system after a specific number of 
rings.

● Released - The screen pop start 
when the Release button is pressed 
on a Call Information Panel (CIP) or 
when the agent hangs up the 
telephone in the Telecommuter or IP 
Telephone configuration.

This screen pop should be run for 
outgoing calls

Select one of the\ following options to 
indicate when it should start:
● Connected - The screen pop starts 

when the party being called answers 
the telephone.

● Released - The screen pop starts 
when the Release button is pressed 
on a CIP or when the agent hangs 
up the telephone in the 
Telecommuter or IP Telephone 
configuration.
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! Important:
Important: If, through Communication Manager, you assign VDN names with more than 15 

characters, you may encounter a situation where your screen pop may match 
multiple VDN names. To avoid this situation, you should not create VDN names 
longer than 15 characters.

7. Select the Next button.

Avaya IP Agent displays the Action window.

8. In the Action window, enter the necessary DDE information for the following fields:

● Service - A string expression that identifies an application or DDE server that can 
participate in a DDE conversation. Usually, the application argument is the file name of 
a program for a Windows-based application. Do not specify the .EXE extension of the 
program.

● Topic - A string expression that is the name of a topic recognized by the application 
argument. This will be the second parameter of the DDEInitiate() function.

! Important:
Important: Many DDE services have distinct features. For this reason, complete syntax for a 

DDE query cannot be specified in this document. For information regarding your 
DDE service, refer to the documentation supplied with that product.

9. Select which option will be used for the DDE conversation from the following list:

● Execute command - A string expression that specifies a command recognized by the 
server application. The string will only be changed to input caller information. The 
syntax must match the syntax required by the DDE program. For example, if 
embedded quotes are necessary, such as "name=""Smith""", you must enter the 
text string with all required quotation marks.
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● Poke Item - A string expression that is the name of a data item recognized by the topic 
specified by the DDE Initiate() function.

Data - A string containing the data to be supplied to the other application.

10. Enter the appropriate information in the fields for the selected option. Use the arrow button 
to the right of the Execute command or Data fields to specify information for Avaya IP 
Agent to retrieve from the telephone call and pass to the DDE conversation.

The information that may be available for retrieval from a call are:

● Called/Caller Name (%n) - Passes the name of the other party on the call, if available

● Called/Caller Number (%m) - Passes the telephone number of the other party on the 
call, if available

● Prompted Digits (%p) - Passes the digits the caller selected while being processed 
through a vector, if available.

● VDN (%v) - Passes the VDN name through which the call was connected

● UUI (%u) - Passes User-to-User-Information that was collected by the Avaya 
communication server from a centralized application.

● Start Time (%s) - Passes the time when the telephone call was received by Avaya IP 
Agent

● End Time (%e) - Passes the time when the telephone call was terminated.

● Date (%d) - Passes the current date when the telephone call is received by Avaya IP 
Agent

You may also specify these parameters manually within the string.

11. If you specified any parameters to be used in the Action window, you are presented with 
the Format Call Information window for each parameter. In this dialog box, you can 
specify the number of characters or digits used for that parameter in the screen pop.

If you want to limit the number of characters presented for each parameter, do the 
following steps:

a. Enable the check box on the specific parameter screen

b. Use the Number of characters to include and Location fields to adjust the 
boundaries of the string. 

c. After you have specified the boundaries of the parameter string, select the Next 
button.

If more than one parameter was specified in the Action window earlier, the Format Call 
Information window for the next parameter is presented. Select the Next button when you 
have finished configuring each parameter.

If there are no more parameters, Avaya IP Agent displays the Testing window.
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12. Select the Test button to verify that the configuration of this screen pop works as intended.

If you are using parameters in your screen pop, you will be presented with another dialog 
box that allows you to enter Caller Name, Caller Number, Prompted Digits, VDN, and 
UUI as test information. Select the Continue button when all necessary test information 
has been entered in these fields.

Avaya IP Agent starts the screen pop.

13. After you have confirmed that the test of the screen pop was successful, close the screen 
pop and select the Next button on the Testing window.

Avaya IP Agent displays the Setup Completed window.

14. Select the Finish button.

Avaya IP Agent saves this screen pop and displays it in the Screen Pops window.

Setting the active screen pop 
This section provides the procedure for specifying which screen pop will be set as the one used 
for incoming or outgoing calls.

Steps for setting an active screen pop
To set the active screen pop:

1. From the Avaya IP Agent main window menu bar, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.
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2. In the Name column, place a check mark next to the screen pops to use for all subsequent 
telephone calls.

It is possible to set multiple screen pops as being active if those screen pops do not 
conflict in their selection criteria. For example, if two or more screen pops are set to 
activate during a Ringing call, but are set for different VDNs, all of these can be active at 
the same time.

3. Close the Screen Pops window.

Avaya IP Agent saves this selection and uses the selected screen pops for any 
subsequent call, if applicable.

Modifying a screen pop 
This section provides the procedure for modifying a screen pop that has already been created.

Steps for modifying a screen pop
To modify a screen pop:

1. From the Avaya IP Agent main window menu bar, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.

2. Choose the screen pop that you want to modify and double-click it.

Avaya IP Agent opens the Screen Pops wizard and populates it with the data configured 
for this screen pop.
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3. For each dialog, change the necessary configuration as needed and select the Next 
button to continue for each one.

See Creating a Windows application screen pop on page 192 or Creating a DDE screen 
pop on page 197 for specific information on each window of the Screen Pops wizard.

4. When you reach the Setup Completed window, select the Finish button.

Avaya IP Agent saves the changes made to the screen pop and closes the Screen Pops 
wizard.

5. Close the Screen Pops window.

Deleting a screen pop 
This section provides the procedure for deleting a screen pop from Avaya IP Agent.

Note:
Note: Deletion of a screen pop cannot be undone.

Steps for deleting a screen pop
To delete a screen pop:

1. From the Avaya IP Agent main window menu bar, select Tools > Screen Pops.

Avaya IP Agent displays the Screen Pops window.

2. Highlight the screen pop to be deleted by clicking on it.

3. From the menu bar, select Edit > Delete.

The selected screen pop is deleted.
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4. Close the Screen Pops window.
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Chapter 11: Dialog Reference 

This section provides descriptions of the graphical interfaces used in Avaya IP Agent and their 
basic functionality. Only those interfaces not described through other sections of this document 
are described here.

This section contains the following topics:

● Main window and menus on page 205

● Avaya IP Agent option dialogs on page 222

● Login Settings dialog box on page 240

● Instant Messaging settings on page 247

● Agent Greetings settings on page 252

● Audio settings on page 257

Main window and menus 
This section describes the menus and panels in the Avaya IP Agent main window.

This section includes the following topics:

● Menu bar on page 205

● Toolbars on page 215

● Information panels on page 220

● System Tray icon on page 221

Menu bar 
The Avaya IP Agent main window provides full-function, multi-line telephony support on your 
personal computer. This window is also used to access all the features found in Avaya IP Agent.

This section defines all of the items available in the Avaya IP Agent menus. Some menus and 
menu items are available only when they are valid for your current configuration. For example, 
the Call menu is not available in an IP Endpoint configuration when a call is not currently active. 
Other menus, menu items, and buttons on the interface will be disabled when the associated 
functionality cannot be used because of configuration, call instance, or agent work mode.
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This section contains the following topics:

● File menu on page 206

● Edit menu on page 208

● Call menu on page 208

● View menu on page 209

● Agent menu on page 211

● Tools menu on page 212

● Audio menu on page 213

● Settings menu on page 214

● Instant Messaging menu on page 214

● Help menu on page 215

File menu 

The following items are available on the File menu:

● Station Login, Station Logout - These items appear as the first item in this menu. They 
are used for logging the station or agent in and out of the Avaya communication server. 
This menu item varies between these two possibilities depending on your current login 
state. These items do not appear for Avaya Callmaster VI configurations.

● Import Settings - Selecting this menu item gives you the ability to open a file containing 
settings from another Avaya IP Agent installation and apply those settings to this 
installation.

● Export Settings - Selecting this menu item saves the settings from this installation of 
Avaya IP Agent to a file. This file can then be re-imported to this personal computer or to 
another personal computer with Avaya IP Agent.
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Note:
Note: When exporting and importing settings, most name changes to features in the 

Phone Features or Personal Phone Features windows are made on a per 
extension basis. To ensure that name changes are made for all extensions, 
right-click on the feature and select the Rename (All Extensions) item from the 
resulting menu. 

Exported settings are platform-dependent. If you export Avaya IP Agent settings from 
a Windows XP personal computer, do not import the settings to a personal computer 
that uses a different operating system.

Imported and exported files include the following settings:

- All settings available in the Program Options window
- Screen pops
- Lightweight Directory Access Protocol (LDAP) settings
- Personal Phone features
- Phone features
- Abbreviated Dialing settings
- Call Center features
- Telephone button labels
- Audio settings
- Speed-dial settings

● Configuration Admin... - Selecting this item begins the Configuration Administration 
process. The contact center system administrator can use this process to define IP Agent 
Program Options features and restrictions in a *.reg registry file. The *.reg file can then be 
used to push IP Agent configurations to other PCs.

The Configuration Admin dialog is described in Configuring an IP Agent *.reg file with 
Configuration Administration on page 92.

Note:
Note: This menu item is available only to users with Feature Access privileges for 

Configuration Admin. The default is "disable access."

● Exit - Selecting this menu item closes Avaya IP Agent after making the necessary logouts 
for the agent and the extension.



Chapter 11: Dialog Reference

208 IP Agent R7 Installation and User Guide August 2007

 

Edit menu 

The following items are available on the Edit menu:

● Cut - Removes any highlighted text in the Number field and places it on the Windows 
clipboard.

● Copy - Copies any highlighted text in the Number field and places it on the Windows 
clipboard.

● Paste - Retrieves the last item placed on the Windows clipboard and places it in the 
Number field.

Call menu 

The Call menu is available only when a call is made or received.

The following items are available on the Call menu:

● Release - Terminates an active call.

● Drop - Disconnects from a call without requiring you to hang up the handset, turn off the 
speakerphone, or press the switch hook.

! Important:
Important: 6400-series telephones must have a Drop button administered on the Avaya 

communication server in order for the Drop feature in the Avaya IP Agent window 
or menus to function properly.
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● Hold - Places a call on hold until you can return to it. While the call is on hold, you can 
place another call, activate a feature, or answer another call.

● Transfer - Sends a call from your extension to another extension or outside number. Use 
this feature when the other party on the call needs to speak with someone else. There are 
three different types of transfers available.

The following types of call transfers are available with Avaya IP Agent:

- Basic Transfer - Select Transfer, dial the number on the keyboard or the Dial Pad, 
announce the call, and select Transfer again.

- Unsupervised Transfer - Select Transfer, enter the number to be called in the 
displayed dialog box, and select the OK button to transfer the call. You are not able to 
talk to the party receiving the transferred call with this type of transfer.

- Enhanced Transfer - Select Transfer, enter the number to be called in the displayed 
dialog, and select OK. You can announce the call and then, in the displayed message 
box, select OK to complete the transfer or Cancel to abort the transfer.

● Conference - Adds other parties to a call. There are two different types of conferences 
available.

The following types of call conferencing are available with Avaya IP Agent:

- Basic Conference - Select Conference which displays another call appearance. Dial 
the number of the party to add to the conference through the keyboard or the Dial Pad, 
announce the conference to the new party, and select Conference again to add the 
new party.

- Enhanced Conference - Select Conference which displays a dialog box. Enter the 
number to call in the appropriate field, and select the OK button. After you announce 
the conference to the new party, select the Yes button in the resulting message box to 
add the new party.

View menu 

The following items are available on the View menu:

● Phone Display - Enabling this item displays a panel above the status bar. This panel can 
display information from sources such as VuStats or call-prompting digits.
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● Dial Pad - Enabling this item displays a Dial Pad window, which contains a series of 
numbers and symbols resembling a telephone keypad. Use your mouse to dial numbers 
on the Dial Pad.

● Toolbars > Show Labels - Enabling this item displays labels for the buttons on the Phone 
buttons toolbar, the Agent toolbar, and the Phone features toolbar.

● Toolbars > Phone Buttons - Enabling this item displays the Phone buttons toolbar, which 
contains buttons for the Drop, Transfer, Conference, and Hold functions.

● Toolbars > Dial Number - Enabling this item displays the Dial Number toolbar, which 
provides a field for entering digits. It also contains the buttons used to access the Contact 
History feature, the Contact Directory feature, the Dial Pad, and the Search Public 
Directory feature.

● Toolbars > Audio Control - Enabling this item displays the Audio Control toolbar. Using 
this toolbar, the user can enable or disable audio transmission, audio receiving, and the 
headset. This toolbar is only available for Road Warrior (VoIP) configurations.

● Toolbars > Agent - Enabling this item displays the Agent toolbar, which an agent can use 
to change their work modes. It also contains a Login/Logout button for agents.

● Toolbars > Phone Features - Enabling this item displays the Phone features toolbar, 
which is populated with previously selected folders from the Phone Features window. 
When you select a folder on this toolbar, a list is displayed with all of the available features 
that are currently assigned to that folder.

● Toolbars > Feature Buttons - Enabling this item displays the Feature button toolbar, 
which is populated with previously selected buttons from the Phone Features window. 
Buttons on this toolbar have an associated lamp that identifies the status of the feature the 
button represents.

● Toolbars > Agent Greetings - Enabling this item displays the Agent greetings toolbar, 
which is used to select, play, and stop agent greetings that have been previously recorded. 
This toolbar is available only for the Road Warrior (VoIP) and Avaya Callmaster VI 
configurations.

● Toolbars > Headset - Enabling this item displays the Headset toolbar, which contains a 
button for answering a call or creating a new call appearance when a call is not currently 
active.

● Toolbars > Instant Messaging - Enabling this item displays the Instant Messaging 
toolbar, which contains buttons for changing your presence state and initiating an instant 
messaging to another Avaya IP Agent user.
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● Toolbars > Launch - Enabling this item displays up to 23 applications that can be 
launched from IP Agent.

● Toolbars > Configure Launch Toolbar... - Selecting this item opens the Configure 
Launch Toolbar dialog. This dialog is described in Configuring the Launch toolbar on 
page 87.

● Status Bar - Enabling this item displays the Status Bar at the bottom of the Avaya IP Agent 
main window. The Status Bar displays different types of information, such as current 
activity, notification of voice messages, the state of Avaya IP Agent, and tool tips.

● Alternate Interfaces - This menu item lists all alternate user interfaces that have been 
installed with Avaya IP Agent. The alternate user interfaces use much less desktop space 
than the default interface. See Using alternate user interfaces on page 127 for more 
information.

Agent menu 

The following items are available on the Agent menu:

● Agent Login - This item displays the Agent Login dialog box for entering your EAS Agent 
login ID number and password.

● Agent Logout - This item enables you to log out so that calls are not routed to this 
extension.

● Auto-In Mode - This is an Automatic Call Distribution (ACD) work mode. Agents in the 
Auto-In mode are available to receive new calls upon completion of the current call.

● Manual-In Mode - This is an ACD work mode. Agents must use the Manual-In feature to 
re-enter the AVAIL (Available) work mode from the AUX (Auxiliary Work) work or the ACW 
(After Call Work) work mode.

● After Call Work (ACW) - This is an ACD work mode that indicates that an agent is 
performing tasks related to the last call.

● Auxiliary Work Mode (AUX) - This is an ACD work mode that indicates that an agent is 
not available to receive an ACD call. Depending on how the ACD is administered, the AUX 
work mode can require that agents provide a reason code before the work mode can be 
assigned. Multiple Auxiliary Work buttons with different reason codes can be assigned to 
an extension.



Chapter 11: Dialog Reference

212 IP Agent R7 Installation and User Guide August 2007

 

● Assist - This item initiates a request for assistance from a skill supervisor.

Tools menu 

The following items are available on the Tools menu:

● Phone Features - Selecting this item displays the Phone Features window which, lists 
the feature buttons that have been assigned to this extension.

● Personal Phone Features - Selecting this item displays the Personal Phone Features 
window, which is used to create a smaller list of phone features that are used often or for 
ease of access.

● Contact History - Selecting this item displays the Contact History window, which 
displays a log of all calls received by this extension and instant message conversations for 
this SIP Enablement Services user ID. This log includes name, number, date, time, 
duration, notes, and can be used to access a transcript of an instant message 
conversation.

● Contacts - Selecting this item displays the Contacts or Contacts Directory window. The 
Contacts window is a simple display where contacts are listed and displayed by 
user-defined groups. The Contacts Directory window is a more detailed view of your 
contacts, which displays information such as addresses, phone numbers, e-mail 
addresses, and other information. You can switch between these views by selecting the 
appropriate option under the View menu of the respective windows. See Using the 
Contact Directory on page 149 for more information. 

● Speed Dial Numbers - Selecting this item displays the Speed Dial Numbers window. The 
Speed Dial Numbers window allows you to create a Speed Dial telephone number that 
does not exist in the Contact Directory. Once you create a Speed Dial telephone number 
with this method, this new entry is added to the Contact Directory and can be edited the 
same as other entries. See Administering Speed Dial from the Speed Dial Numbers 
window on page 158 for more information.

● Search Public Directory - Selecting this item displays the Search Public Directory 
window, which allows you to search Lightweight Directory Access Protocol (LDAP) servers 
by any field defined in the public directory. See Using a Public Directory with Avaya IP 
Agent on page 181 for more information.
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● Screen Pops - Selecting this item displays the Screen Pops window, which lists all the 
screen pops that are defined on this personal computer. See Screen pops on page 191 for 
more information.

● Agent Greetings - Selecting this item displays the Agent Greetings window, which lists 
all of the agent greetings that are defined on this personal computer. Agents, with the 
proper access permissions, can manage the greetings from this window. See Agent 
Greetings on page 171 for more information.

● VuStats Monitor - Selecting this item displays the VuStats Monitor window, which is used 
to view the VuStats information being sent to this extension. See Using VuStats on 
page 177 for more information.

● Program Options - Selecting this item displays the Program Options dialog box for 
Avaya IP Agent. See Avaya IP Agent option dialogs on page 222 for more information.

Audio menu 

Note:
Note: The Audio menu is not available for Callmaster VI configurations.

The following items are available on the Audio menu:

● Volume and Ringer Settings - Selecting this item displays the Volume and Ringer 
Settings dialog box. Through this dialog box, you can adjust the volume for your 
speakers, microphone, and ringer. You can also mute all sound devices and control other 
options.

● Audio Options - Selecting this item displays the Audio Options dialog box through which 
you can adjust the settings for IP audio, such as bandwidth and gain levels. This item is 
only available for Road Warrior configurations.

● Audio Monitor - Selecting this item displays the Audio Monitor dialog box, which 
displays the audio levels currently used for your microphone and speakers. This window 
also displays information for your VoIP connection. This item is only available for Road 
Warrior configurations.

● Tuning Wizard - Selecting this item runs the Tuning Wizard, which queries the personal 
computer for the optimal settings for Voice-over-IP and playing agent greetings. This item 
is only available for Road Warrior and Telecommuter configurations.
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Note:
Note: Access to Audio Options, Audio Options, and Tuning Wizard menu items can 

be restricted using the Tools > Program Options > Feature Access option, and 
selecting the Disable Access - Restrict the user from accessing this feature 
checkbox for each feature. Restricting access to the Audio Tuning Wizard does 
not affect the situation where iClarity determines that a tuning session must be 
performed.

Settings menu 

Note:
Note: The Settings menu is displayed only for Callmaster VI configurations

The following items are available on the Settings menu:

● Phone Configuration - Selecting this item downloads the PASTE data from the Avaya 
communication server to the Avaya Callmaster VI unit.

Instant Messaging menu 

The following items are available on the Instant Messaging menu:

● IM Preferences - Selecting this item displays a dialog box that allows you to adjust many 
instant messaging aspects, such as notification alerts, privacy, and history.

● Send a message - Selecting this item displays a dialog box that allows you to enter the 
instant messaging address. After you have entered an address, you can send an instant 
message to that user.
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● My Presence Status- Selecting this item allows you to change your instant messaging 
presence state to one of those appearing in the subsequent menu.

● IM Wizard - Selecting this option displays the Instant Messaging Setup Wizard, which 
allows you to configure the Instant Messaging feature. You can only select this item if you 
are not currently logged in to SIP Enablement Services.

Help menu 

The following items are available on the Help menu:

● Contents - Selecting this item displays the table of contents for Avaya IP Agent online 
help.

● About Avaya IP Agent - Selecting this item displays the About dialog box which provides 
product information for Avaya IP Agent.

Toolbars 
This section provides descriptions and additional information on the toolbars of the Avaya IP 
Agent window. Toolbars contain buttons that provide quick access to specific commands and 
tools. Toolbars can be added or removed from the main window by selecting each one in the 
View menu on page 209.

This section contains the following topics:

● Toolbar locations on page 216

● Phone buttons toolbar on page 216

● Dial Number toolbar on page 216

● Agent toolbar on page 217

● Agent greetings toolbar on page 217

● Phone features toolbar on page 218

● Feature button toolbar on page 218
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● Audio Control toolbar on page 218

● Headset toolbar on page 219

● Instant Messaging toolbar on page 219

● Callmaster toolbar on page 219

Toolbar locations 

Each toolbar can be moved to any location in the main window.

To move a toolbar:

1. Move the mouse pointer on the far-left side of the toolbar until the mouse pointer changes 
its appearance to the resizing icon.

2. Click and hold the left mouse button.

3. Drag the toolbar to the necessary location. The toolbar will change positions as you move 
it over different areas of the main window.

4. When the toolbar is correctly positioned in its new location, release the left mouse button.

Phone buttons toolbar 

The Phone buttons toolbar provides quick access to the basic phone buttons: Hold, Drop, 
Transfer, and Conference.

The Transfer and Conference buttons provide drop-down lists that allow the agent to select the 
type of transfer or conference to make.

Dial Number toolbar 

The Dial Number toolbar contains the Number field for entering telephone numbers to dial. 

Additionally, this field can be used to enter the first characters of a name from the Contact 
Directory. If the first character of the string entered in this field is a letter, the title of the field will 
be changed from Number to Name. When you enter a partial name in this field and press the 
Enter key or click the telephone button on the right side of the field, a list is displayed with all 
entries in the Contact Directory that match the string of characters. 
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For example, entering Sm in the field and pressing the Enter key could display a pop-up menu 
with the following entries in the Contact Directory:

This field will search for entries only in the Contact Directory. It cannot be used to search a 
public directory (LDAP).

This toolbar also contains the following features that you can access with a single click:

● Dial Pad window

● Contacts/Contact Directory window

● Speed Dial drop-down list

● Speed Dial Numbers window

● Contact History window

● Recent call drop-down list

● Search Public Directory window

Agent toolbar 

The Agent toolbar provides buttons for agent login and logout, as well as agent work modes for 
Avaya communication servers with Expert Agent Selection (EAS).

Note:
Note: If multiple Auxiliary Work buttons with differing reason codes are assigned to this 

extension, an arrow is displayed to the right of the Aux Work button. When you 
select this arrow, a menu that lists all of the Auxiliary Work reason codes is 
displayed. Select the appropriate reason code from this menu.

Agent greetings toolbar 

The Agent greetings toolbar lets you select, play, and stop greetings. This toolbar is only 
available for Road Warrior (VoIP), Telecommuter (with Avaya Switcher II), and Avaya 
Callmaster VI configurations. For this toolbar to be available, you must be logged in as an agent 
and have the appropriate feature buttons assigned to this station. See Configuring the Avaya 
communication server on page 33 for more information on which buttons are necessary.
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Phone features toolbar 

The Phone features toolbar can display one or more folders from the Phone Features window. 
When you click a button in this toolbar, Avaya IP Agent displays a list of the items contained 
within the associated folder. 

To display items on this toolbar, open the Phone Features window, right-click on the folder that 
you want to display, and select Display on Toolbar.

Note:
Note: This toolbar can support a maximum of seven buttons.

Feature button toolbar 

The Feature button toolbar can display one or more items from the Phone Features window. 

To display items on this toolbar, open the Phone Features window, right-click on a feature that 
you want to display, and select Display on Toolbar.

Note:
Note: This toolbar can support a maximum of seven buttons.

! Important:
Important: During station administration, if you delete a Phone Feature button from the 

Feature button toolbar, the entire Feature button toolbar will be deleted. To rebuild 
the toolbar, choose Tools > Phone Features and select File > Rebuild All to 
refresh phone features and rebuild the Feature button toolbar, Phone feature 
toolbar, and Personal Phone Features. 

Audio Control toolbar 

The Audio Control toolbar allows control of the following items:

● Microphone status and volume

● Speaker status and volume

● Ringer status and volume control

This toolbar is only available for Road Warrior (VoIP) and Avaya Callmaster VI configurations.
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Headset toolbar 

The Headset toolbar contains a button used to toggle the headset or handset on and off hook.

Note:
Note: If this station has been set as a 606A1 phone type on the Avaya communication 

server, this button may not function properly in the Telecommuter configuration.

Instant Messaging toolbar 

The Instant Messaging toolbar contains the following controls:

● Start IM Session - Selecting this button to display a dialog box, in which you can enter the 
user name of another Instant Messaging user. After you had entered the user name, an 
Instant Message Session window is displayed.

● Presence - Select this button to display a popup menu, which allows you to change your 
instant messaging presence state.

Callmaster toolbar 

Note:
Note: This toolbar is only available for Callmaster VI configurations.

The Callmaster toolbar contains the following controls:

● Microphone - Select this button to mute the microphone on the Callmaster VI headset.

● Volume control - Select this button to display a slider control that allows you to adjust the 
volume of audio heard through the headset.

● Headset - Select this button to enable or disable the Callmaster VI headset.

Launch toolbar

The Launch toolbar contains the icons of up to 23 applications that can be launched from IP 
Agent. This toolbar is customizable by following the instructions in Configuring the Launch 
toolbar on page 87.
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Information panels
This section contains descriptions and information on the areas of the main window that display 
information to the user.

There are three different types of panels in Avaya IP Agent, which are described in the following 
topics:

● Call Information Panel on page 220

● Agent Information Panel on page 220

● Phone Display Panel on page 220

Call Information Panel

Avaya IP Agent displays the Call Information Panel (CIP) only during incoming and outgoing 
calls. It provides information about the call, such as call status, call display, call duration. It also 
displays an Answer/ Release/ Reconnect button. 

If a call is currently active and the other party is listed in the Contact Directory, that name is 
displayed in the CIP instead of the information passed from the ACD.

The call status, incoming, outgoing, or on-hold, is displayed in the first section. Right-click the 
CIP to display a pop-up menu containing available options for this call, such as hold, transfer, 
and conference.

The timer in this panel displays the amount of time that has elapsed for a call and the work done 
in a subsequent non-active work mode, such as ACW. When an agent enters Auto-In or 
Manual-In mode, the timer is reset to 0.

Note:
Note: To disable the call timer, see How to remove the call timer on page 283.

Agent Information Panel 

Avaya IP Agent displays the Agent Information Panel when agent status information is available 
and no calls are currently active. If you are logged in as an agent, the status information also 
includes the current agent work mode.

Phone Display Panel 

The Phone Display Panel is a 40-character display that is located above the Status Bar. This 
display area is updated automatically with call-related and non-call-related information from the 
Avaya communication server, such as call-prompting digits, VuStats data, and the local date 
and time display from the ACD. Only those telephone types that are capable of displaying 80 
characters are compatible with this feature. See Compatible telephone types for Avaya IP 
Agent on page 24 for compatible telephone types.
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System Tray icon 
The Avaya IP Agent System Tray icon is an easy way to access commonly used features and to 
change your agent work mode.

To display the System Tray icon menu, right-click the icon.

If you are not logged in as an agent, the work mode entries in this menu will not be displayed.

Placing calls through the System Tray icon

You can use two methods to place a call using the Avaya IP Agent System Tray icon:

● Highlight dialing - Highlight a telephone number in any application. Then, when you 
right-click the System Tray icon, selecting the item at the top of the menu will automatically 
dial the highlighted number.

● Clipboard dialing - If you highlight a telephone number, right-click the selection, and select 
Copy, that number is saved to the Windows clipboard. Then, if you right-click the Avaya IP 
Agent System Tray icon, the top item of the resulting pop-up menu will display the 
telephone number that you copied to the clipboard.

Highlighted 
telephone
number

Avaya IP Agent
System Tray icon

dialing item
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Both of these methods allow for calling telephone numbers with letters, such as 
1-866-GO-AVAYA.

Call handling with the System Tray icon

The Avaya IP Agent System Tray icon can also be used to access common telephone 
functionality, such as placing a call on Hold.

To use the capability, you must be on a call when you right-click the System Tray icon.

Avaya IP Agent option dialogs 
Use the Program Options dialog box to configure the many feature areas of Avaya IP Agent. 
Select Tools > Program Options... to display this dialog box.

This section contains descriptions for the following panels of the Program Options dialog box:

● General Settings panel on page 223

● ACD Agent panel on page 226

● Call Handling panel on page 227

● Contact History panel on page 228

● Call Information Display panel on page 229

● Desktop Integration panel on page 230

● Database Options panel on page 231

● User Interface Options panel on page 232

● External Number Format panel on page 233

● Event Logging panel on page 235

● Greetings Options panel on page 236

● Voice Message Number panel on page 237
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● Phone Settings panel on page 238

● Feature Access panel on page 239

General Settings panel 

The General Settings panel contains the following items:

● PASTE Feature Access Code - This feature is used for Avaya Callmaster VI 
configurations. Use this field to enter the PC Application Software Translation Exchange 
(PASTE) code for an Avaya Callmaster VI unit. This code, which is found on the Avaya 
communication server, allows the Avaya Callmaster VI unit to translate information sent 
from the Avaya communication server and relay that information to Avaya IP Agent.

● Enable automatic login - This feature is only available for Road Warrior, Telecommuter, 
IP Telephone, and Avaya Telephone configurations. When this check box is enabled, 
Avaya IP Agent attempts to register with the Avaya communication server when started. It 
will use the information that was last used for a successful registration with the Avaya 
communication server.

● Enable support for auto-answer - When this check box is enabled, Avaya IP Agent 
automatically connects an incoming call without requiring the agent to pick up the handset 
or select the Answer or headset buttons on the main window. For this functionality, the 
auto-answer feature on the Avaya communication server must be assigned to this 
extension. After activating support for auto-answer, you must restart Avaya IP Agent.

● Handle voice call request from other programs - When this check box is enabled, 
Avaya IP Agent intercepts requests from other applications on the personal computer to 
begin a call and functions as though the call was started through Avaya IP Agent.
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● Enable Instant Messaging Feature - When this check box is enabled, Avaya IP Agent 
allows you to register with SIP Enablement Services as an instant messaging user during 
the station login process.

Note:
Note: If you upgraded IP Agent to R7 from IP Agent R6, and this check box was 

enabled in R6, you must re-enable the field in R7.

● Enable software update using HTTP - When this check box is enabled, Avaya IP Agent 
reads the configuration file in the location specified in the Address field for program 
updates. The configuration file is a file that redirects Avaya IP Agent to the location of the 
current update. This file can be created in any ASCII text editor or you can use the 
configuration file provided on the Avaya IP Agent software download package. If an update 
for Avaya IP Agent is found, it is installed.

! Important:
Important: The Enable Software Update feature requires the active user’s Microsoft 

Windows profile to have administration privileges.

The default filename is IPAgentUpdateInfo.txt. However, you may rename this file 
and enter the name of the new file in the Address field. This feature uses only Uniform 
Resource Locator (URL) or IP addresses that can communicate information by using the 
Hypertext Transfer Protocol (HTTP). The following example displays the format of the 
configuration file, including optional entries [Update] and [Report]:

Note:
Note: This feature does not support Universal Naming Convention (UNC) or local 

directory paths. For example, \\servername\resource\filename or 
file:///c:\temp\filename are not supported.

- The Version entry is mandatory. This entry specifies the version of the available 
update. Avaya IP Agent compares the current version of the application against the 
version listed in the configuration file. If the version in the configuration file is later than 
the version of Avaya IP Agent being used on the personal computer, Avaya IP Agent 
reads the location specified in the PathToUpdate entry.

- The PathToUpdate entry is optional. This entry specifies the URL or IP address 
where the Avaya IP Agent update is available. If a location is not specified in this entry, 
Avaya IP Agent searches the directory containing the configuration file for 
AvayaIPAgent.exe.

[Update]
Version=7.0.4.57
PathToUpdate=http://myserver:80/setupfolderpath/setup.exe

[Update]
NewCfgAddress=http://myserver:80/newconfigfolderpath/IPAgentUpdateInfo.txt

[Report]
Address=http://myserver:80/reportfolderpath/report.asp
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- The NewCfgAddress entry is optional. This entry specifies the URL or IP address 
where another configuration file is located. If the other configuration file is found, 
Avaya IP Agent uses the information in this file rather than the information in the 
previous configuration file. Using this feature eliminates the need for the administrator 
to visit each installation and make the change manually. When Avaya IP Agent is 
redirected to another configuration file, the location and filename are overwritten in the 
Program Options. When Avaya IP Agent is restarted, it will attempt to open the new 
configuration file instead of the old one.

- The Address entry is optional. This entry is used by Avaya IP Agent to send 
information to a Web page following an upgrade. This information can then be viewed 
by an administrator to determine which personal computers have applied the latest 
Avaya IP Agent update. For example, following an update, Avaya IP Agent could send 
the following string to a Web page for entry into a database, such as an .ASP Web 
page:

The Address entry is used to prefix the string of fields and data.

If you require assistance in creating a Web page for this feature, you can contact the 
Avaya Professional Services Organization for information and pricing regarding 
available services.

! Important:
Important: If Internet Explorer, iClarityAdmin, Bluetooth Integrator or the Log Collection tool 

are running when the update is attempted, the update will fail.

http://server.company.com/
report.asp?pcname=MYPC&station=5551212&agentid=1000&version=4.0.1.5&lastup
date=Failed&date=01/01/2003&time=12:00:00 PM
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ACD Agent panel 

The ACD Agent panel contains the following items:

● Configure program for EAS agent support - When this check box is enabled, Avaya IP 
Agent supports the Expert Agent Selection (EAS) feature for Avaya communication 
servers. Otherwise, Avaya IP Agent supports a non-EAS environment. EAS environments 
use skills and non-EAS environments use splits.

● Prompt for agent ID and password during agent login - When this check box is 
enabled, Avaya IP Agent displays a dialog box when an agent requests a login to the 
Avaya communication server. The dialog box prompts the agent for agent ID and 
password.

● Save agent password during agent login - When this check box is enabled, Avaya IP 
Agent saves the password of an agent after a successful login.

● Automatically log into the ACD - When this check box is enabled, Avaya IP Agent 
attempts to automatically log the agent in to the Avaya communication server after 
successful extension registration.
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Call Handling panel 

The Call Handling panel contains the following items:

● Call Transfer - Use Basic Transfer - Selecting this option sets the default transfer mode 
to the basic method.

● Call Transfer - Use Unsupervised Transfer - Selecting this option sets the default 
transfer mode to the unsupervised method.

● Call Transfer - Use Enhanced Transfer - Selecting this option sets the default transfer 
mode to the enhanced method.

● Call Conferencing - Use Enhanced Conference - Enabling this check box sets the 
default conferencing mode to the enhanced method. Otherwise, Avaya IP Agent uses the 
basic conferencing mode.

Note:
Note: The default transfer mode in this panel is changed if you select a different transfer 

mode from the main window. For example, if you set Use Basic Transfer in this 
panel, but select to use an Enhanced Transfer from the main window, Use 
Enhanced Transfer is now set as the default in this panel.
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Contact History panel 

The Contact History panel contains the following items:

● Log incoming calls - When this check box is enabled, Avaya IP Agent makes a record of 
all calls received at this station in the Contact History log.

● Log outgoing calls - When this check box is enabled, Avaya IP Agent makes a record of 
all calls made from this station in the Contact History log.

● Months to keep calls in log - Use this field to specify the number of months for which 
records are stored in the Contact History log.

● Number of recent calls displayed - Use this field to specify the number of records that 
are displayed when you click the Contact History quick list on the Dial Number toolbar.

● Clear history - Selecting this button clears all records from the Contact History log.
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Call Information Display panel 

The Call Information Display panel contains the following items:

● Display call information on the title bar during a call - When this check box is enabled, 
Avaya IP Agent displays information about the active call in the title bar of the main 
window.

● Replace call information with contact directory entry - When this check box is 
enabled, Avaya IP Agent uses the information from the Contact Directory if the telephone 
number for the active call is found. If the telephone number for the active call is not found, 
the call information from the Avaya communication server is displayed.

● Display call information using Japanese font - When this check box is enabled, Avaya 
IP Agent displays all information in Japanese. This feature is available only if the Japanese 
version of Avaya IP Agent was installed.

● Enter the size of the font to be used to display call information on Call Information 
Panel - Use this field to select the point size of the font that Avaya IP Agent uses to display 
call information in the Call Information Panel on the main window.
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Desktop Integration panel 

The Desktop Integration panel contains the following items:

● Highlight dialable numbers in Microsoft® Internet Explorer windows - When this 
check box is enabled, telephone numbers that appear in a valid format in Internet Explorer 
will be highlighted in yellow. You can then place the mouse cursor over the highlighted 
telephone number and click it for Avaya IP Agent to automatically dial that number.

Note:
Note: You must restart Internet Explorer to activate Desktop Integration.
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Database Options panel 

The Database Options panel contains the following items:

● Directory: - This field displays the current location of the database (Agent.mdb) that 
Avaya IP Agent uses to store the entries for the Contact History log and the Contact 
Directory. 

Note:
Note: If you want to change the location of the program database, you must copy the 

database to the new location before changing this setting.

● Default - If you have previously changed the location of the database, you can select this 
button to change the location back to the default location that was set at application 
runtime.

● Change... - Select this button to specify a different location for the Avaya IP Agent 
database (Agent.mdb).

● Enable program database backup - If you want to Avaya IP Agent to automatically save 
a copy of the program database, place a check mark in this check box.

● Days between backups - Use this spin control to specify the number of days between 
backups of the program database.
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User Interface Options panel 

The User Interface Options panel contains the following items:

● Always display the main window on top - When this check box is enabled, Avaya IP 
Agent always appears in the foreground of your Windows desktop, in front of all other 
application windows. 

Note:
Note: This option is disabled in Windows Vista. It appears disabled on the panel. 

● Display tooltips for toolbars - When this check box is enabled, tooltips appear when the 
mouse cursor is placed over buttons on the toolbars of the main window.

● Display letters on the dialpad - When this check box is enabled, the Dial Pad displays 
the letters that correspond to the numbers on the number pad of a telephone.

● Display the Shortcut icon in the system tray - When this check box is enabled, the 
Avaya IP Agent icon is displayed in the System Tray on the Windows task bar.

● Incoming Calls - Display the main window for incoming calls - When this check box is 
enabled and a call is received, the main window is displayed in front of any other 
application windows that are currently open.

● Incoming Calls - Flash window for incoming calls - When this check box is enabled, 
the title of the main window in the task bar flashes when a call is incoming. This behavior 
resembles selection and de-selection of the window.
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External Number Format panel 

Note:
Note: The three controls in this panel are automatically disabled if you have set your 

dialing properties for the United States. The controls are only available for those 
countries outside of the United States.

For countries outside the United States, information must be provided in this panel 
regarding the format of telephone numbers within the country. Using this panel, you 
can set the maximum and minimum length of telephone numbers used within the 
country, including city codes. This information determines when the code for another 
country should be added to a telephone number so that the number can be stored in 
the correct format.

The External Number Format panel contains the following items:

● Maximum number of digits in city code - Specify the number of digits that are dialed for 
telephone numbers that use a code to identify a city.

● Minimum number of digits in phone number, including city code - Specify the fewest 
number of digits that can be used to dial an external call. This number should also include 
the code used to identify a city.

● Maximum number of digits in phone number, including city code - Specify the largest 
number of digits that can be used to dial an external call. This number should also include 
the code used to identify a city.
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Internal Dial Plan panel

The Internal Dial Plan panel allows support for multiple internal dial plans. Dial plans of more 
than five digits are available only through MultiVantage or Communication Manager systems. 
When any of these check boxes are enabled, Avaya IP Agent treats a dialed number consisting 
of the selected number of digits as an internal extension.

! Important:
Important: For a phone number to be correctly reformatted and stored in the application 

database, the enabled dial plan option must be set prior to accepting or 
generating calls or creating contact phone numbers.
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Event Logging panel 

The Event Logging panel contains the following items:

● Enable logging for IP Agent - When this check box is enabled, all associated program 
activity is recorded. Avaya support personnel use this information to determine the cause 
of any problems with Avaya IP Agent.

! WARNING:!

WARNING: Restrict Event Logging may limit the ability for Avaya Services to diagnose an 
issue with your system. If you do not enable Event Logging, make sure that Event 
Logging can be enabled at the time of calling in a trouble ticket.

● View Log - Select this button to display the Avaya IP Agent log file.

● Monitor - Select this button to display the Events Monitor window. This window displays 
all Avaya IP Agent events that are recorded with the logging feature. This window displays 
information only if the Enable logging for IP Agent check box is enabled.

Note:
Note: You should enable recording of event logs only if they are requested by Avaya 

technical support personnel.
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! WARNING:!

WARNING: If you do restrict the logging for technical support , it may limit the ability for Avaya 
Services to diagnose your issue. If you do decide to "lockdown / restrict" this 
utility, make sure that the feature can be unlocked at time of calling in a trouble 
ticket.

Greetings Options panel 

The Greetings Options panel contains the following items:

● Location field - This field displays the path where Avaya IP Agent stores agent greetings 
for the Road Warrior, Telecommuter (with Avaya Switcher II), and Callmaster VI 
configurations.

● Default - Select this button to change to the location that was set during installation.

● Change - Select this button to open a browse window where you can select the directory 
where Avaya IP Agent uses and stores agent greetings. You can store agent greetings on 
the local personal computer or in a network location.

Note:
Note: If you have recorded agent greetings in another location, those greetings will not 

be moved if you change the location.
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Voice Message Number panel 

The options on this dialog determine what action is taken when you click the voice message 
icon in the System Tray or on the main application status bar.

Note:
Note: This icon is displayed only when voice messages exist for an extension.

The Voice Message Number panel contains the following items:

● Do nothing - Avaya IP Agent does not initiate any action when you click the icon.

● Dial this number - Select this option and provide a telephone number or extension to dial 
in the associated field. When you click the icon, Avaya IP Agent dials the number in this 
field.

● Use Application - Select this option and provide the path and filename of an executable 
program file for Avaya IP Agent to run when you click the icon.

● Goto URL - Select this option and provide a Uniform Resource Locator (URL) address 
that will be opened when you click the icon.
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Phone Settings panel 

Note:
Note: The Phone Settings panel is only visible for Callmaster VI configurations.

The Phone Settings panel contains the following items:

Headset
● Off - Select this button to deactivate the Callmaster headset. When the headset is 

deactivated, you cannot use it for calls. Deactivation of the headset is primarily used in the 
process of recording agent greetings.

● On - Select this button to activate the Callmaster headset.

● Volume - Use this slider control to adjust the volume of the audio output heard through the 
headset.

Ring
● Pattern - Use this field to select one of the eight distinctive audio signals that notify you 

when a call is waiting to be answered.

● Volume - Use this slider control to adjust the volume of the Callmaster ringing pattern.

● Test - Select this button to cause the Callmaster to ring according to the current settings in 
the Pattern and Volume fields.
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Feature Access panel 

! Important:
Important: In order for the Disable Modification feature to function properly, an 

administrative password must be set through the Set Password button. If a 
password is not set, the Disable Modification check box can have a check mark 
placed in it, but it cannot restrict users from modifying any options because a 
password must be used for validation.

Use the Feature Access panel to restrict users from administering or making changes to the 
various features of Avaya IP Agent. When any changes are made to these feature areas, you 
must restart Avaya IP Agent for these restrictions to take effect.

The Feature Access panel contains the following items:

● Feature List - Each of the Avaya IP Agent areas listed in this box can be protected from 
modifications. To select a feature area, click on the feature in this list.

● Disable Access - When this check box is enabled, users are restricted from accessing the 
specified feature panel. This option is reinforced for the Program Options feature by 
setting the administrative password. When access to a feature is disabled, the feature 
does not appear in the menus on the menu bar of the main window.

Note:
Note: If Program Options access is disabled, then Configuration Admin access must 

also be disabled.

● Disable Modification - When this check box is enabled, users cannot alter the feature.

● Disable Selection - When this check box is enabled, users cannot activate a screen pop 
by double-clicking it in the Screen Pops window.
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● Set Password/Enter Password - Select this button to display the Change Password... 
dialog box. When you enter a password, the options for the Feature Access dialog box 
cannot be changed until the proper password is entered.

! Important:
Important: Once Disable Access to Program Options is enabled and an administrative 

password is set, re-enabling access to Program Options can only be done via 
regedit or the use of an external script update.

Note:
Note: The Event Logging panel is always available, even if you have restricted access 

to all features. In this manner, agents can activate logging without administrator 
intervention. You should need to record event logs only if they are requested by 
Avaya technical support personnel.

Login Settings dialog box 
Use the Login Settings dialog box to specify the necessary data for Road Warrior, 
Telecommuter, IP Telephone, Avaya Telephone, and Instant Messaging configurations. This 
dialog box is accessed by pressing the Settings button on the Login window that is used to 
register with an Avaya communication server.

This section contains the following topics:

● Login tab on page 241

● Call Server tab on page 242

● IM tab on page 243

● Audio tab on page 244

● Emergency tab on page 245

● Advanced tab on page 246

Note:
Note: If you are using the IP Telephone configuration, only the Login tab will be 

displayed.
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Login tab 

The Login tab of the Login Settings dialog box contains the following controls:

● Extension - The extension number used in conjunction with Avaya IP Agent.

● Password - The numeric password associated with the specified extension number.

● Remember password for next login session - When this check box is enabled, the 
Login window retains the password used to register this extension number with the Avaya 
communication server. If you are concerned about the possibility of unauthorized persons 
assuming this identity, leave this check box blank.

● Automatically login if possible when application restarts - When this check box is 
enabled, logging in to the Avaya communication server is attempted automatically when 
Avaya IP Agent is started.

● Dialing Location - Specify the dialing configuration that Windows should use when 
making telephone calls. For example, an agent using a notebook computer may have one 
configuration that dials 9 for an outside line when in the office, and a separate 
configuration that does not dial 9 when the notebook computer is used in other locations.

● Properties - Select this button to display or modify the configuration specified in Dialing 
Location list.
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Call Server tab 

The Server tab of the Login Settings dialog box contains the following controls:

● Primary Server Address - This field contains the domain name or IP address of the 
Avaya communication server that this extension will connect to.

● Alternate Server Addresses - This list box is automatically populated after registration of 
the Avaya communication server, specified in the Primary Server Address field, 
completes successfully. If communication with the primary Avaya communication server 
fails after Avaya IP Agent successfully registers with it, Avaya IP Agent attempts to use the 
other Avaya communication servers in this field.

● Number of alternate servers - This area displays the number of communication servers 
that are available in the Alternate Server Addresses field.

● Add - This button allows manual addition of an Avaya communication server to the list of 
alternate Avaya communication servers.

● Remove - Select this button to remove the currently highlighted communication server in 
the Alternate Server Addresses list. Removing an Avaya communication server from the 
list in this manner affects only the current Avaya IP Agent session. If you log off from the 
Avaya communication server or shut down Avaya IP Agent and then reconnect, this list of 
alternate server addresses is again refreshed from the list kept on the Avaya 
communication server.
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IM tab 

The IM tab of the Login Settings dialog box contains the following controls:

● User Name - Enter the SIP Enablement Services user name that will be used for instant 
messaging at the personal computer.

Note:
Note: The user name is case-sensitive. It must match the user name that was defined 

on SIP Enablement Services.

● Password - Enter the password associated with the user name.

● Remember password for next login session - Enable this check box if you want Avaya 
IP Agent to retain the password for this user name.

● Server Address - Enter the IP Address or domain name of the SIP Enablement Services.
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Audio tab 

The Audio tab of the Login Settings dialog box contains the following controls:

● Road Warrior (Voice over IP) - Select this option to specify that both the data channel 
and the voice channel are routed through the personal computer using Internet Protocol.

● Bandwidth Setting - Select the rate at which data is transmitted and received in the Road 
Warrior configuration.

● Telecommuter - Select this option to specify that the data channel is routed through the 
personal computer using Internet Protocol and that voice communications are conducted 
through a telephone.

● Telephone at - Enter or select the telephone number through which voice communications 
are to be conducted.



Login Settings dialog box

IP Agent R7 Installation and User Guide August 2007 245

 

Emergency tab 

The Emergency tab of the Login Settings dialog box contains the following controls:

● Enable Emergency Call Handling feature - When this check box is enabled, Avaya IP 
Agent notifies the Avaya communication server that this endpoint supports this feature and 
that emergency calls placed from this endpoint should transmit the specified telephone or 
extension number to emergency services.

● Your extension number - Select this option if you want your extension number to be 
transmitted to emergency services personnel when an emergency call is made.

● Telephone number - Select this option if you want a specific telephone number to be 
transmitted to emergency services personnel when an emergency call is made. Enter the 
telephone number in the associated field. See Configuring the Emergency Call Handling 
Service on page 102 for more information regarding this feature.
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Advanced tab 

The Advanced tab of the Login Settings dialog box contains the following controls:

● Use the following IP address (as displayed by the VPN client) - Select this option if you 
need to replace the IP address of this personal computer with a different IP address so 
that transmissions from this personal computer are recognized by the VPN. The VPN 
information must be provided before registering with the Avaya communication server.

Note:
Note: The IP address cannot be 0.0.0.0.

● Choose from the following port range to communicate with the server - When this 
check box is enabled, Avaya iClarity IP Audio will use the port range that you specify in the 
associated fields. This feature is used to restrict the Avaya iClarity IP Audio to a limited 
range of ports with which to communicate through a network firewall. Avaya iClarity IP 
Audio uses the UDP and TCP/IP protocols in association with this range.

Note:
Note: The range specified must cover a range of at least 100 ports.

● Lowest port number - Enter the lowest port that Avaya iClarity IP Audio will use. The 
minimum for this field is 1025.

● Highest port number - Enter the highest port that Avaya iClarity IP Audio will use. The 
maximum for this field is 65535.
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Audio Port Range Administration 

On the Avaya communication server, use the UDP Port Range fields on the IP Network 
Region administration screen to configure the port selections for an IP endpoint.

Prior to administering the audio port range values, you must set the IP network region with 
which the endpoint will be associated. See the documentation for your Avaya communication 
server for information on network regions.

It is important that the intersection of the audio port ranges set for Avaya iClarity IP Audio and 
for the Avaya communication server overlap by at least 100 ports. In the event that the overlap 
is less than 100, the range reported by the Avaya communication server is ignored.

For example, if the port range is set to 51000-51100 and the Avaya communication server 
reports an audio port range of 50950-51005, then the overlap is 5 and Avaya iClarity IP Audio 
ignores the range reported by the Avaya communication server.

Note:
Note: The Avaya communication server may require that you enable ports 1719 and 

1720 on your firewall for proper communication.

Instant Messaging settings
The Instant Messaging Preferences dialog box allows you to configure this feature in many 
ways.

This section contains the following topics:

● Alerts tab on page 248

● Privacy tab on page 249

● Status tab on page 250

● History tab on page 251
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● Responses tab on page 252

Alerts tab

The Alerts tab contains the following controls:

● Alert when - Highlighting one of the entries in this list box displays the available alert 
methods in the Alert by box. You can be notified of the following instant messaging 
events:

- When an instant message is received - The selected notification actions in the Alert 
by box are performed when another Avaya IP Agent user sends you an instant 
message.

- When a contact comes online - The selected notification actions in the Alert by box 
are performed when an Avaya IP Agent user in your Contact Directory changes his 
or her state to Online.

- When a contact goes offline - The selected notification actions in the Alert by box 
are performed when an Avaya IP Agent user in your Contact Directory changes his 
or her state to Appear Offline or logs off from the SIP Enablement Services.

● Alert by - Placing a check mark next to an alert method will cause Avaya IP Agent to 
perform that notification when the highlighted event in the Alert when box occurs. Not all 
alert methods are available for all instant messaging events. The following list describes 
the available notification actions:
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- Showing a message by the system task bar - When the selected instant messaging 
event in the Alert when box occurs, Avaya IP Agent displays a small information 
message box above the Windows System Tray. This message box displays the user 
name of the instant messaging user from your Contact Directory and the event that 
occurred.

- Playing a sound file - When the selected instant messaging event in the Alert when 
box occurs, Avaya IP Agent plays a sound file on your personal computer.

- Displaying the IM session window with the first incoming message - If this alert 
method is enabled, an Instant Message Session window is displayed when another 
Avaya IP Agent user sends you a text message. This text message is displayed in the 
window.

Privacy tab

The Privacy tab contains the following controls:

● Allow all users to send me instant messages and view my online status - Selecting 
this option allows all other Avaya IP Agent users to send instant messages to you and see 
your current presence state.

● Block the following users from sending me instant messages and viewing my online 
status - Selecting this option allows you to block other Avaya IP Agent users from sending 
instant messages to you or seeing your current presence state.

● Add - Select this button to add an Avaya IP Agent user to your list of blocked instant 
messaging user names.

● Remove - Select this button to remove the highlighted user name from the list of blocked 
instant messaging users.
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Status tab
.

The Status tab contains the following controls:

● Allow Avaya IP Agent to automatically change your status to "On the phone" when 
you are on the phone - Enable this check box to have your presence state changed to On 
the phone when you receive a call through Avaya IP Agent.

Note:
Note: If you use the Telecommuter mode and place a call through your telephone 

instead of Avaya IP Agent, your presence state will not change.

● Allow Avaya IP Agent to automatically change your status to "Away" when you are 
idle more than - Enable this check box to have your presence state changed to away 
when you have not used the keyboard or mouse for the amount of time specified in the 
minutes field.

● Minutes field - Use this field to set the amount of time that you must not provide keyboard 
or mouse input for Avaya IP Agent to set your presence state to Away.
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History tab

The History tab contains the following controls:

● Enable Instant Messaging History - Place a check mark in this check box to have Avaya 
IP Agent record all messages that are exchanged between you and all other users through 
instant messaging.

● Path - In this field, provide a path where the message database will be located. In the IP 
Agent R7 Controlled Desktop environment, you cannot chnage this field.

Note:
Note: If you change the location of this database, your previous message history will not 

be migrated to the new location.

! Important:
Important: You should not have multiple users storing instant messaging databases in the 

same location.

● Browse - Select this button to display a window that allows you to select an existing folder 
on your personal computer as the location in the Path field. You can also create a new 
folder in this window and set it as the location in the Path field.
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Responses tab

The Responses tab contains the following controls:

● Enable IM responses on incoming calls - Place a check mark in this check box to have 
Avaya IP Agent place a response icon on the Call Information Panel for calls to or from 
other instant messaging users.

For example, if you are on a telephone call and another instant messaging user tries to call 
you, an instant messaging icon is displayed on the new call appearance. If you click this 
icon, you can select a predefined response from a popup list. This response is sent to the 
instant messaging user trying to call you, notifying that user why you are not answering 
their call.

● Present Responses - Place a check mark in one or more responses to make them 
available when you click the instant messaging icon on a Call Information Panel.

● User defined responses - If you want to have additional responses to select from, enter 
the necessary text in these fields. Once you have entered text into these fields, you can 
then place a check mark in the associated check box to make them available.

Agent Greetings settings 
The Agent Greetings dialog boxes are used to configure a single agent greeting. Through 
these settings, you configure the criteria that will cause this agent greeting to be played.
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This section contains the following topics:

● Greeting Description settings on page 253

● ANI settings on page 254

● VDN settings on page 255

● Prompted Digits settings on page 256

Greeting Description settings 

The Greeting Description dialog box contains the following controls:

● Greeting - Enter the title of this Agent Greeting.

● Description - Enter text in this field to provide more information for this agent greeting, 
such as purpose or usage.

● Auto-play only for Agent ID - If this option is selected, this agent greeting is played for 
incoming calls only if the currently logged in agent ID matches the ID entered in the 
associated field to the right of this option button.

● Auto-play only when an agent is logged in - If this option is selected, this agent greeting 
is played for incoming calls only if the agent is logged in to the ACD.

● Auto-play greeting for all incoming calls - If this option is selected, this agent greeting is 
played for all incoming calls, even if the agent is not currently logged in to the ACD.

● Auto-play only in active agent mode - If this check box is enabled, this agent greeting is 
played only if the agent is in the Auto-In or Manual-In work mode.
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ANI settings 

The ANI (Automatic Number Identification) dialog box contains the following controls:

● Auto-play only for this ANI - When this check box is enabled, this agent greeting is 
played only if the ANI string contains the digits that you specify in the accompanying field 
to the right of this check box.

● Partial Matching - When this check box is enabled, this agent greeting is played if the 
digits in the Auto-play only for this ANI field appear anywhere within the ANI string.

● Look for the digits from the - If you enable the Partial Matching check box, you must 
also select the location in the ANI string where the digits are to be found. For example, if 
you select the Left option, the digits specified in the Auto-play only for this ANI field must 
be the first digits in the ANI string.

● Starting at - This field is displayed only if the Look for the digits from the field is set to 
Middle. Use this field to specify how many digits from the left side of the string should be 
ignored before attempting to match the digits specified in the Auto-play only for this ANI 
field.

The field at the bottom of this dialog box displays the current settings and how those settings 
are applied in the comparison of an ANI string.
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VDN settings 

The VDN dialog box contains the following controls:

● Auto-play only for this VDN - When this check box is enabled, this agent greeting is 
played if the VDN on which the call is received matches the string in the associated field to 
the right of this check box.

● Partial Matching - When this check box is enabled, this agent greeting is played if the 
digits in the Auto-play only for this VDN field appear anywhere in the VDN string.

● Look for the digits from the - If you enable the Partial Matching option, you must also 
select the location in the VDN string where the digits are to appear. For example, if you 
select the Right option, the digits specified in the Auto-play only for this VDN field must 
match the final digits in the VDN number for this agent greeting to be played.

● Starting at - This field is displayed only if you set the Look for the digits from the field to 
Middle. Use this field to specify how many digits from the left side of the string should be 
ignored before the system attempts to match the digits specified in the Auto-play only for 
this VDN field.

The field at the bottom of this dialog box displays the current settings and how those settings 
are applied in the comparison of a VDN string.



Chapter 11: Dialog Reference

256 IP Agent R7 Installation and User Guide August 2007

 

Prompted Digits settings 

The Prompted Digits dialog box contains the following controls:

● Auto-play only for these prompted digits - When this check box is enabled, this agent 
greeting is played if the digits entered by the caller during vector processing match the 
digits in the associated field.

● Partial Matching - When this check box is enabled, this agent greeting is played if the 
digits in the Auto-play only for these prompted digits field appear anywhere within the 
string of prompted digits.

● Look for the digits from the - If you enable the Partial Matching option, you must also 
select the location in the prompted digits string where the digits can be found. For 
example, if you select the Middle option, the digits specified in the Auto-play only for 
these prompted digits field must be present in the string, at the position specified in the 
Starting at field, for this agent greeting to play.

● Starting at - This field is displayed only if the Look for the digits from the field is set to 
Middle. Use this field to specify how many digits from the left side of the string should be 
ignored before the system attempts to match the digits specified in the Auto-play only for 
these prompted digits field.

The field at the bottom of this dialog displays the current settings and how those settings are 
applied in the comparison of the string of prompted digits.
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Audio settings 
This section provides descriptions of the Audio Options and Audio Tuning Wizard dialog 
boxes. Both of these dialog boxes are available for Road Warrior (VoIP) configurations. The 
Telecommuter configuration uses only the Audio Tuning Wizard dialog box.

This section contains the following topics:

● Audio Options dialog box on page 257

● Audio Monitor dialog box on page 259

● Volume and Ringer Settings dialog box on page 260

● Audio Tuning Wizard on page 261

Audio Options dialog box 

The Audio Options dialog box contains the following items:

● Headset or Handset - Select this option button if you are using a headphone or a handset 
to speak to and hear the other party on a call. This option button is disabled if the Audio 
Tuning Wizard identifies a half-duplex sound card in your personal computer.

● PC Microphone and PC Speakers - Select this option button if you are using a 
microphone and personal computer speakers to speak to and hear the other party on a 
call. 

- Automatic Acoustic Echo Cancellation - This feature is not available in this release 
of iClarity.
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● Half-Duplex Sound Card - Select this option if you have a half-duplex sound card in your 
personal computer. This option button is disabled if the Audio Tuning Wizard identified a 
full-duplex sound device in your personal computer. If you are using Avaya IP Agent in the 
Road Warrior (VoIP) configuration, it is highly recommended that you use a full-duplex 
sound device for maximum audio quality. A list of supported sound devices is available on 
the Internet at http://support.avaya.com.

● Bandwidth Setting - Select how your personal computer connects to the Avaya 
communication server. Avaya IP Agent uses the bandwidth setting to determine which 
codec to use with the Avaya communication server. This field contains the following 
options:

- 28800 bps or faster modem - For a 28800 bps or better mode connection, the G.723 
codec may be used. This codec is used for low-speed connections.

- Cable, xDSL or ISDN
● G.729a - Use this codec for mid-speed connections.

● G.723 - Use this codec for low-speed connections.

- Local Area Network
● G.711 u-law (CCITT u-law) - Use this codec for high-speed connections.

● G.711 A-law (CCITT A-law) - Use this codec for high-speed connections.

● G.729a - Use this codec for mid-speed connections.

● G.723 - Use this codec for low-speed connections.

● Jitter Buffer - Displays the size of the jitter buffer, which stores packets to ensure a 
consistent delivery of voice to your speakers or headset so that the voice stream you hear 
does not contain gaps. The larger the jitter buffer, the longer the delay receiving audio from 
the other party. Generally, a maximum of 200 milliseconds is considered acceptable. 
Avaya recommends that you use the Automatic setting so that Avaya iClarity IP Audio 
changes the setting as necessary. If this setting does not provide adequate audio quality, 
contact Avaya technical support for assistance.

! Important:
Important: Do not disable the jitter buffer or set the jitter buffer to none. This will cause 

problems for any Voice-over-IP communications.

● Receive Gain - Use the slider control to set the gain for incoming sound during a call. The 
default value is 1.00.

● Transmit Gain - Use the slider control to set the gain for outgoing sound during a call. The 
default value is 0.25.

● Audio Receive Clarity - Enter a value to adjust the quality of incoming sound during a 
call. The default value is 1. If you experience popping and clicking noises with the audio 
received through Voice-over-IP, you should increase this value. This value can range 
between 1 and 100. You should use the lowest possible value that eliminates the quality 
problems. Increase the value by 1 until the problem no longer occurs.

http://support.avaya.com
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● Always use this value - Enable this check box if you do not want Avaya iClarity IP Audio 
to automatically adjust this value through the Audio Tuning Wizard.

● Comfort Noise - Sets whether you want Avaya iClarity IP Audio to generate noise when 
the other party is not speaking. This noise indicates to you that the call is still active.

● Restore button - Select this button to use the values for the settings that were present 
when this dialog box was opened.

● Reset button - Select this button to set all values to the default product values.

Note:
Note: You cannot restore or reset settings while you are logged in to the server.

Audio Monitor dialog box 

The Audio Monitor dialog box displays the current statistics for your Voice-over-IP (VoIP) 
communications. These statistics are available only during an active call. If the quality of your 
VoIP communications degrades, use this dialog box to determine which areas are problematic 
and which settings in the Audio Options dialog box should be changed.

The Silence Suppression Enabled check box allows you to reduce the total number of 
packets that are sent through your VoIP connection. When this feature is enabled, Avaya IP 
Agent will not transmit audio when you are not speaking.
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Volume and Ringer Settings dialog box 

The Volume and Ringer Settings dialog box contains the following items:

● Playback
- Volume - Use this slider to adjust the volume for all sound output through your 

personal computer speakers or headphones.
- Mute - Enable this check box to eliminate all sound output through your speakers or 

headset.

● Sidetone
- Volume - Use this slider to adjust the volume of your voice as heard through your 

headset or personal computer speakers.
- Mute - Enable this check box to eliminate hearing your own voice through your 

headset or personal computer speakers.

● Record
- Volume - Use this slider to adjust the volume of all sound transmitted through a 

microphone to your personal computer.
- Mute - Enable this check box to eliminate sound being sent to your personal computer 

through the microphone.

● Ringer
- Volume - Use this slider to adjust the volume of the sound that is played through your 

speakers or headset that occurs when you receive an incoming call.
- Mute - Enable this check box to eliminate any sound that indicates an incoming call.

● Play ringing through the internal PC speaker - Enable this check box to play the sound 
associated with an incoming call through the speakers of your personal computer and your 
headset simultaneously. If your personal computer does not have an internal speaker, this 
option will have no effect.
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Audio Tuning Wizard 
The Audio Tuning Wizard is a feature that detects the hardware and software settings for your 
personal computer. It will also have you test the levels for your microphone and speakers for 
optimum performance. See Initializing IP Endpoint configurations on page 110 for information 
and descriptions for the Audio Tuning Wizard interface.
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Appendix A: Shortcut keys 

This section contains quick reference information for shortcut keys.

Shortcut keys refer to key combinations that you can use to invoke a particular command. For 
example, to place a call on hold, you can press Ctrl + H. Some of the most commonly used 
shortcut keys are shown in this section. In order for shortcut keys to work as documented, the 
Avaya IP Agent window must have focus as the current application.

Shortcut key functions
This section contains the shortcut keys that can be used when the Avaya IP Agent is the 
currently selected window on your desktop. These shortcut keys are divided into the following 
categories:

● Call features on page 263

● Agent features on page 264

● Avaya IP Agent features on page 264

● Windows features on page 265

Call features 

To... Press...

Place a call on hold Ctrl + H

Transfer a call Ctrl + T to dial the number and then again 
to transfer the call

Conference another party Ctrl + F to dial the number and then again 
to conference the call



Appendix A: Shortcut keys

264 IP Agent R7 Installation and User Guide August 2007

 

Agent features 

Avaya IP Agent features 

To... Press...

Log in Ctrl + Ins

Log out Ctrl + Del

Change to After Call Work (ACW) mode Ctrl + W

Change to Auxiliary Work (AUX) mode Ctrl + A

Change Available mode assignment to automatic (Auto-In) Ctrl + I

Change Available mode assignment to manual (Manual-In) Ctrl + M

Request supervisor assistance (Assist) Ctrl + S

Mark an event log entry Ctrl + E
Use this key combination 
to place an identifier on a 
line in the event log. This 
can be used to indicate 
when you notice a 
problem. This feature is 
only available when the 
event logging feature is 
enabled.

To... Press...

Display the Call menu for an incoming call Alt + C

Display the Contact History window Alt + H

Display the Contact Directory window Alt + D

Display the Search Public Directory window Alt + S

Display online help F1

Exit Avaya IP Agent or close the current active window Alt + F4
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Windows features 

View the Properties of the selected item in the Search 
Public Directory, Screen Pops, or Contact Directory 
windows.

Alt + Enter

Change the view from the Avaya IP Agent main window to 
the last-used alternate user interface

Ctrl+U

To... Press...

To... Press...

Alternate between running applications Alt + Tab

Cut selected text to the clipboard Ctrl + X

Copy the selected text to the clipboard Ctrl + C

Paste clipboard contents to the selected area Ctrl + V
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Appendix B: Language support

This section contains quick reference information for supported languages.

Untranslated components
The following Avaya IP Agent components are provided only in English:

● Installation

● Event log

● Avaya IP Agent internal files

● Shortcut keys

● readme.txt file 

● Uninstall program

● iClarity Administration tool (iClarityAdmin.exe)

Supported languages for Avaya IP Agent
The following languages are supported with Avaya IP Agent:

● English (US)

● Italian

● French

● German

● Portuguese (Brazilian)

● Spanish

● Japanese

● Korean

● Chinese (Simplified)

● Dutch
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● Russian

The English version of Avaya IP Agent can be installed on supported operating systems using 
the languages specified above. Other language versions of Avaya IP Agent can be installed 
only on supported operating systems using that language. For example, the German version of 
Avaya IP Agent can be installed only on supported operating systems using German.
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Appendix C: Troubleshooting 

This section contains information used for troubleshooting problems with Avaya IP Agent. It is 
divided into the following topic areas so that it is easy for you to locate the information that you 
need:

● Diagnostic log files on page 269

● Login on page 270

● Voice-over-IP on page 274

● Making and receiving calls on page 278

● Other on page 280

● Alternative solution possibilities on page 283

Diagnostic log files
In the event an unhandled exception occurs in IP Agent, two log files will be generated in the 
<application data>\Log Files folder. If IP Agent is installed into the default directory, the log 
files will be found in:
C:\Documents and Settings\<user>\Application Data\Avaya\Avaya IP Agent\Log Files 

The following table describes the generated log files:

Filename Contents

Diagnostic_(mm-dd-yyyyhh.mm.ss).dmp1

1.  The mm-dd-yy hh.mm.ss value indicates the local system time when the exception occurred. Use the 
timestamp to pair the Diagnostic and Module List files together.

The captured binary mini-dump file generated 
when an unhandled exception occurs in the 
Avaya IP Agent application.

Module_List_(mm-dd-yyyy hh.mm.ss).txt Ascii text file which includes summary 
information regarding the unhandled exception 
and a version listing of the modules loaded at 
application runtime.
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Login 
This section lists those problems associated with registering with the Avaya communication 
server and logging in as an agent.
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Problem What to do

Cannot register with the Avaya 
communication server.

Check for a valid configuration:

● Avaya IP Agent has limited support for 
firewalls and Virtual Private Networks 
(VPN). See Advanced tab on page 246 
for more information on configuring 
Avaya IP Agent for use with VPNs.

● An Avaya communication server earlier 
than DEFINITY R10 cannot be used for 
Avaya IP Agent. MultiVantage and 
Communication Manager servers are 
fully supported.

● Ensure that the network connection 
from the personal computer is 
operating normally.

● Ensure that the integrated firewall 
feature of Windows XP is disabled. If 
this feature is enabled, iClarity IP Audio 
cannot function properly.

Agents cannot log in to EAS. Ensure that the following administration 
items have been addressed:

● Feature Access Codes are 
administered.

● If you are using a Road Warrior (VoIP) 
configuration, ensure that an IP Media 
Processor has been properly 
configured so that Road Warrior (VoIP) 
configurations can operate properly. 

● If the Avaya communication server has 
the station set for Auto-answer, ensure 
that Avaya IP Agent has the Enable 
support for auto-answer option 
enabled in the Program Options 
window. 

● Ensure that the station is configured for 
an AUX button. Without this button, 
agents cannot log in correctly if the 
Avaya communication server is 
configured so that agents must enter 
AUX work mode when logging in to 
EAS.

You changed your login extension but the 
Avaya communication server does not 
recognize your login.

Restart your personal computer and 
attempt the login procedure again.
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The phone download for the Avaya 
Callmaster VI failed.

Enter the PASTE code again for the Avaya 
Callmaster VI so that the Avaya 
communication server sends the updates 
to the station. Select Tools > Program 
Options and enter the number in the 
PASTE Feature Access Code: field.
Note: Avaya communication servers can 
transmit only eight PASTE downloads 
simultaneously. To ensure that you do not 
encounter this download failure in the 
future, agents in the contact center should 
leave Avaya IP Agent running after logging 
off when shifts are completed.

The agent does not seem to be logged in 
because all of the icons are still disabled.

Verify the following configuration items:

● On the Avaya communication server, 
verify that the station has the following 
work mode features assigned to 
buttons. If these buttons are not 
assigned to the station, Avaya IP Agent 
cannot enable the work modes on 
Agent toolbar:
- Auto-in or Manual-in
- After Call Work (ACW) (optional)
- Auxiliary Work (AUX). 

● On the Avaya communication server, 
verify that the first AUX work mode 
button assigned to the station has a 
blank reason code or a reason code of 
0.

The agent logs in but is immediately logged 
out.

If the station or agent is administered as 
auto-answer on the Avaya communication 
server, you must activate Enable support 
for auto-answer in the Program Options 
for Avaya IP Agent. After changing this 
setting in Avaya IP Agent, you must restart 
Avaya IP Agent for the change to take 
effect. 

Problem What to do
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Agents are logged off repeatedly from EAS 
or the Avaya communication server.

● Ensure that the network is not having 
stability problems or failures in service.

● On the Avaya communication server, 
ensure that the Auto-In field for the 
agent is set to station and not aux. 
Also, ensure that the Enable 
automatic login option in the Program 
Options dialog for Avaya IP Agent is 
activated.

● If you are using Avaya Callmaster VI 
stations or emulation, a PASTE code is 
required on the Avaya communication 
server.

Agent is unable to log into the ACD in 
shared control mode.

On voice terminals which support a 
headset button, ensure that the headset 
button is selected prior to attempting an 
ACD login.

Problem What to do
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Voice-over-IP 
This section lists those problems that are associated with Road Warrior (VoIP) configurations.

Problem What to do

Agent cannot be heard by other party. ● Ensure that a defective sound device 
or microphone is not being used.

● Ensure that the sound device is 
configured properly through Windows.

● Ensure that excessive background or 
personal computer noises are not 
preventing voice transmission.

● Adjust the transmit gain level when 
using full-duplex mode in a noisy 
environment.

● Ensure that the microphone or headset 
is not muted.

Transmit and Receive lights on the status 
bar are red.

The selected bandwidth setting cannot be 
supported. To change bandwidth settings, 
log out of the ACD and the Avaya 
communication server, select Settings 
from the Login window, and select a lower 
bandwidth setting on the Audio tab.

There is excessive bandwidth usage when 
an agent is not actively on calls.

On the Avaya communication server, 
change the Service Link Mode: for this 
extension from permanent to 
as-needed.

Agents cannot establish calls. ● Ensure that an improper codec is not in 
use.

● Ensure that the network can support 
the bandwidth required for 
Voice-over-IP.
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The voice quality of the agent is poor when 
using Voice-over-IP (Road Warrior).

● Check to see if the iClarity Status 
screen displays a high number of 
dropped packets and a low number of 
discarded packets. This indicates an 
inadequate sound device in the 
personal computer.

● Check to see if the iClarity Status 
screen displays an equal number of 
dropped and discarded packets. This 
indicates problems with network 
bandwidth.

● If the iClarity Status screen displays the 
correct information, run the Tuning 
Wizard again. The Tuning Wizard 
cannot be run while the transmit and 
receive channels are active. To 
deactivate the transmit and receive 
channels, you can either log the 
extension out of the Avaya 
communication server or change the 
extension settings from the Avaya 
communication server to use the 
as-needed option for the Service Link 
Mode field instead of permanent.

● Ensure that your personal computer 
has enough system resources to 
handle VoIP communications in 
addition to the applications being used. 
See Voice-over-IP considerations on 
page 28.

● If you are experiencing problems while 
using Internet Explorer, disable the 
Play Sounds feature of Internet 
Explorer.

The voice quality of the other party is poor 
when using Voice-over-IP (Road Warrior).

● Lower the gain setting on the 
microphone.

● Set the Jitter Buffer in the Audio 
Options dialog box to Automatic.

● Ensure that your personal computer 
has enough system resources to 
handle VoIP communications in 
addition to the applications being used. 
See Voice-over-IP considerations on 
page 28.

● If you are experiencing problems while 
using Internet Explorer, disable the 
Play Sounds feature of Internet 
Explorer.

Problem What to do
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Agent hears his or her own voice (Road 
Warrior).

Lower the Transmit Gain in the Audio 
Options dialog box.

Caller hears his or her own voice (Road 
Warrior).

Lower the Receive Gain in the Audio 
Options dialog box.

Receiving and transmitting audio is 
delayed using the Road Warrior 
configuration.

● Ensure that your Avaya communication 
server is optimized to handle “shuffling” 
and “hairpinning” for Voice-over-IP. 
Consult your Avaya communication 
server documentation for more 
information.

● Lower the Jitter Buffer in the Audio 
Options dialog box.

● If you are using the Windows Quality of 
Service (QoS) feature in conjunction 
with a firewall, the range of ports for 
QoS set up on the Avaya 
communication server must overlap the 
range of firewall ports specified in 
Avaya IP Agent by 100 ports. If these 
ranges do not overlap by 100 ports, 
QoS is not used by iClarity IP Audio, 
and transmissions are done within the 
range of firewall ports.

● Ensure that your personal computer 
has enough system resources to 
handle VoIP communications in 
addition to the applications being used. 
See Voice-over-IP considerations on 
page 28

● If you are experiencing problems while 
using Internet Explorer, disable the 
Play Sounds feature of Internet 
Explorer.

Problem What to do
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There is echo and poor voice quality while 
using Voice-over-IP (Road Warrior).

● If you are using speakers and a 
microphone instead of a headset, 
change to half-duplex in the Audio 
Options dialog box. Using separate 
speakers and a microphone can cause 
feedback.

● Ensure that your personal computer 
has enough system resources to 
handle VoIP communications in 
addition to the applications being used. 
See Voice-over-IP considerations on 
page 28

● If you are experiencing problems while 
using Internet Explorer, disable the 
Play Sounds feature of Internet 
Explorer.

You do not know how to stop the transmit 
and receive audio traffic.

● If the Service Link Mode for this 
station is set to permanent on the 
Avaya communication server, the 
transmission and receiving of audio 
over the network is inactive only when 
the agent first logs in. The first call that 
occurs for this extension will cause the 
audio traffic to begin and remain active 
until the extension is logged off of the 
Avaya communication server. 

● If the Service Link Mode for this 
station is set to as-needed, the audio 
link will become inactive 10 seconds 
after the release of a call.

The Audio Tuning Wizard does not run 
when you attempt to start it.

The Audio Tuning Wizard cannot be run 
while the audio transmit and receive 
channels are active. If you are on an active 
call, wait until the call has been completed, 
log out of Avaya IP Agent, and log out of 
the Avaya communication server. You must 
then re-register your extension with the 
Avaya communication server, run the 
Audio Tuning Wizard, and then log in as an 
agent through Avaya IP Agent.

Problem What to do
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Making and receiving calls 
This section lists problems that are associated with placing outgoing calls and receiving 
incoming ACD calls through Avaya IP Agent.

Problem What to do

Agents cannot place calls. ● Ensure that the agent is logged in.
● Check the Windows Dialing Properties 

to rule out improper number formatting. 
Dialing rules must conform to the 
dialing rules of the country in which the 
Avaya communication server resides.

● Ensure that calling cards are not being 
used.

In Telecommuter mode, picking up the 
handset does not automatically answer the 
incoming call displayed in the Avaya IP 
Agent window.

● Ensure that the Service Link 
Mode: for the station is set to 
as-needed.

● Ensure that the Enable support for 
auto-answer option is disabled. This 
option is found in the Program 
Options in Avaya IP Agent. If this 
option is enabled, disable it and then 
reboot your personal computer.

● The auto-answer feature must be 
configured in Avaya IP Agent and for 
the station definition on the Avaya 
communication server.

Attempts to conference two existing call 
appearances results in a Call could not be 
conferenced error.

This problem can occur if the event logging 
feature is enabled, a virus scan program is 
set to analyze all accessed files, and the 
personal computer has a processor that is 
slower than 1GHz. To remedy this 
situation, turn off the event logging feature.
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In the Telecommuter or IP Telephone 
configurations, the Avaya IP Agent main 
window does not display that a call is 
incoming until the second or third ring.
The main window is very slow in displaying 
the Call Information Panel for an incoming 
call.

● The processor of the personal 
computer is being used too heavily. To 
resolve this problem, close one or more 
applications to decrease the load on 
the processor.

● A virus scanning program is monitoring 
and validating the activity of the 
executable files for Avaya IP Agent and 
any log files. To resolve this problem, 
configure the virus scanning 
application to not scan the directory 
where Avaya IP Agent was installed. 
By default, this location is as follows: 
C:\Program Files\Avaya\
Avaya IP Agent
Alternatively, you can configure your 
virus scan program to scan instances 
only where program files are written to 
instead of all file types. This will 
decrease the necessity of your virus 
program to scan the log files that are 
modified in Avaya IP Agent when a call 
is received.

● Ensure that there is enough network 
bandwidth for Avaya IP Agent to 
receive the data channel information in 
a timely manner.

The call appearance remains active after 
an agent takes a call and the calling party 
hangs up.

Set Service Link Mode to "AS-NEEDED" 
rather than "PERMANENT."

The No-Hold-Conference feature button is 
not fully functional with IP Agent Road 
Warrior, Telecommuter, and Shared Control 
(via server or IP phone) configurations 
whether the system parameters SLA and 
NDT are enabled or not.
The No-Hold-Conference feature button 
works properly when dialing the next party 
with DialPad or Send TouchTone, but not 
with Dial Number. When use Dial Number 
to add the next party

When you use Dial Number to add the next 
party, you will get two call appearances 
instead of 3-way conference. You must 
then make an extra click of the Conference 
button to complete the 3-way conference.

Problem What to do
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Other 
This section lists general problems that one might encounter with Avaya IP Agent.

Problem What to do

Collected digit information is not displayed. ● You must have a callr-info button 
assigned for non-Callmaster 
telephones so that collected digit 
information is displayed. Buttons are 
configured for extensions through the 
change station command on the 
Avaya communication server.

● Ensure that VuStats is deactivated. 
This can be done by double-clicking on 
the Normal Mode button in the Phone 
Features window.

User-to-User-Information (UUI) is not being 
displayed.

On the Avaya communication server, 
ensure that the UUI IE Treatment field in 
the Trunk-Group definition form is set to 
service-provider.

User-to-User-Information (UUI) is not being 
transmitted between agents for transfers or 
conferences

Ensure that Communication Manager has 
the appropriate features enabled.

The Call Information Panel (CIP) is not 
displaying any data.

This problem can occur if you are 
emulating a phone type that is normally 
configured to display 40 characters of 
information and it is currently in use 
because of VuStats, Q-call, or if it is already 
busy with information from another 
incoming call. You can either change the 
phone type emulation to one that displays 
80 characters of information or disable 
VuStats so that the call information panel is 
not committed to displaying this 
information. See Compatible telephone 
types for Avaya IP Agent on page 24 for 
telephones that support 80 character 
displays.

In Telecommuter mode, touch-tones are 
not sent when the agent presses the 
buttons of the number pad on the 
telephone.

This situation occurs because the data 
portion of the Telecommuter configuration 
is sent through Avaya IP Agent on the 
personal computer and not the telephone. 
Use the Dial Pad or the personal computer 
keyboard to enter numbers where Dual 
Tone Multi-Frequency (DTMF) signals are 
needed.
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Avaya IP Agent is reacting slowly. The Event Logging feature of Avaya IP 
Agent can inhibit product performance. If 
you are not working with Avaya support 
personnel to solve a problem with Avaya IP 
Agent, this feature should be disabled. 
However, if you must run event logging, 
you should ensure that any anti-virus 
program is not scanning every file when 
changes are made. Your anti-virus software 
should be scanning default file extensions, 
such as .exe and .com.

The settings for one Avaya IP Agent 
installation were exported, but the import 
did not seem to work on another 
workstation.

● Ensure that you are not trying to use 
exported settings from an Avaya IP 
Agent installation on another operating 
system. Setting exports from an 
operating system, such as Microsoft 
Windows 2000, cannot be imported on 
a different operating system, such as 
Microsoft Windows XP. Also, if one 
Avaya IP Agent installation is 
configured for Avaya Callmaster VI, 
those settings cannot be imported to an 
Avaya IP Agent installation with an IP 
Endpoint configuration.

● If you are renaming items from the 
Phone Features or Personal Phone 
Features windows, you must use the 
Rename (All Extensions) option. 
Otherwise, the name change only 
occurs for the specific extension 
number.

The button feature assignments were 
changed for this extension, but the 
assignments either are not displayed in 
Avaya IP Agent or they fail to work.

Do the first item in the following list. If the 
first item does not correct the problem, 
use the subsequent items that are 
appropriate for your configuration.

● Select Tools > Phone Features from 
the main window and then select 
Rebuild All from the menu bar on the 
Phone Features window.

● Refresh the phone features for your 
Avaya Callmaster VI by selecting 
Settings > Phone Configuration from 
the menu bar.

● For IP Endpoint configurations, exit and 
restart Avaya IP Agent.

Problem What to do
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Phone Feature buttons do not work or are 
performing a different function.

If you are logging in as a different extension 
than the one that was just used with Avaya 
IP Agent, you must reboot the personal 
computer and log in again to regain these 
functions.
or
During station administration, if you delete 
a Phone Feature button from the Feature 
Buttons toolbar, the entire Feature Button 
toolbar will be deleted. 
Choose Tools > Phone Features and 
select File > Rebuild All to refresh phone 
features and rebuild the Feature button 
toolbar, Phone feature toolbar, and 
Personal Phone Features. 

The agent was in Auto-In mode, received a 
call, and selected the After Call Work 
mode. When the call was finished, the work 
mode changed back to Auto-In.

If the agent needs to use the After Call 
Work mode consistently, use the Manual-In 
work mode instead of the Auto-In work 
mode.

The agent is unable to record greetings. ● For Avaya Callmaster VI 
configurations, check to see if the 
headset button in the Agent Greetings 
window is activated. If so, click on the 
button to deactivate it and try to record 
the greeting again. The headset can 
also be deactivated through the 
headset button on the Avaya 
Callmaster VI unit. 

● For Road Warrior (VoIP) 
configurations, the recording of agent 
greetings can be done only when the 
transmit and receive audio connections 
are inactive. You can log off and restart 
Avaya IP Agent to record agent 
greetings, but the first call instance that 
occurs will once again disable the 
ability to record agent greetings.

● For Telecommuter (without Avaya 
Switcher II), IP Telephone, and Avaya 
Telephone configurations, agent 
greetings are not supported.

Problem What to do
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Alternative solution possibilities 
If the information in this section did not solve your problem, it is possible that areas other than 
Avaya IP Agent are at fault. You can investigate the following areas for solutions:

The folders in the Phone Features window 
are not in the appropriate language.

This problem occurs when multiple 
languages are installed for Avaya IP Agent. 
When first opened, the Phone Features 
window displays the names of the folders in 
the language version of Avaya IP Agent 
that is currently running. However, if you 
change to a different language version, the 
folders in this window retain the language 
used when the window was first opened. To 
reset the folders to the current language, 
select File > Rebuild All from the menu 
bar on the Phone Features window. This 
action will reset all folders and features. 
Any customization you may have made to 
feature names will be lost.

How to remove the call timer The call timer can be removed from Call 
Information Panels by editing the following 
entry in the Registry:
[HKEY_CURRENT_USER\SOFTWARE\Avaya\
Avaya IP Agent\Config\Settings]
"HideCallTimer"=dword:00000001

Fatal errors are occurring when the Call 
History window is opened.

This could be a sign that the Avaya IP 
Agent database is corrupt. To resolve this 
problem, uninstall and reinstall Avaya IP 
Agent. Any data stored in the database 
previous to this action is lost.

When Play greetings using Avaya 
Switcher II is enabled in the Audio Tuning 
Wizard, the Agent Greetings item does 
not appear in the Tools menu.

After you have enabled this feature, you 
must restart Avaya IP Agent for the Agent 
Greetings menu item to be displayed.

Avaya IP Agent stops responding when the 
USB headset is removed.

Avaya IP Agent cannot dynamically adjust 
to hardware changes in the sound system 
of your personal computer. You must not 
remove any sound devices from your 
personal computer while Avaya IP Agent is 
running.
To close this instance of Avaya IP Agent, 
use the Windows Task Manager.

Problem What to do
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● Firewall configurations

● Network configurations and available bandwidth

● Speed and available resources of the personal computer being used with Avaya IP Agent

● Problems with the Central Office (your telephone service provider)

● Network failures (WAN/LAN)

● Problems occurring in the other party’s telephone system

● VPN software problems (timeouts, configuration)

● Avaya communication server configuration problems
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Appendix D: IP Agent Bluetooth Integrator

The Avaya IP Agent Road Warrior configuration offers the optional use of a Bluetooth adapter 
and headset to allow you to answer, mute and release calls. The Bluetooth headset is capable 
of operation up to 30 feet away from the PC where the Bluetooth adapter is installed.

The Bluetooth hardware and software are not included with IP Agent R7. You must acquire 
them separately.

Note:
Note: IP Agent R7 will only work with Bluetooth headsets on Windows XP Professional 

systems.

This appendix contains the following sections:

● Before you begin on page 285

● Installing the Bluetooth Utility on page 286

● Configuring the Bluetooth Integrator on page 287

● Pairing the Bluetooth headset on page 287

● Connecting to the Avaya Bluetooth Integrator on page 288

● Configuring IP Agent on page 288

● Logging in to IP Agent on page 289

Before you begin
Avaya has tested and verified the operation of the following Bluetooth hardware and software 
with IP Agent R7:

● Plantronics 510 Voyager headset.

● D-Link DBT-120 Bluetooth adapter Revision C.

You should use the documentation that accompanies the hardware and software to familiarize 
yourself with their operation. See http://www.support.dlink.com/products/
revision.asp?productId=DBT-120 for more information. 

Note:
Note: The use of any other Bluetooth hardware or software is unsupported by Avaya 

and is done at your own risk.

http://www.support.dlink.com/products/revision.asp?productId=DBT-120
http://www.support.dlink.com/products/revision.asp?productId=DBT-120
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This appendix includes general instructions for installing and configuring the Bluetooth devices 
to work with IP Agent R7. Your specific installation may require some configuration steps not 
defined here.

Installing the Bluetooth Utility
To install the Bluetooth Utility:

1. Insert the D-Link Bluetooth 2.0 USB Adapter CD-ROM into your CD drive.

The USB Bluetooth Adapter installation screen appears.

2. Click Install Driver.
The Bluetooth Setup Settings Setup Program screen appears.

3. Click Install the Bluetooth Utility.

The Bluetooth Stack for Windows Installation Wizard screen appears.

4. Click Next.
The License Agreement screen appears.

5. Select I accept the terms in the license agreement and click Next.
The Ready to Install the Program screen appears.

6. Click Install.
The Bluetooth Stack for Windows Setup screen appears.

7. Select I accept and Click OK.

A dialog appears asking for the plug the Bluetooth adapter into an available USB port.

8. Click OK.

The Install complete screen appears.

9. Click Finish.

A dialog appears instructing you to reboot your system.

10. Reboot the system.
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Configuring the Bluetooth Integrator
The IP Agent R7 Bluetooth Integrator is installed by default during the IP Agent R7 installation 
process. If this item was deselected during the initial installation process for some reason, you 
can add the Bluetooth Integrator by following the process described in Changing or removing 
Avaya IP Agent on page 84.

To configure the Bluetooth Integrator:

1. Start the Bluetooth Integrator:

Start > Programs > Avaya > Avaya IP Agent > Avaya Bluetooth Integrator 
2. Select Start automatically at Avaya IP Agent station login.

3. Click Close.

Pairing the Bluetooth headset
To pair the Bluetooth headset with the Bluetooth Adapter:

1. Open the Bluetooth Utility by either:

- Double click the Bluetooth icon in the Icon Tray
- Start > Programs > Bluetooth > Bluetooth Settings
The Add New Connection Wizard appears.

2. Select Express Mode.

3. Put the headset into broadcast mode by holding both the "Answer" and "+" buttons until 
the red and blue lights flash alternately.

4. Click Next.
5. Select PLT 510.

6. Click Refresh.

The Bluetooth Utility will discover your headset.

7. Click Next.
The Bluetooth Security screen appears.

8. Enter the security code: 0000

9. Click Next.
A tone will sound in the headset.

10. Press the headset "Answer" button.
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11. Double click the PLT 150 icon in the Bluetooth Settings screen.

A tone sounds in the headset.

12. Press the headset "Answer" button.

The PLT 150 icon shows the "connected" symbol.

13. Exit the Bluetooth Settings window.

Connecting to the Avaya Bluetooth Integrator
To connect the headset to the Avaya Bluetooth Integrator:

1. Restart the Avaya Bluetooth Integrator.

2. Click Connect.

A tone sounds in the headset.

3. Push the headset "Answer" button.

Configuring IP Agent
The first time you use IP Agent after connecting your Bluetooth adapter and headset, you must 
configure IP Agent to recognize the new hardware.

To configure IP Agent:

1. Start IP Agent.

2. Cancel the Login dialog.

3. From the Audio menu item select Tuning Wizard.

The Audio Tuning Wizard screen appears.

4. Verify that the Bluetooth device is selected for both fields.

5. Click Next.
The playback device test screen appears.

6. Test the playback device as described on this screen.

7. Click Next.
The microphone test screen appears.

8. Test the microphone as described on this screen.
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9. Click Next.
The background sound test screen appears.

Test the background sound as described on this screen.

10. Click Next.
11. Click Finish.

Logging in to IP Agent
To login in to IP Agent:

1. From the File menu item select Station Login....
2. Select the Road Warrior configuration.

3. Click Log in.
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Glossary

Abbreviated Dial 
Feature

Allows the agent to store telephone numbers, that the agent selects, for quicker 
and easier dialing by selecting a single button. Each number can be a complete 
or partial telephone number, an extension number, or a trunk or feature code.

ACD See Automatic Call Distribution (ACD).
Active Call A call appearance state where the voice (talk) path between two parties has 

been connected.
ACW See After Call Work (ACW).
Add/Remove 
Programs

A Microsoft Windows feature that allows you to remove programs that have 
been installed on your computer. The Add/Remove Programs component is 
found in the Control Panel.

After Call Work 
(ACW)

An ACD agent work mode in which agents are performing tasks related to a 
previously completed call. In this mode, the agents are unavailable to receive 
ACD calls.

Agent A person who receives calls that are delivered from a split or skill.
Agent greetings Recorded messages played by Avaya IP Agent when a call is received by an 

agent. This feature is used to eliminate the need for an agent to repeat the 
same statement for every call.

Agent Mode An agent logs into an Avaya communication server with a specific agent ID, 
which is associated with certain assigned skills and configuration settings. Do 
not confuse this with registering as an extension with the Avaya communication 
server as an agent must first register as an extension before logging in with an 
agent ID.
Logging in as an agent enables the Agent toolbar in the main window.

Agent Skill A centrally-defined attribute that is associated with an EAS ACD agent ID, 
which represents a certain ability or assignment for that agent. An agent can be 
assigned up to 20 skills. The meaning of each Agent Skill is customizable. 
Examples of what could be considered skills are: the ability to speak a 
particular language or the expertise to handle a certain product.

Agent work mode A feature of agent call handling. Agent work modes are the different call work 
modes and call states an agent can be in (logins, logouts, After Call Work, AUX, 
and so forth). Data about these states is displayed in the history log.

Agent toolbar A toolbar that provides buttons for agent login and logout and agent modes, 
such as Auto-In, Manual-In, and After Call Work.
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Alternate 
Gatekeeper

A feature of Avaya communication servers that notifies IP endpoints of all IP 
addresses for a network region. If communication fails with an IP address on 
the Avaya communication server, Avaya IP Agent attempts to reconnect with 
another IP address within the same network region.

Alternate User 
Interface

Avaya IP Agent interfaces that use much less space on the Desktop than the 
main window.

Assist Allows an agent to request assistance (whether on an active ACD call or not) 
from the split or skill supervisor by pressing the Assist button or by putting the 
call on hold and dialing the Assist feature access code, followed by the split 
group number. The agent must be logged into the split or skill.

Auto-answer An Avaya communication server feature where calls directed to an agent are 
connected without any action required on the part of the agent. An agent can 
begin conversing with the other party without having to accept the call by 
activating a call appearance or releasing the switch hook.

Autodial A telephone feature where a single button is used to dial a complete telephone 
number.

Auto-In An ACD work mode. In the Auto-In mode, when an agent disconnects from a 
call, that agent is automatically available to receive another ACD call.

Automatic Call 
Distribution (ACD)

A method of call distribution where EAS agents are placed in groups called 
skills. An EAS agent can be logged into up to 20 skills simultaneously. EAS 
distributes calls to the extension of an agent that possesses the necessary skill.

Automatic Number 
Identification (ANI)

A service that provides the telephone number of an incoming call.

AutoPlay A Microsoft Windows feature that causes an application on a CD-ROM to run 
without any user interaction as soon as the CD-ROM is inserted into the drive.

AUX See Auxiliary Work (AUX) mode.
AUX RC See Auxiliary Reason Code (AUX RC).
Auxiliary Reason 
Code (AUX RC)

A numeric code that describes the reason for entering the AUX work mode, 
such as lunch or meetings. This Expert Agent Selection (EAS) feature enables 
a contact center to track the time of an agent more precisely. 

Auxiliary Work 
(AUX) mode

An ACD agent work mode indicating that the agent is unavailable (for example, 
observing a pre-defined period of inactivity or in training) to receive an ACD 
call.

Available An agent state in which the agent is able to accept an ACD call. This is a 
sub-state of the Auto-In and Manual-In modes.

Avaya 
communication 
server

A DEFINITY, MultiVantage, or Communication Manager system. These 
systems receive and distribute communications throughout a contact center.

Avaya IP Softphone Avaya IP Softphone is an Avaya product that enables you to log in to an Avaya 
communication server as an extension. Avaya IP Softphone does not support 
agent login and cannot co-reside with Avaya IP Agent.
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Avaya Switcher II A type of headset unit that provides connections to a telephone and to the 
soundcard of a personal computer. This headset allows you to record and play 
agent greetings in the Telecommuter mode for personal computer-based 
installations of Avaya IP Agent. (Not available in Windows Vista.) For 
information about using an Avaya Switcher II, see:
http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf

Avaya Telephone 
(DCP/IP)

An Avaya IP Agent configuration where calls are conducted through a Digital 
Communication Protocol (DCP) or Internet Protocol (IP) telephone. Avaya IP 
Agent does not take over, but shares control with the telephone. Any action can 
be done through either the physical telephone or through Avaya IP Agent. This 
configuration does not require the creation of a second extension for use with 
Avaya IP Agent.

Bandwidth The maximum number of digital bits that can pass through a communications 
channel every second. For example, Ethernet 10BaseT has a maximum 
bandwidth of 10 megabits per second.

Basic Conference A mode of joining multiple parties to the same call. Up to five parties can be 
added, for a total of six on a call. The agent selects Conference, dials the 
number through the keyboard, talks to the party, and selects Conference again. 
See also Enhanced Conference. 

Basic Transfer A transfer mode that sends the current call to another telephone number or 
extension. The agent remains on the line until the call is answered and can 
announce the call. See also Enhanced Transfer and Unsupervised Transfer.

Bluetooth Bluetooth technology provides provides the ability to answer, mute and release 
calls via a wireless headset when operating in Road Warrior (VoIP) mode.

Call appearance A call connected to an extension. Most telephone types can support multiple 
call appearances simultaneously. Each call appearance is represented with a 
Call Information Panel in the main window.

Call Information 
Panel (CIP)

A single panel (40-character display) that displays information about a single 
call, such as caller name, call duration, status icon, and control buttons, such as 
Answer/Release and Reconnect.

Call Prompting An Avaya communication server feature that routes incoming calls based on 
information entered by the calling party, such as an account number. The caller 
is prompted to select options from those listed in an announcement. See 
Prompted digits for related information.

Callmaster VI A special telephone produced by Avaya. This telephone connects to a personal 
computer through a serial cable. This telephone and telephone type (606A1) 
are fully supported by Avaya IP Agent.

Call Work Code A numeric sequence, up to 16 digits, entered by an agent that identifies the type 
of call received by the agent. These codes are user-defined and administered 
on the Avaya communication server.

CIP See Call Information Panel (CIP).

http://www.plantronics.com/media/media_resources/literature/user_guides/MX10_en.pdf
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Circuit pack Expansion modules that can be used to expand a DEFINITY, MultiVantage, or 
Communication Manager server. For Avaya IP Agent, the required circuit packs 
are related to IP communications.

Comma-separated 
values

Fields and records in a text file that are delimited by commas. This is a simple 
form of a database.

Communication 
Manager

The software used in Avaya communication servers. Communication Manager 
systems succeed and surpass DEFINITY and MultiVantage systems.

Communication 
server

A general term for Avaya DEFINITY, MultiVantage, and Communication 
Manager systems.

Conference See Basic Conference or Enhanced Conference.
Connected A trunk state in which a caller and an agent are able to converse on an ACD 

call.
Contact center A location where communications are received and placed. These 

communications can be telephone calls, e-mail, Web-based instant messaging, 
and others.

DDE See Dynamic Data Exchange (DDE).
DEFINITY ECS DEFINITY Enterprise Communications Server (ECS). The DEFINITY ECS is a 

telecommunications system that routes voice and data information between 
various endpoints, such as telephones, terminals, and computers. It provides 
highly robust networking capabilities and includes an extensive set of standard 
features, such as Attendant Consoles, Voice Processing Interface, Call 
Coverage, DS1/E1 Connectivity, Hospitality Support, Recorded Announcement, 
and Trunk-to-Trunk Transfer. It also allows for the addition of optional features 
and upgrades to the system as business needs change.

Delimited text file A file containing fields, records, and values that are separated by commas, 
tabs, semicolons, or other characters.

Dial Pad An Avaya IP Agent dialog box that displays the 12 characters available on a 
telephone.

Dial Number button A button on the Dial Number toolbar that an agent uses to go off-hook and 
initiate a dial tone or to dial the digits previously entered in the Number text 
box.

Dial Number toolbar A toolbar that provides a number text box, access to the Contact Directory, 
Contact History, Speed Dial, and Recent Calls list. When an agent enters a 
string (for example, lan) followed by Enter, a popup menu displays with a list of 
the directory entries that start with that string. If the first character of the number 
is a letter, the title of the field will be changed from Number to Name.

Dial Plan The configuration of an Avaya communication server that determines how 
extensions, external telephone numbers, and server features are contacted or 
activated. For example, a dial plan might determine that all internal extensions 
can be reached by dialing a five-digit number. Dial plans are configured through 
an Avaya communication server.
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Digital 
Communications 
Protocol (DCP)

A communication protocol used to transmit voice and data between Avaya 
telephone sets and an Avaya communication server.

DNS See Domain Naming System (DNS).
Domain For Windows networking, a domain is a subnetwork comprised of a group of 

clients and servers under common control.
For the Internet, a domain is the highest subdivision of a domain name. For 
example, .com, .org, and .net are domains.

Domain Naming 
System (DNS)

An Internet mechanism where Uniform Resource Locator (URL) addresses are 
translated to Internet Protocol (IP) addresses. For example, www.avaya.com 
translates to a series of numbers that use the format 123.123.123.123. DNS 
servers can exist inside private networks that are separated from the Internet.

Drop An agent uses this feature to disconnect from a call and place another call or to 
disconnect the last person added to a conference call.

Dynamic Data 
Exchange (DDE)

A form of communication between Windows applications that allows the 
exchange of data, information, and commands.

EAS See Expert Agent Selection (EAS).
Emergency Call 
Handling (ECH)

An Avaya communication server feature that determines the location of IP 
endpoints that place a call to emergency services, such as 911 in the United 
States.

Enhanced 
Conference

A feature that allows you to add up to six telephone numbers to a call. See also 
Basic Conference.

Enhanced Transfer A transfer option that sends the present call to another phone number or 
extension. See also Basic Transfer and Unsupervised Transfer.

Expert Agent 
Selection (EAS)

An optional Avaya communication server feature that builds on the power of the 
Call Vectoring and ACD features to send a particular call to an agent who has at 
least one of the skills that the caller requires.

FAC See Feature Access Code (FAC).
Feature Access 
Code (FAC)

A 1-to-4 digit number with an optional leading * or # that is assigned during 
Avaya communication server administration to invoke features. For example, 
*81 may invoke Service Observing Listen Only. FACs require an available call 
appearance with dial tone before the FAC can be sent to the Avaya 
communication server. Assigned FACs may not be available to all users on an 
Avaya communication server based on class of restrictions and whether the 
feature has been enabled in the Avaya communication server.

Feature button A button that can be assigned to any one of a number of Avaya communication 
server features. Feature buttons are assigned to an extension during station 
administration on the Avaya communication system.

Firewall Hardware, software, or a combination of the two that provide a boundary 
between two or more networks. Firewalls can be implemented on different 
devices with differing levels of security and access.
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Graphical User 
Interface (GUI)

An environment where icons, dialog boxes, windows, buttons, fields, and other 
controls are presented through the use of program functions supplied by the 
operating system. You can interact with the interface with a pointing device, 
such as a mouse, and, usually, the keyboard.

GUI See Graphical User Interface (GUI).
H.323 A specification that defines packet standards for multimedia communications 

over IP networks that interact with telephony networks.
Hold A feature that allows an agent to leave a telephone call without disconnecting it. 

You can return to the call at any time.
HTML See HyperText Markup Language (HTML).
Hypertext A word or series of words in a software application that can be used to access 

information through user interaction.
HyperText Markup 
Language (HTML)

A structured language used in the authoring and presentation of information. 
See also Hypertext.

iClarity IP Audio An Avaya component that provides station registration and voice/data signalling 
with an Avaya communication server.

Installation folder The directory on the personal computer that contains the Avaya IP Agent files.
Instant Messaging An application that allows users to exchange brief messages to one another in 

real time.
Internet Protocol 
address (IP address)

A unique, 32-bit (4-byte) number that identifies a computer on a TCP/IP 
network and is used in the transmission and delivery of data packets. An IP 
address is represented in four, 8-bit (1 byte) values, separated by periods. For 
example, 128.10.10.1. From left to right, each byte represents greater detail 
about the logical location within the network.

IP Address See Internet Protocol address (IP address).
IP Endpoint A telephone extension that uses IP for data signaling, voice communication, or 

both. Extensions that use the Road Warrior, Telecommuter, IP Telephone, or 
Avaya Telephone configuration are considered IP Endpoints.

IP Telephone A telephone set that uses an Ethernet connection to relay voice 
communication. This is also the name for the configuration by which control of 
the telephone is shared by Avaya IP Agent.

Jitter Buffer A data area where Voice-over-IP packets are collected and assembled for the 
purpose of playing through an audio device. Because IP packets vary in receipt 
time, the jitter buffer assists in making audio quality consistent to the listener.

LAN See Local Area Network (LAN).
LDAP See Lightweight Directory Access Protocol (LDAP).
Lightweight 
Directory Access 
Protocol (LDAP)

A network protocol used over TCP/IP networks for querying and retrieving 
information from a hierarchical directory.
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Local Area Network 
(LAN)

A private, interactive communication network through which computers can 
communicate over short distances at high data transfer rates.

Log A record of activity.
Login The process of identifying a user with a computer, device, or server so that the 

user can use resources or features. In regards to Avaya IP Agent, an agent 
must log in to the Avaya communication server to receive ACD calls.

Login ID A number and that allows an EAS agent to log in to the Avaya communication 
server. Skills and other information are assigned to the login ID of the agent.

Logout The act of a user that notifies a computer, device, or server that no further tasks 
will be performed by this user at this time and that no resources should be 
allocated for this specific user.

Manual-In An ACD work mode. In the Manual-In mode, the agent automatically enters the 
ACW mode when the agent disconnects from an ACD call. To become available 
to receive another ACD call, the agent must manually select the Auto-In or 
Manual-In mode.

Media Encryption Communications between Avaya iClarity IP Audio and the Avaya 
communication server are encoded so that the information cannot be 
deciphered by unauthorized recipients.

Microsoft Installer 
technology

Microsoft Installer technology (MSI) is designed to reduce the total cost of 
ownership (TCO) of deploying the Avaya IP Agent application by increasing the 
customers’ ability to manage and maintain application components during 
setup and runtime. 
The MSI installation database tracks which feature require one or more 
components, which files comprise each component, where each file is installed 
on the system, and where component sources are located.

MSI See Microsoft Installer technology.
MultiVantage A line of next-generation communication servers offered by Avaya. 

MultiVantage systems succeed and surpass DEFINITY systems.
Network A group of devices that are connected in such a way that data or 

communications can be transmitted and received between the devices.
Off-Hook The voice path to your telephone is active.
On-Hook The voice path to your telephone is inactive.
PC Application 
Software Translation 
Exchange (PASTE)

A feature of an Avaya communication server where data for a call is passed to a 
Callmaster VI telephone set, which can then send the data through a serial 
connection to a program, on the personal computer, that can interpret the data.

Phone display A 40-character display that is located in the status bar of the Avaya IP Agent 
main window. This display area receives information from the Avaya 
communication server so that you can see call and non-call related information, 
such as call prompted digits and VuStats.

Prompted digits One or more numbers entered by a caller that indicate responses to automated 
questions posed when the call first enters the contact center.
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PSTN See Public Switched Telephone Network (PSTN).
Public Directory A database that can be accessed through the Lightweight Directory Access 

Protocol (LDAP) protocol. A Public Directory usually contains information on 
people or personnel within some unit of organization, such as a business, 
educational facility, and so forth.

Public Switched 
Telephone Network 
(PSTN)

The worldwide voice telephone network.

Quality of Service 
(QoS)

A technology used to prioritize real-time communications over data 
transmissions. Real-time communications can include of multimedia, 
Voice-over-IP, video, and others. Some operating systems, network devices, 
and network software support QoS.

RC See Reason Code (RC).
Read-only A folder or file that can be read, but not modified, updated, or deleted.
Reason Code (RC) A numeric code that describes the reason that an agent enters the AUX work 

mode or logs out of the system.
Registry The system-wide repository of information supported and used by Windows. 
Release Disconnects the current call.
Response file See Silent install.
Right-To-Use (RTU) A licensing mechanism used in Avaya communication servers. In some 

situations, multiple RTUs can be used by a single extension so that data and 
voice signaling are supported.

Road Warrior An Avaya IP Agent configuration where calls are conducted through a personal 
computer with a sound device and a network connection by using Voice-over-IP 
(VoIP). No telephone set is required for this configuration.

Screen Pop The automatic display of information on the screen of the personal computer 
from other sources, such as databases or Web pages. Screen Pops are 
activated by triggering criteria.

Silent install A method of installing software where no graphical user interfaces are 
presented and no user interaction is required.

Skill An attribute that is assigned to an ACD Agent. Agent Skills can be thought of as 
the ability for an Agent with a particular set of skills to handle a call that requires 
one of those skills.

Softphone A software application that enables you to control telephone calls, both 
incoming and outgoing, directly from your computer, where communication is 
done through Voice-over-IP.

Split A group of extensions that receives special-purpose calls in an efficient, 
cost-effective manner. Normally, calls to a split arrive primarily over one or a few 
trunk groups.
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Station Login The process of registering as an extension of an Avaya communication server. 
With Avaya IP Agent, a station login must be completed before an agent login 
can occur.

Switch A private call-handling system providing voice-only or voice and data 
communications services, including access to public and private networks, for a 
group of terminals within a premises. See also Communication server.

System Tray The area of the Windows task bar where applications can display an icon for 
simplified access to special features. Avaya IP Agent displays an icon in the 
System Tray.

TAPI Assisted 
Dialing

Avaya IP Agent supports telephony-enabled applications, such as Microsoft 
Scheduler. This support provides the ability for telephony-enabled Windows 
applications to originate a call and have the call reflected in the Avaya IP Agent 
application.

Telecommuter An Avaya IP Agent configuration where voice communications are performed 
through a telephone and data communications are sent through the network to 
a personal computer. In this configuration, calls to an extension can be routed 
to any telephone number.

Telephone type Avaya produces many different models of telephone sets with differing 
capabilities. Each model supported by Avaya IP Agent is considered a 
telephone type. Telephone types are identified by the unique number 
associated with each model.

Toll quality A term used to compare audio quality and reliability of voice communications to 
that of telephone calls placed over the PSTN.

Toolbar A row of buttons used to activate various functions of Avaya IP Agent through 
the main window.

Tooltips Brief descriptions that are displayed when the mouse pointer is over a toolbar 
button or control in the application interface.

Transfer See Basic Transfer, Enhanced Transfer, or Unsupervised Transfer.
Unsupervised 
Transfer

A call transfer option that lets an agent send the present call to another phone 
number or extension. The agent does not talk to the party receiving the 
transferred call. See also Basic Transfer and Enhanced Transfer.

User-to-User 
Information (UUI)

A unique identifier that is added to an incoming call through an external 
application, such as Avaya ASAI.

VDN of Origin 
Announcement 
(VOA)

A short announcement that is assigned to a Vector Directory Number (VDN) 
through Avaya communication server administration. The VOA identifies the 
origin or purpose of a call for the call center agent who answers the call.

Vector On a communication server, a list of steps that processes calls according to a 
configuration set by the administrator. The steps in a vector can send calls to 
splits or skills, play announcements and music, disconnect calls, give calls a 
busy signal, prompt callers for information, or route calls to other destinations.



Virtual Private Network (VPN)

300 IP Agent R7 Installation and User Guide August 2007

Virtual Private 
Network (VPN)

A group of computers or network devices that can communicate privately and 
securely over a public IP network through the use of encryption and special 
protocols.

VOA See VDN of Origin Announcement (VOA).
Voice-over-Internet 
Protocol (VoIP)

A technology where speech is converted to a digital signal and transmitted 
through Internet Protocol packets over the Internet or an intranet.

VuStats An Avaya communication server feature that displays contact center activity 
and information on the display of a telephone set. For Avaya IP Agent, this 
information can be viewed in the status bar of the main window and the VuStats 
Monitor window.

Web Dialer An Internet Explorer plug-in that highlights telephone numbers and allows a 
user to click on these numbers to automatically dial them through Avaya IP 
Agent. This plug-in also contains a toolbar that allows a user to enter and dial 
telephone numbers through Internet Explorer.

Windows Terminal 
Server / Windows 
Terminal Services

A Windows-based server that allows client terminals, personal computers, and 
other devices to use an environment and applications supplied by the server. 
Depending on the type of client, processing and storage can take place on the 
server or the client.

Zip Tone A short dial tone that indicates that an ACD call is being connected to the agent.
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